DFPlayer - auf den Spuren der Störgeräusche (TX/RX oder MP3-Chip-IO-SDcard Kommunikation)

Ja mit Klicks und anderen Symptonen… daher war ich erstmal wieder davon ab.

Nee, ich bin ja nicht nur hier unterwegs, ich such mir meine Infos da zusammen, wo ich sie finde, hauptsächlich im Englischsprachigen. Dashier ist ja nun auch ein ziemlich monothematisaches Forum und meine Bastelinteressen sind etwas weiter gestreut. Nachdem ich feststellen musste, dass es viele Varianten gibt und die meisten irgendwelche Probleme haben, hab ich angefangen, meine Probleme zu lösen, Lösungen gefunden(nicht hier) und dann mal geschaut, ob es hier was gibt. Und tatsächlich gibt es einen aktuellen Faden, der sich mit der Grottigkeit des gehassliebten dfPlayers beschäftigt. Ein Teil, das dermaßen berüchtigt für seine vielen Fehlfunktionen ist, kann auch nen gepinnten Faden mit häufigen Problemen vertragen, und ich dachte, das hier wäre dieser Faden. Über das Umlöten dieser Brücke stand hier noch nichts. Tut mir leid, wenn ich damit jetzt keinen mords Erkenntnisgewinn in die Diskussion eingebracht habe, mir erschien es so, als handele es sich (hier) um eine neue Information.

Ja sorry, ich bin halt seit gut 25 Jahren in Foren unterwegs und wollte „mal eben“ was ich so herausgefunden habe Hier teilen. Aus mal eben wurde nix, weil der Bestätigungslink ewig nicht in meiner Inbox aufgetaucht ist, (GMX ist schuld, für Aktivierungslinks nehm ich aber nicht meine Hauptadresse) und dann geb ich mir nen Tag später mit meinem Posting Mühe und muss hinterher feststellen, dass ich es wieder kastrieren darf, dann frustriert mich das. Mir war nicht klar, dass das so gewollt ist, ich hielt es für ein Preset von discourse und ich wollte damit niemanden angreifen.

@Topic: Es erscheint mir am sinnvollsten, herauszufinden, wo brauchbare Versionen des dfPlayers herzubekommen sind, bzw die minderwertigen Quellen auszusortieren. Dann kann man sich auf eine anständige Stromversorgung beschränken und die übrigen Tricks vergessen, weil man sie nicht braucht. Ist ja auch irgendwie witzlos eine wahnsinnig kleine Platine(praktisch) zu haben um sie dann wieder mit externen Kunstschaltungen vollzukleistern, bis das Ganze dann nicht nur viel größer, sondern durch die angehäufte Komplexität auch fehleranfällig und teuer (Zeit, Material) ist.

Grüße
Mo

Ich habe einen AduinoUno nehmen müssen,weil mein Nano noch in der Post war.
es gibt keine Störgeräusche oder brummen.Der gleiche Aufbau mit dem ArduinoNano und es brummt , auch kein Masse Kontakt mit der SD-Karten Abdeckung hab auf alles geachtet.
Tausche ich den Nano gegen den Uno ist alles wieder gut.
ist das normal ?

Wie versorgt du die beiden? Über die USB Schnittstelle?
Oder bekommen DF Player und die Arduinos direkt von der Versorgung am 5V Pin Ihre Spannung?

Da fällt mir ein, ich hab doch noch ein linear Netzteil… (Wie konmte ich das vergessen :man_facepalming:) Das muss ich mal raus kramen und damit testen wie sich die Quelle auswirkt.

Ich würde nämlich behaupten das man über die USB Buchse noch Komponenten mit in den Versorgungskreis einbaut, die stören.

Mittlerweile kam meine Lieferung von AZ an. Habe nun 3 Player mit dem Chip YX5200-24S5. Merke da keinen Unterschied zu der JL-Variante. Eher sogar noch ein leises ‚Beep‘, wenn zwischen den Titeln gewechselt wird.
Hoffe mal, dass die Töne über Kopfhörer nicht so laut sind.

ja beide über USB.
Wenn das verbaut wird,über Vin 5Volt, so ist der Plan

Interessant wäre ob das Verhalten über den 5V pin das selbe ist.

ja ob über Vin oder USB an der Powerbank kein störendes geräusch,alles super.
nehme vom pc die USB buchse dann brummt es.liegt wohl am datenleiter,kann sein

Ich denke man muss die Störgeräusche am finalen Aufbau analysieren und beseitigen.

ich habe auch festgestellt das beim China nachbau vom nano gegenüber der ware von AZ die
TX und RX vertauscht sind

Schon sehr oft hier erwähnt, aber ich wiederhole es gerne nochmal: Vin benötigt 7-12V! 5V reichen hier nicht aus! 5V geht nur über USB oder den 5V Pin.

dan bekommt er über Vin 9Volt von einer Blockbatterie, das reicht auf jeden fall

Dabei muss man bedenken, das die 4V die zu viel sind irgendwo hin müssen. Das wird meistens in Wärme abgetragen.
Das würde ich vorher unbedingt testen.

1 „Gefällt mir“

ich habe auch festgestellt das beim China nachbau vom nano gegenüber der ware von AZ die
TX und RX vertauscht sind

Hast du das mal gecheckt, ob sie wirklich vertauscht sind? Ich hatte schon Platinen, da waren nur die Beschriftungen vertauscht, aber die Funktionen nicht:

8 Beiträge wurden in ein existierendes Thema verschoben: Ton stottert ab und zu?

Vor einigen Tagen kamen die bestellten MH-ET Player aus China.
Aber die sind bei mir noch schlimmer als die JL.
Das rauschen der JL haben sie nicht aber dafür ein helles fiepen.
Ich hatte auch den Eindruck, dass sich das bei längerer Laufzeit verstärkt hat.

Das kann ich bestätigen. Muss wohl am Chipsatz liegen.

For what it’s worth: Für alle Noobs wie mich die sich hier durch den Thread wühlen und sich denken: Was soll ich jetzt machen?

Mein Aufbau verwendet eine Intenso 10000S Powerbank, Arduino wird über USB Kabel mit Strom versorgt, der DFPlayer mit Chip YX5200-24SS hat keinen externen Verstärker angeschlossen, und der Lautsprecher hat 4Ohm.

Da mich das, zugegebenermaßen leise, Rauschen/Brummen des Lautspreches bzw. das schon etwas nervigere im Kopfhörer und das Fiepen nach ca. 1 Sekunde nachdem man auf Pause drückt trotzdem etwas gestört hat (meinen Sohn würde es wahrscheinlich nicht stören), hab ich mich daran gemacht mal einige EINFACHE Sachen hier im Thread auszuprobieren:

  • 1K Widerstände an RX und TX -> ändert bei mir nichts (deshalb hab ich nur wie vom „Hersteller“ empfohlen 1K am RX gelassen)
  • 10K Wiederstände an RX und TX -> Player funktioniert bei mir nicht mehr
  • Diode am VCC des Players um die Spannung von 5V auf ca 4.2V zu verringern -> macht bei mir keinen Unterschied
  • Player mit 3.3V des Arduinos versorgen -> Verursacht ein ratterndes Geräusch
  • Die GNDs des Players „kurzschließen“ (bin später draufgekommen, dass sie das über das SD Karten Gehäuse schon sind) bzw. verschiedene GND Anschlussvariationen -> hat nichts geändert (hätte ich auch nicht erwartet)
  • Nur VBus und GND vom USB Stromanschluss verwenden (die USB Datenkabel kappen, Link hab ich nicht mehr) -> keine Verbesserung
  • Versorgung über +5V - > keine Verbesserung, und RFID reader funktioniert dann nicht mehr bei mir :confused:

Ich glaube das war ziemlich alles. Im Endeffekt hab ich mir eine Kopfhörerplatine einer alten Stereoanlage (von 97/98 glauch ich) angesehen:

6 und 9 sind dabei die Ausgänge für die Kopfhörer. Ich hab die Platine dann mit Steckleisten versehen und in meinen Aufbau für die Kopfhörer und auch für den Lautsprecher integriert und siehe da: Rauschen war weg. Ich muss auch dazu sagen, dass der Lautsprecher (aufgrund des 120Ohm Widerstandes) natürlich viel zu leise war.

Da ich aber nicht die nötigen Bauteile habe (keine Spulen und keine Konsensatoren in ensprechender Dimensionierung) und ich auch keine Ambitionen habe mir diese zu besorgen oder die Platine zu verwenden bzw. die Bauteile dort zu entwenden, hab ich einfach mit Vorwiderständen und Potis experimentiert (wie auch schon hier im Thread als „Symptombekämfpung“ erwähnt). Dabei funktioniert für mich folgendes gut:

  • 10-20Ohm bei jeweils SPK+ und SPK- (der Visaton FH10HM 4Ohm Schiffsansage Lautsprecher ist dann immer noch laut genug)
  • 100Ohm bei jeweils DR und DL und 100µF Kondensatoren wie hier (ich kann mich auch nicht mit Kopfhörern über mangelnde Lautstärke beklagen)

Mit Kopfhörer höre ich zwar noch ein sehr sehr leises Rauschen und Pause-Fiepen, aber das ist zumindest für mich zu vernachlässigen. Ich bekomme auch eine gute Qualität mit aktiven Lautsprechern am Kopfhörerausgang.

Falls das schon so in etwa irgendwo hier steht, dann tut’s mir leid, dass ich es unsinnigerwise wiederholt hab, aber es war für mich etwas unübersichtlich zumindest die einfachen Informationen zusammenzutragen und vll erleichtere ich es hiermit jemanden.

PS: Noch eine lustige Anmerkung. Ich hab nach meinen Experimenten mit meinem TonUINO Aufbau bei verschiedene Audiogeräten und Kinderspielzeug zu Hause genauer hingehört. Alle haben ein gewisses Knacksen und Rauschen, etc. also vielleicht sollte man sich auch nicht zu sehr reinsteigern. ;D

4 „Gefällt mir“

Hallo in die Runde,

da mich das Thema Brummen/Störgeräusche bei der Wiedergabe auch letzte Nacht umgetrieben… und fasst in die Verzweiflung getrieben hat, ergänze ich hier einmal meine Lösung.

Bei mir war das „Brummen“ wie bei vielen anderen nur während der Wiedergabe zu hören. Meine Tochter hätte es wahrscheinlich nicht gestört, aber das „Brummen“ (oder eher laute Pulsen) war deutlich zu hören und hat mich enorm gestört - zumal mein Bruder als Toniebox-Besitzer sofort darauf rumgeritten hätte.

Somit musste das Brummen weg: Ich wollte mich schon an die SMD-Modifikationen am DFPlayer mini machen (wie von @Jost weiter oben beschrieben, Brummen aus dem Lautsprecher).

Bei mir war die Lösung aber recht einfach - und kam zufällig:
Denn alle bisherigen Tests hatte ich mit Powerbank und Stromversorgung über die MiniUSB-Buchse gemacht. Nachdem ich die Stromversorgung auf die PINs der TonUINO Platine gelegt habe, waren die Störgeräusche verschwunden… :smiley:

Vielleicht hilft es auch bei Euch

Gruß werner23

Hallo,

Bei unserer Box kommt es darauf an, welches Ladegerät angeschlossen ist. Bei manchen brummt der Lautsprecher, bei anderen gar nicht. Obwohl alle dafür geeignet sein sollten. Also ähnliche Problemlösung.