Benötige Hilfe beim Ein/Ausschalter


#1

Servus zusammen,
als Laie habe ich leider Schwierigkeiten, einen Ein/Ausschalter mit LED sinnvoll anzuklemmen.
Ich hatte einen normalen On/OFF Schalter erfolgriech im Einsatz - hier habe ich einfach + unterbrochen und gut war.

So sieht die Schaltung

Ich möchte gerne quasi mit dem Ein/Ausschalter die Stromversorgung zwischen PowerBank und Arduino steuern.
Beim EInschalten soll die LED angehen - wenn aus dann aus.

Ich hoffe jemand kann mir hier helfen und die laienhafte Schaltung für mich vervollständigen - das wäre großartig.
Es reicht vollkommen aus, wenn das einfach mit Paint-bearbeitet wird…
Ich würde bzw. meine kleine würde sich sicher riesig über Unterstützung freuen.

Besten Dank vorab


Vorstellung MedionUINO
#2

Vielleicht hilft es Dir, ich habe vom USB Kabel nur das rote Kabel(plus) getrennt. Die Verdrahtung vom Schalter, siehe Bild. Damit die LED leuchtet, wenn “AN”, muß der Anschluss von der LED auf die Masse(GND) von Thorsten´s Platine verbunden werden. Der Schalter macht genau was Du möchtest, LED “AN”, leuchtet die LED und “AUS”, leuchtet die LED nicht.


#3

Bei meiner Box war das Problem, dass sich die Box ausschaltet, wenn eine gewisse Zeit nichts abgespielt wird. De Arduino zieht vermutlich zuwenig Strom, so dass sie Powerbank (Power Add 2) keinen Strom mehr abgibt. Man muss den Ein-/Ausschalter dann nochmals betätigen.


#4

@ minnie

Habe das mal jetzt genauso gemacht, wie auf deinem Bild.
Allerdings leuchtet die LED im Schalter auch, wenn der Schalter auf Ausstellung ist.

Was mache ich falsch?

Muss die Brücke vielleicht zwischen NO und C?

Dank dir


#5

Hm, ich hab alles gelötet wie auf meinem Bild, LED leuchtet nur wenn “AN”. Vielleicht kannst du mal ein Foto machen. Ansonsten sieh Dir mal diesen Plan an.


#6

@minnie

Das braune Kabel geht auf GND der Platine.
Habe auch nur das rote Kabel des USB Kabels durchtrennt. Ein- und Ausschalten funktioniert auch. Die LED leuchtet halt nur permanent.

Danke fürs Draufschauen.

Edit: ich habe eine Vermutung. Muss ich nur noch checken.

  1. Edit: wie ich vermutet habe. Habe die roten Kabel vertauscht gehabt.

Jetzt läuft alles, wie es soll.


#7

Bin noch nicht weitergekommen…habe das wie oben auf dem Schaltbild verdrahtet - jedoch ohne Erfolg.
Ich hab fast die Vermutung mein Schalter ist defekt.
Wenn er in der Aus Stellung ist kann hab ich mit dem “Durchgangsprüfer” ein Signal zwischen NC und C.
Wenn ich den auf EIn - also einrasten lasse - habe ich nirgends mehr einen Durchgang… ?
Wo müsste er den Durchgang haben im eingerasteten Zustand ?


#8

Ich habe bei mir mit dem Durchgangsprüfer folgende Werte ermittelt:

Schalter auf AN-Stellung(gedrückt/eingerastet:)
C und N0 = Durchgang
C und NC = kein Durchgang

Schalter auf AUS-Stellung:
C und N0 = kein Durchgang
C und NC = Durchgang

Wie es Aussieht ist der Schalter defekt, wie Du bereits vermutest.

Du könnstest eine Brücke mit C und NC setzen, dann ist der Schalter bei AUS-Stellung(nicht gedückt), “AN” und bei AN-Stellung(gedrückt/eingerastet), “AUS”. Wäre eine Alternative und gewöhnungsbedürftig.


#9

welcher Schalter wurde hier verwendet? wenn es ein Raster/Schalter ist dann suvhe genau sowas auch


#10

um diesen handelt es sich


#11

Vielen Dank für eure Hilfe.
Jetzt funzt auch mein Schalter wie gewünscht


#12

Wie sieht es denn mit dem 12V schalter aus mit der Led und der selbsthaltung wenn nur 5 Volt Anliegen…

Noch kurz zur info NC steht für normal closed sprich normal geschlossen
Und NO steht für normal geöffnet bezieht sich immer auf die grundstellung


#13

Die LED leuchtet ganz normal
Kann mir vorstellen das diese bei 12v heller leuchtet
Mir reicht’s jedoch


#14

Ich habe den Schalter einmal als 12V und einmal als 5V Variante. Kann bei der Helligkeit nicht wirklich einen Unterschied feststellen. Kann aber auch dran liegen, dass die 12V Variante rot und 5V blau ist.


#15

hallo,
bin mir nicht sicher ob ich das hier, oder doch in einen eigenen Post schreiben soll…

in einem anderen Post gibt es diese Skizze mit einem drei adrigen Schalter (oder wie das auch heist :blush: )
Um diesen Schalter dreht es sich TedGem Schalter

Da ich allerdings direkt per USB Kabel anschliessen wollte, habe ich also nur ein Kabel des USB Kabels getrennt und an den Schalter geführt. An und aus funktioniert, aber der Schalter leuchtet nicht. Nun meine Frage, was mach ich mit dem goldenen Pin?Wo schliesse ich den an?
hier noch ein Bild, wie meine Verkabelung derzeit ist!

Ich hoffe jemand kann mir helfen :slight_smile:


Stromversorgung über Magnetschaltung
#16

Hey flo,

der goldene Kontakt muss an GND. Steht doch in der Skizze :roll_eyes:

Mfg DS


#17

Danke, das war natürlich die Lösung :no_mouth:
Hatte das mit drei Schaltern, in Verzweiflung, auf verschiedenste Weise getestet. Wie sich herausstellt, sind die Hälfte der Schalter defekt…:unamused: