LED anschließen

Ich würde meiner TonUINO Box gerne ein LED Lämpchen hinzufügen. Diese soll neben dem An-Schalter optisch anzeigen, dass das Gerät bereit für eine Karte ist.
Ich kenne mich mit Programmierung nicht aus. Kann mir jemand sagen, wie ich den Code erweitern muss, so dass immer ein LED leuchtet, sobald der Arduino läuft. Und an welchem Pin muss ich die LED dann anschließen?

Viele Dank

1 „Gefällt mir“

Wenn es nur das ist, schriebst du einfach in die setup() Routine:

pinMode(6, OUTPUT);
digitalWrite(6, HIGH);

Die LED kommt dann mit entsprechendem Vorwiderstand an Pin 6.

3 „Gefällt mir“

Prima danke, musste erstmal den richtigen Pin finden. Aber jetzt geht´s

Hallo, wollte mir auch eine Status LED einbauen, wo genau habt Ihr den PinMode im Code eingebaut oder kann ich den ruhig am ende vor der letzten geschweiften Klammer setzen?

Wie gesagt, am Ende von der setup() Routine vor der geschweiften Klammer. Von mir aus hier:

2 „Gefällt mir“

Danke, das hat geklappt.

hättet ihr denn einen Tipp, wo ich eine solche LED mit passendem Vorwiderstand herbekomme? Ich hab von dem Thema keine Ahnung, würde es aber auch gerne umsetzen…:wink:

Wenn du wirklich nur eine oder zwei LED mit Vorwiderstand brauchst wäre das hier zum Beispiel eine Option für dich:

Das ist zwar preislich recht teuer aber einzelne LED und einzelne Widerstände wirst du recht schwer online bekommen, evtl in einem Modellbauladen um die Ecke…

Alternativ bekommst du 100 LED und 100 Widerstände aus China für fast den selben Preis wie oben das Beispiel.

2 „Gefällt mir“

@vinyli
Danke für deine schnelle Antwort. Tschuldigung für die blöden Fragen, aber was bedeutet in deinem Beispiel mcd? Ist das die Helligkeit?

Müsste es für den Arduino dann 5V sein? Und schließe ich das rote Kabel (mit Widerstand) dann an den PIN 6 und das schwarze an GND?

Danke für deine/eure Antworten!

mcd steht für milli Candella und gibt die lichtstärke an. Ja der Arduino gibt 5V aus, kann aber den pin genauso gut auf masse ziehen also entweder das rote Kabel an dauerspannung und masse an den arduino oder genau anders rum rot an den arduino und schwarz auf Masse.

@Tammo
Kurz gesagt, Ja zu all deinen Fragen. :wink:

  • mcd steht hier für Milli-Candela, also für die Helligkeit.
  • 5V wäre für den Arduino richtig
  • das rote Kabel an (+) und das schwarze an (-) bzw GND

An welchen Pin du die LED anschließt hängt davon ab wie es in dem Sketch deklariert ist. Ich nutze die Version von @stephan und da ist es glaube Pin 6

Ich hatte anfangs eine LED ohne Widerstand angeschlossen. Das tat problemlos. Will sagen, die LED fetzt es nicht gleich raus.

Mittlerweile habe ich einen Powerbutton mit integrierter LED. (ist glaub für 12v ausgelegt) . Auch das tut problemlos und pulsiert dank Stephans code supertoll wenn mukke läuft.

Ist wohl nicht empfehlenswert:

https://www.mikrocontroller.net/topic/252997

EDIT: bitte nur die ersten paar Beiträge lesen, bevor die sich gegenseitig beschimpfen :man_facepalming:

1 „Gefällt mir“

Power Button mit LED:

Der von mir verwendete Schalter hat eine eingebaute LED mit entsprechendem Vorwiderstand.
Habe die LED direkt an den Pin 6 angeschlossen und steuer Sie über PWM an.

Hallo @ThaBasti,

geht der Anschluss der LED im Schalter an Pin 6 nur mit einem mit 5 Polen oder auch mit 3?

Ich habe diese


und frage mich, ob ich die auch über Pin 6 betreiben kann und wenn ja, wie ich die anschließen muss…

Danke!
VG
Tammo

Da steht dass der goldene Kontakt an GND muss, also bekommt die LED wohl die 5V vom Schließer. Von Vorwiderstand steht da auch nix müsstest du mal im Datenblatt gucken. Das Thema mit genau diesem Schalter gab es hier aber auch schon.

Den gleichen habe ich mir bestellt. Aber in China! Kostenpunkt 0,75€. :grimacing:

Die Schalter sind für 12V ausgelegt und haben dafür anscheinend einen Vorwiderstand integriert. Habe ich selbst nicht überprüft, funktioniert aber bei mir bisher problemlos.
Als Status LED an Pin 6 wird das zumindest out of the Box nicht funktionionieren, wenn du mit den 2 silbernen Pins V+ schaltest und der goldenen GND benötigt. Pin 6 schaltet auf HIGH (V+) …

Irgendwie will meine 5V-LED nicht…

Code ist im Setup enthalten und die LED leuchtet einfach nicht.
(https://www.ebay.de/itm/371442495231)

Habe rot an PIN 6, sprich 3 weiter nach den drei Buttons. (4 weiter habe ich auch getestet falls die erste PIN als 0 gezählt wird…)
Schwarz auf GND, sprich den drittletzten in der gleichen Reihe.

Platine 2.1 (kann ich nicht zu 100% einsehen - evtl. doch 1.51) und Tonuino DEV.

Wo ist mein Denkfehler…?

Das wäre dann ja A5 (die Buttons sind A0-A2). Du musst mit der LED an D6. Die freien D Pins sind noch weiter rechts. Also bei der Platine 1.51 der zweite Pin von rechts in der unteren Reihe ist D6. Von rechts sind da D5, D6, D7 & D8:

2 „Gefällt mir“