Probleme mit Adminkarte und Adminmenü sperren

#1

Hallo, also bei mir (Dev 2.1) geladen am 10.Mai. Funktioniert garnichts davon.
Mach ich eine Admin Karte funktioniert es, und ich komm mit dieser Kate nach wie vor ins admin Menü.
Ich lege ls Sperre fest das nur mit der karte das Menü geöffnet werden darf.
Drück ich die drei tasten dauerhaft komm ich aber trotzdem ins admin Menü .
Kann mir jemand sagen warum? ausserdem wird mein Shortcuts den ich festgelegt habe nicht dauerhaft gespeichert.funktionier ein paar mal und dann nicht mehr.

Bitte um Hilfe

Übersicht der Bedienung TonUINO
#2

Es funktioniert gar nichts? Das musst du bitte genauer beschreiben. Bitte poste auch die Konsolenausgaben während du das mit der Admin Karte testest. Da kann man dann evtl. sehen ob die Settings gespeichert werden. Beim booten z.b. sollte ersichtlich sein ob das Admin Menü gesperrt ist und wie.

PS: Spiel bitte die neuste Version auf, 10. Mai ist nicht aktuell.

#3

ok.setzt mich heute Abend nochmal hin und teste es mit der aktuellsten Version.

#4

Super, danke. Eigentlich sollte sich da nichts in der Richtung geändert haben, aber um Ergebnisse zu vergleichen ist das auf jeden Fall sinnvoll.

#5

kann halt den Arduino nicht mehr über usb im betrieb anschließen da bereits im Gehäuse verbaut :frowning:

#6

Okay, dann sollest du das Gehäuse Design überdenken. :wink: Wie macht du sonst Firmware Updates?

#7

Hallo Stephan, das ich es richtig verstehe, habe nun eine Karte konfiguriert mit Admin Funktionen.
Wenn ich nun im Menu “das Admin Menü Absichern” “nur admin Karte” auswähle dann den Vorgang mit der Pause Taste bestätige und anschließen den Tonuino ausschalte, bedeutet das, das ich wenn ich den Tonuino wieder anschalte und ins admin Menü möchte unbedingt diese adminkarte benötige und ich es nicht mehr über den Tastendruck Vor,Zurück, und Pause schaffe in das Adminmenü zu gelangen.
habe ich das richtig verstanden?

#8

So soll es eigentlich sein ja. Du kannst aber jederzeit (eine leere Karte vorausgesetzt) bei Verlust eine neue anlernen.

#9

ok.das habe ich jetzt ausgiebig mit der neusten software, (heute gedowloaded und aufgespielt) getestet.
Ich komm nach wie vor ins admin Menü wenn ich die die Drei Tasten gleichzeitig ca 4 Sekunden drücke und dann loslasse

#10

Sogar einen anderen Arduino Nano hab ich schon getestet um einen Bestückungsfehler auszuschließen.
Immer mit dem selben Ergebnis.

#11

Wie so oft: Bitte poste die Konsole, dort wird am Start angezeigt ob und wie das admin Menü gelockt ist.

#12

Wie geht das?usb anschließen und dann?
Der arduino muss dazu nicht in der Hauptplatine sein oder?

#13
#14

Jetzt weis ich immernoch nicht wo die Konsole ist und was ich machen soll.
Was wo einstecken und wo wird mir dann was angezeigt?

#15

Also ich hab es selbst auch noch nicht gemacht, aber ich vermute das es folgender Punkt der FAQ ist ;
Wo finde ich den Debugger?

  • Arduino - Tools - Serial Monitor (CTRL+Shift+M)

Ich würde den Arduino vom Akku an den Rechner packen und dann den Debugger starten und schauen was passiert…

#16

genau:

Ich hab dir mal eine Skizze gemacht:

#17

Vielen Dank Curon und Nanos.
Ich Versuch es sobald ich zuhause bin und poste einen Screenshot wenn alles klappt.

1 Like
#18

Ich habe an die FAQ noch ein Bild angefügt. Da es auf einem Linux PC entstanden ist, könnte es geringfügig anders als bei Windows aussehen, aber von Grundprinzip her ist es gleich.

Bitte kopiere den Text der Konsole hier rein und formatiere es als Codeumgebung (Schaltfläche </>)

#19

So, geschafft.das steht im Monitor:

Wie ich es interpretiere ist das Admin-Menü nicht gesperrt.
Die Frage ist warum?Habe es gerade eben eingestellt das es nur mit einer adminkarte geöffnet werden kann.

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
0
Firmware Version: 0x0 = (unknown)
WARNING: Communication failure, is the MFRC522 properly connected?
=== playShortCut()
3
Shortcut not configured!

#20

Genau.

Das ist eine gute Frage. Was mich vor allem beunruhigen würde, ist de Fehlermeldung zum MFRC522. Funktioniert dein Kartenleser?