Tonuino spielt immer nur einen Song und geht dann aus

Hallo an Euch,

ihr habt mir bei meinem ersten sehr gut weitergeholfen. Jetzt wollte ich hoch hinaus und habe einen zweite Box begonnen. Was meine Lötkompetenz angeht habe ich mich schon verbessert, allerdings spielt die Box immer nur einen Song und geht dann aus. Es gibt ein paar Patzer meinerseits. Habt ihr eine Idee woran es liegen könnte und was ich tun kann, damit es wieder funktioniert?

IMG_1134 image0 image1

Habe gerade keine Zeit um die Hardware zu analysieren…
Aber poste doch bitte noch die Konsolenausgabe (am Besten so lange bis der Tonuino aus geht). Evtl. erkennt man da den Fehler…

Bleibt der Tonuino eingeschaltet oder geht er komplett aus?
Wenn er ausgeht, geht er auch einfach so nach der Zeit aus?
Evtl. schaltet die Powerbank (welche hast du?) einfach aufgrund zu wenig Last ab.

Vielen Dank für deine Antwort!
Der Tonuino spielt ganz normal den ersten Song ab. Wenn der vorbei ist, geht die Lampe am MP3-Modul aus und in Folge dessen, schaltet die Powerbank nach wenigen Sekunden ab.
Ich benutze einen Intenso-Powerbank Xs 1000.
Beim ersten Probelauf hat die Powerbank einwandfrei funktioniert.

Den Gedanken mit der Last hatte ich auch schon. Aus diesem Grund habe ich die Powerbank von meinem ersten Versuch (Die Box funktioniert) ausprobiert. Die schaltet allerdings auch ab. :pensive:

image1

Hast du die SD Karte vom ersten für den 2. Kopiert und nutzt die gleichen Karten?

Ja. Ich habe die Karte vom ersten auf einen zweiten kopiert und jeweils mit dem Programm bereinigt benutz. Ich meine diese Tonuino-Toolbox.

Und wenn du Mal die original Karte testweise in den neuen steckst?

Wie Manu schon sagt ohne Monitor Ausgabe wird es schwierig aber so habe ich die Fehler bei meinen Boxen gesucht, wenn ich im Log nix fand… Komponenten durchgetauscht auch Karten und Speicher Medien

Es kann sein, dass Exemplarabhängig die Stromaufnahme des Arduino, DF-Players oder RFID-Reader geringfügig unterschiedlich sind. Wahrscheinlich liegt die Stromaufnahme deines Tonuino beim Abspielen gerade so im Bereich, dass die Powerbank noch nicht abschaltet. Geht der Tonuino in Pause geht die Stromaufnahme unter den Grenzwert für das Abschalten und die Powerbank schaltet sich ab. Hier hilft nur eine zusätzliche Last. Z.B. eine LED mit Vorwiderstand direkt von +5V gegen Ground. Rote LED - Vorwiderstand 330 Ohm, Grüne LED - Vorwiderstand 180-200 Ohm. Dadurch wird die Stromaufnahme um ca 10 mA erhöht. Das sollte eigentlich ausreichen.

Wie @Manu erwähnt hat wäre eine Kontrolle von der Konsole interessant.
Ich hatte ein sehr ähnliches Problem, welches ich gestern abschliessen konnte.

Beim Start zeigte es mir in der Konsole an, dass der Timer den Wert „-1“ hinterlegt hatte. Aber wenn „kein Timer“ gesetzt ist, sollte (gem. meinem Verständniss) aber „0“ sein.

Ich musste einfach einmal den Timer im Admin-Menü verändern.

Prüfe mein Artikel: Nach paar Titel - Power off!

Vielen Dank für eure Lösungsansätze! Leider weiß ich nicht, was ihr mit „Konsolenausgabe“ meint. Braucht man dafür ein extra Programm? Meint ihr den Sketch?
Als ich die alte SD-KArte eingelegt habe, ist die Box schon nach wenigen Sekunden ausgegeangen und hat das Lied gar nicht erst zuende gespielt.

Mit Konsole ist der serielle Monitor in der Arduino IDE gemeint. Zum Aufrufen klickst du das Symbol oben rechts an, das aussieht wie eine kleine Lupe. Falls dann nur Hyroglyphen angezeigt werden, musst du noch die Übertragungsgeschwindigkeit einstellen auf 115200. Der Tonuino muss über USB am PC angeschlossen sein.

1 Like

eventuell stimmt auch etwas mit den Namen der MP3s in dem Ordner nicht.

Wie Stephan schon sagte, am besten schaust du in der Konsole was er sagt, dann können wir dir sicher helfen.

Vielen Dank für eure Tipps! Hier nun die Konsolenausgabe während der Wiedergabe. Danach passiert nichts mehr. Habt ihr eine Idee, was ich tun kann? Was bedeutet wohl „Com Error 129“?

 _____         _____ _____ _____ _____
|_   _|___ ___|  |  |     |   | |     |
  | | | . |   |  |  |-   -| | | |  |  |
  |_| |___|_|_|_____|_____|_|___|_____|

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 30
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 15
Inverted Volume Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
900053
Firmware Version: 0x92 = v2.0
=== playShortCut()
3
== playFolder()
=== disablestandby()

Com Error 129
0 Dateien in Ordner 1
Album Modus -> kompletten Ordner wiedergeben
=== disablestandby()
Card UID: 14 73 7A 2B
PICC type: MIFARE 1KB
Authenticating Classic using key A...
Reading data from block 4 ...
Data on Card :
 13 37 B3 47 02 0A 02 1B 7C 00 00 00 00 00 00 00

10
10
== playFolder()
=== disablestandby()

Com Error 129
0 Dateien in Ordner 10
Album Modus -> kompletten Ordner wiedergeben

Das Problem ist höchst wahrscheinlich dieses hier, Zitat aus der #hardware FAQ:

Bitte schaut euch Immer die #hardware FAQ und die #software FAQ an. Dort sind schon viele bekannte Probleme gesammelt worden. Oder benutzt auch gerne die Suchfunktion. Das hilft auch oft weiter. :nerd_face:

1 Like

Tausend Dank! Darauf wäre ich niemals gekommen! Ich habe viel gelernt und das Problem ist gelöst.