TonUINO knackt nur nach dem Einschalten

Guten Tag,
Vorne weg mal, super Projekt! Ich liebe es.

Leider laufen meine beiden TonUINOs nicht richtig an.
Habe alles nach Plan verkabelt und hoffe das ist richtig so.

Leider knacken beide direkt nach dem Einschalten ziemlich laut.

Was könnte das sein?

Firmware habe ich bereits aufgespielt, sowie eine SD nach gewünschtem Format und Struktur eingelegt.

Habe diese Karte:


Ich finde leider keinen Plan für die neuen Pins die die „alte“ Karte nicht hat. Ich habe die Buttons an der gleichen Stelle angeschlossen.

(4Ohm Visaton - könnte das das Problem sein?)

Anhang:

Die neuen Pins unten links auf der Platine sind GND (-) Pins. Die erleichtern das Anschließen der Buttons, da so immer direkt ein Ground verfügbar ist. Der bisherige Schaltplan kann also immer noch verwendet werden.

Ein kurzen Geräusch beim Einschalten ist normal. Wenn die Geräusche dauerhaft vorhanden sind, schau mal in die FAQ, da stehen mögliche Ursachen.
Wenn dein Problem eigentlich gar nicht im Knacken besteht, kannst du auch mithilfe von Fehler finden / Troubleshooting für Neulinge versuchen dein Problem genauer einzugrenzen. Deine Beschreibung bisher ist eher knapp. Es knackt, aber was erwartest du denn?

Was verwendest du eigentlich für Taster? Wenn ich das richtig erkenne, sind das rastende (Schalter). Mit denen funktioniert das nicht.

2 Like

Nein. Nur bei hoher Lautstärke kann es Probleme geben.

Meinst du sowas?


Wenn ja, Stromversorgung überprüfen. Wie speist du deinen Tonuino(s)? Über den Mini-USB?

Was sagt denn die Konsole?
siehe #software FAQ

Vielen Dank, mit Hilfe der FAQ konnte ich dem Problem auf die Schliche kommen.

Es liegt vermutlich an einem zu schwachen Netzteil / USB.

Schließe ich es an ein Labornetzteil 3A an geht es.

Ich hatte vergessen zu sagen: Ja es knattert wenn es einmal begonnen hat die ganze Zeit.

Danke ich denke ich muss mich nach einem stärkeren Netzteil umschauen… und oder vllt noch die hochohmigeren Lautsprecher nehmen?..

1 Like

Nein, nur die max. Lautstärke evtl. limitieren.

Probiere ein anderes Netzteil mal aus. Netzteil vom Handy sollte eigentlich ausreichen.

Da könntest du Recht haben!

1 Like

Muss euch enttäuschen :slight_smile: sind Taster.
Nachdem ich direkt am 5V Pin einspeise geht es wunderbar, mit den gleiche Netzteil.

Problem gelöst.

2 Like

Wie hast du denn Vorher eingespeist? Lag es vielleicht am USB-Kabel (falls du per USB eingespeist hast)

Genau, also über den USB Port vom Arduino Nano und USB Netzteil ging es nicht.
Dort war von 10 mal einschalten 9 mal Knattern oder spätestens wenn ich etwas lauter gedreht habe.
Jetzt mit dem selben Netzteil direkt am 5V pin klappt alles wunderbar!
(Aber auch anderes Kabel - könnte also auch sein)

Nur das abspeichern der Karten schlägt manchmal fehl, vielleicht Abstand zu groß oder an der falschen Position abgelegt, das muss ich noch schauen.

Vielen Dank für das tolle Projekt!

Hallo zusammen,

ich hatte eben grad ein ähnliches Phänomen als ich das Amperemeter zwischen der Power Bank und dem dem VIN (also Betrieb über den Spannungsregler) hatte. Das Amperemeter bringt einen kleinen Vorwiderstand mit sich. Immer wenn die „Bässe“ kamen, dann knackte es kurz.

Ursache war der Reset des Nano. In der Kombination scheint der interne Spannungsregler vom Nano nicht steif genug um „Leistungsanforderungen“ vom Player auszuregeln. Dann gibt es scheint mir einen kurzen Spannungseinbruch der den BOD vom ATMEL triggert.
Nano macht einen Reset
Der Player spielt zunächst unbeirrt weiter
Im Hochlauf reinitialisiert der Nano den DF-Player und der kackt dann kurz.
Interessant war, dass der DF-Player den laufenden Titel ohne erneute Anwahl weiter gespielt hat.

Wie gesagt, kommt hier erschwerend der Einfluss des Amperemeters hinzu, was nicht dem normalen Betrieb entspricht. Aber es zeigt, dass die Situation schon etwas grenzwertig ist.

Ich werde daher die Spannungen trennen. Der DF-Player bekommt einen Direktzugang zur Power Bank und ich werde einen Elko als Puffer spendieren.

MfG, Nick

Ja, das Knattern kommt vom ständigen Reset.
Daher am Besten direkt über den 5V Pin an der Platine einspeisen (nutzt du die eigentlich?).

1 Like

Als Ergänzung zu @Manu

1 Like

@Manu
Sehe, die Erkenntnis ist nix neues ;o). Eine Solide Versorgung des DF-PLayers ist wichtig. Und vermutlich bei 4 Ohm Lautsprechern umso mehr, weil die Ströme größer werden.

Eher die Frage, was der Player an Strömen ab kann.

Laut Datenblatt sind 4 Ohm drin. Dann muss er das auch können. Aber ich melde mich, wenn es bei mir die Panzersicherung raus wirft ;o).

Habe auch nen 4 Ohm (eigentlich 2x 8Ohm parallel) verbaut. Bisher auch noch keine Probleme gehabt. Es kann halt vorkommen, dass bei hoher Lautstärke dann mal die Spannung weggeht, wenn die Quelle nicht gut ist. Aber du weißt ja, was du machst, von daher passt das auch. Aber manch anderer versorgt seinen Tonuino über die Mini-USB-Schnittstelle des Arduinos. Da gehts halt nicht mehr…