DF-Player Kurzschluss?

Hallo zusammen,

mein TONuino hat bis vor kurzem noch wunderbar funktioniert.

Ich wollte Ihn dann provisorisch in meine gebaute Box einbauen und habe dabei vermutlich einen Kurzschluss verursacht.

Der Lautsprecher knarrt nur noch. Ich habe es mit einem anderen Lautsprecher getestet, der knarrt auch.
SD Karte entfernt, der selbe Fehler.
Es wird COM Error 1 angezeigt.

Entferne ich den Player erscheint kein COM Error.

Kann ich den DF-Player alleine reparieren?
Ich werde vermutlich einen neuen bestellen müssen. Kann es auch sein das am Board selber auch etwas beschädigt wurde? dann bestelle ich direkt ein neues Set.

Mfg Jan

Möglich ist vieles, aber die :crystal_ball: weiß grad keinen Rat. Daher, teste erstmal nur nen neuen DFPlayer (natürlich sicher stellen, daß ein möglicher Kurzschluss behoben ist). Wenn du damit nicht weiter kommst, kannst du mehr auswechseln. Die Tatsache, das der Arduino noch geht (er zeigt ja Konsole) deutet schon darauf hin, das er noch funktioniert. Sind schon relativ robust die Dinger…

auf dem Player bzw. auf dem Arduino sieht man auch keine typischen „Spuren“ . Ich werde mal einen neuen Player testen und beim nächsten mal besser isolieren :wink:

Naja es muss auch nicht gleich nach Ampere stinken und kann trotzdem hinüber sein. :wink:

Neuer MP3 Player auf den Arduino, erneut das brummen. Neuer Arduino und alter MP3 Player, brummen weg.

Der MP3 Player war nicht defekt, es war tatsächlich der Arduino. Bzw kann das auch nur ein Software Fehler sein? Oder sind nur die Pins zum MP3 Modul defekt? Kann man so etwas testen? Dann könnte ich den Arduino für andere Spielereien behalten.

Hört sich das Brummen in etwa so an?

Wenn ja, dann hast du höchstwahrscheinlich in deiner Spannungsversorgung ein Problem (zu niedrige Spannung, instabile Spannung / Wackelkontakt oder der Arduino hat ein Problem mit der Spannungsversorgung). Wie speist du denn die 5V ein? Über USB, VIN oder direkt auf den 5V Pin?

Ja !!! Genau so hört es sich an.

Komischerweise funktioniert aber die gleiche Powerbank und das gleiche Kabel mit dem neuen Arduino.
Ich werde mir mal ein USB Kabel basteln und dann direkt an die Pins gehen. Vll ist ja nur die USB Buchse defekt

Hast du ein Multimeter? Wenn ja, dann miss mal die Spannung am 5V Pin (zu Ground)… Da sollten 5V anliegen. Am DfPlayer mal schauen, ob da am VCC min. 3,3V ankommen (wenn du die Tonuinoplatine nutzt, sollten 5V ankommen, wenn ich den Schaltplan richtig im Kopf habe).

Edit: das heißt, du gehst aktuell von der Powerbank direkt auf den Mini-USB des Arduinos?

Ja genau, ich gehe direkt auf den Mini USB.

Ich kann es morgen erst durchmessen.

Ich habe ein USB Kabel durchtrennt und direkt an die Platine 5v und gnd angeschlossen. Siehe da, das knattern ist weg

Hört sich so an als sei da was vom USB (auf dem Arduino) abgeraucht. Wäre trotzdem interessant, welche Spannung über den USB raus kommt.
Wobei eigentlich müssen da 5V rauskommen, da auch 5V über die Powerbank reingehen… wahrscheinlich kommt zu wenig Strom durch…