Probleme mit dem Standby Timer

Ich hoffe, meine Frage ist hier richtig aufgehoben. Wenn ich im Admin-Menü eine Timer-Zeit wähle bekomme ich keine Bestätigung nach Auswahl der Zeit (hab alle Zeiten ausprobiert). Der Tonuino schaltet im Akku-Betrieb dann aber dennoch ab…allerdings schon nach ca. 30 Sekunden.

Wenn ich ein Netzgerät zum Durchladen anschließe geht er dann nicht aus.

Hat jetzt beim Aufspielen der Software was nicht gepasst oder muss ich noch was am Code ergänzen?

Ich gehe mal davon aus, dass du über das Adminmenü die Zeiten für den Standbytimer configuriert hast. Im serMonitor kannst du sehen, ob das Ausschalten des Tonuinos über die Software erfolgt. Da erscheint unmittelbar vor abschalten die Meldung Power off. Schaltet der Tonuino vorher ohne diese Meldung einfach ab, erfogt das Abschalten möglicherweise von der Powerbank, weil die Grundlast zu gering ist. Dieses Thema wurde hier schon oft angesprochen. bei Betrieb über das USB-Kabel direkt vom Computer sollte die Abschaltung nach 30 sek nicht erfolgen.
Noch ein Hinweis. Das Timeout für das Adminmenü hat damit aber nichts zu tun. Das dient dazu, dass der Tonuino aus dem Adminmenü aussteigt, wenn das Adminmenü nicht zu ende geführt wird oder im Adminmenü 5 min keine taste gedrückt wurde. Da wird nach ablauf der Timeoutzeit der Standbytimer gestartet.

Schon mal vielen Dank für die Schnelle Antwort.
Ich bin jetzt aber was verwirrt. Ist der Standby-Timer im Admin-Menü jetzt dazu da, dass der Arduino die Leistung runterfährt und die Powerbank ausschalten kann, oder dass das Admin-Menü nach einer definierten Zeit verlassen wird?

Das würde dann ja auch heißen, dass der Tonuino immer an bleibt, wenn ich ihn über Netzgerät betreibe auch wenn nichts mehr abgespielt wird? Hab ich Dich da richtig verstanden?

Das sind zwei unabhängige Timer. Der StadbyTimer wird aktiv, wenn nichts abgespielt wird. Nach der im Adminmenü configurierten Zeit, fährt der Arduino den Stromverbrauch runter damit zB. die Powerbank wegen unterschreitung der minimallast nach einer Powerbankabhängigen Zeit ausschaltet. Gleichzeitig wird auch ein Ausschaltsignal über einen Ausgang des Arduino ausgegeben, das eine zusätzliche Schaltung z.B. Pololu switch ansteuert und damit den Tonuino Ausschaltet. Der TimeoutTimer wird nur bei aktivem Adminmenü gestartet, und verhindert, dass der Tonuino unendlich lange eingeschaltet bleibt, weil das Adminmenü nicht beendet wurde. Der Standbytimer würde dann nämlich nicht aktiviert werden.

Das würde dann ja auch heißen, dass der Tonuino immer an bleibt, wenn ich ihn über Netzgerät betreibe auch wenn nichts mehr abgespielt wird? Hab ich Dich da richtig verstanden?

Das ist im Prinzip richtig. Wird der Tonuino über ein Netzgerät oder den USB Port des Computers betrieben, geht er zwar in den Ruhemodus aber schaltet nicht aus.

Ok, vielen Dank. Jetzt habe ich aber immer noch das Problem, dass ich an (aktuell) zwei Punkten im Admin-Menü nicht weiter komme. Wenn ich beim Standby-Timer eine Zeit auswähle kommt keine Bestätigung. Auf dem Nano leuchten dann auch beide LEDs auf und gehen nicht mehr aus, wie sonst nach einer Eingabe. Ein weiteres Problem hab ich bei der Auswahl der Modi: der Hörbuchmodus wird mit „Ohje, das hat wohl nicht geklappt“ (oder so ähnlich) quittiert. Sieht das für Dich nach einem Hardware oder Software-Thema aus?

Hier hilft nur die Konsolenausgabe weiter. Hier kannst du sehen, ob eventuell Tasten nicht richtig gelesen werden. Ich hatte mal das Problem, dass Tasten beim Drücken Mehrfachimpulse gegeben haben und einiges durcheinander kam. Es sieht nämlich so aus, als ob das Adminmenü schon vorzeitig in das Schreiben der RFID Karten geht.
Poste doch mal die Konsolenausgabe, da kann man schon mal mehr sehen. Wenn du die Software richtig eingearbeitet hast sollte da nicht das Problem liegen. Bei mir funktioniert das Fehler frei.

Hier meine Konsolenausgabe. Die letzte Änderung der Sleeptimeranpassung wurde wohl doch übernommen. Sonst kann ich da (noch) nichts rauslesen. Erkennst Du was „Außergewöhnliches“?

20:29:25.067 -> 
20:29:25.067 ->  _____         _____ _____ _____ _____
20:29:25.067 -> |_   _|___ ___|  |  |     |   | |     |
20:29:25.067 ->   | | | . |   |  |  |-   -| | | |  |  |
20:29:25.102 ->   |_| |___|_|_|_____|_____|_|___|_____|
20:29:25.102 -> 
20:29:25.102 -> TonUINO Version 2.1
20:29:25.102 -> created by Thorsten Voß and licensed under GNU/GPL.
20:29:25.102 -> Information and contribution at https://tonuino.de.
20:29:25.102 -> 
20:29:25.102 -> === loadSettingsFromFlash()
20:29:25.102 -> Version: 2
20:29:25.102 -> Maximal Volume: 25
20:29:25.102 -> Minimal Volume: 5
20:29:25.102 -> Initial Volume: 15
20:29:25.102 -> EQ: 1
20:29:25.102 -> Locked: 0
20:29:25.102 -> Sleep Timer: 15
20:29:25.102 -> Inverted Volume Buttons: 1
20:29:25.102 -> Admin Menu locked: 0
20:29:25.102 -> Admin Menu Pin: 1111
20:29:25.102 -> === setstandbyTimer()
20:29:25.136 -> 900053
20:29:27.240 -> Firmware Version: 0x92 = v2.0
20:29:27.240 -> === playShortCut()
20:29:27.240 -> 3
20:29:27.240 -> Shortcut not configured!
20:31:58.459 -> === volumeDown()
20:31:58.459 -> 14
20:32:10.633 -> === volumeUp()

So, jetzt kommen wir der Geschichte langsam auf die Spuren. wenn ich auf den grüner Taster (Pause) gehe, kommt keine Anzeige in der Konsole. Es wird nur für laut und leise was angezeigt. Taster gewechselt… Selbes Ergebnis :thinking:

Das Drücken der Pausetaste erscheint nur bei laufender Wiedergabe oder bei langem Druck (Shortcut) in der Konsole.

Da hab ich mal sauber als Newby geoutet :man_facepalming:

Ok, funktioniert…hab ne Karte aufgelegt und da zeigt auch die Pausetaste ne Reaktion. Danke @Gute_Laune für den Hinweis. Siehst Du sonst was, was nicht passen könnte?

Ok, der Lernprozess geht weiter. Habe nun die beiden Szenarien durchgespielt. Die Sleeptimerzeit setzen ging…allerdings wird keine Bestätigung gegeben, ich seh es nur in der Konsole:

20:44:32.475 -> === 8 ===
20:44:32.475 -> === voiceMenu() (5 Options)
20:44:36.339 -> 649
20:44:36.339 -> 649
20:44:37.210 -> 1
20:44:38.707 -> 650
20:44:38.742 -> 650
20:44:39.960 -> === 1 ===
20:44:39.960 -> === writeSettingsToFlash()
20:44:39.960 -> === setstandbyTimer()
20:44:39.960 -> 1216392

Dann hab ich eine Karte neu konfiguriert und wollte „Hörspielmodus“ auswählen. Da kommt dann folgende Meldung:

20:46:03.396 -> === 1 ===
20:46:06.601 -> Karte wird neu konfiguriert!=== setupCard()
20:46:06.636 -> 615
20:46:06.636 -> 615
20:46:06.671 -> === voiceMenu() (99 Options)
20:46:13.879 -> 596
20:46:13.914 -> 596
20:46:15.478 -> 1
20:46:16.940 -> 340
20:46:16.940 -> 340
20:46:18.646 -> 2
20:46:19.690 -> 341
20:46:19.690 -> 341
20:46:21.081 -> 3
20:46:22.090 -> 342
20:46:22.090 -> 342
20:46:24.808 -> 4
20:46:25.818 -> 343
20:46:25.818 -> 343
20:46:28.078 -> === 4 ===
20:46:28.113 -> === voiceMenu() (9 Options)
20:46:32.814 -> 597
20:46:32.814 -> 597
20:46:33.371 -> 1
20:46:37.720 -> 598
20:46:37.720 -> 598
20:46:38.694 -> === 1 ===
20:46:38.729 -> Authenticating again using key A...
20:46:38.764 -> PCD_Authenticate() failed: Timeout in communication.
20:46:39.809 -> === writeSettingsToFlash()
20:46:39.809 -> === setstandbyTimer()
20:46:39.809 -> 1336419

Was ist den der „PCD_Authenticate“ , der da nicht klappt?

Es gibt bei Einstellungen im Adminmenü nie ein akustisches Feedback, dass die Änderung erfolgreich war. Somit ist da alles in Ordnung.
Grundsätzlich habe ich ein bisschen den Überblick verloren, wo noch Probleme bestehen. Das Beschreiben einer Karte scheint ja noch nicht zu funktionieren. Hast du wie in der Hardware FAQ beschrieben schon mit dem Abstand zwischen Reader und Karte experimentiert?

Wie sieht es mit dem Abschalten nach 30Sek aus?

Wenn die zu geringe Grundlast in Kombination mit der Powerbank das Problem ist, reicht es zusätzlich eine LED anzuschließen.

Gerade bei solchen Fragen hilft auch die Suchfunktion weiter.

Grundsätzlich ging es in diesem Topic aber mal um eine Erweiterung der Software. @stephan könntest du das Thema splitten?

Erledigt. Danke für den Hinweis.

1 Like

Zur Karte: den FAQ hatte ich gesehen. Die Karte funktioniert ja soweit, wird umgehend erkannt und ich hab sie mit dem Partymodus anlernen können. Nur beim Hörspielmodus (die anderen Modi hab ich nicht ausprobiert) kommt „Ohweh…“

Zum Abschalten: In der Konsole habe ich das noch nicht nicht gesehen. Allerdings wird der Nano ja währenddessen durch das USB-Kabel vom PC mit Strom versorgt und schiebt sich damit vor die Versorgung durch den Akku, oder? Ich gehe davon aus, dass es die Abschaltung durch die Powerbank selber ist. Ich habe einen Schalter mit LED verbaut, der während dem Betrieb läuft. Sollte ich noch einen Widerstand dazwischen setzen?

Zur Suche: Daran hatte ich tatsächlich noch nicht gedacht…aber…jetzt auch nicht wirklich was gefunden. Bei den Themen geht es dann meist darum, dass die Karten nicht funktionieren. Bei mir funktioniert sie j a nur bei einem Modus nicht. Werde einfach mal ne andere Karte ausprobieren.

Vielen Dank für Eure Unterstützung bisher!