Problem: Sound stottert bzw. verzerrt

Hallo Community,

meine Schwester hat ihren ersten Tonuino in Betrieb genommen. Ich bin da die technische Unterstützung und nun haben wir ein Sound-Problem. Karten anlernen funktioniert, Die Musik wird dann auch abgespielt. Aber es kommt immer wieder zu verzerrtem Sound. Ich habe ein 10 Sekunden Aufnahme bei Youtube hochgeladen. Da hört man, dass es zuerst normal abspielt, dann verzerrt, dann wieder normal…

https://youtu.be/a6ijwBsS5i8

Vielleicht gibt es ja bereits Erfahrungen, woran das liegen könnte. Ich hatte auch etwas im Forum gesucht. Es wird häufig auf die SD-Karte verwiesen. Die eingebaute SD-Karte wurde mit dem SD Card Formatter formatiert. Ich habe mit meinen beiden eigenen Tonuinos auch keine Probleme (Gleicher Karteninhalt und Vorgehensweise).

Ansonsten würden wir erstmal:

  • Einschaltgeräuschunterdrückung per MOSFET überbrücken, damit dies ausgeschlossen werden kann.
  • SD-Karte austauschen gegen eine funktionierende von mir
  • Lötstellen überprüfen

Lautsprechergröße weiß ich gerade nicht. Aber es war 4 oder 8 Ohm.

VG
Albert

Was für eine SD-Karte ist denn in Verwendung?
Welcher dfPlayer (Chipsatz) wird verwendet?

Das wäre auch mein erster Vorschlag gewesen.

Welche MOSFETs hast du benutzt?
Aber sicher mal eine Überlegung wert, diese Schaltung zu überbrücken.

Das würde ich als erstes mal Testen.

Hast du die originale Software oder hast du etwas rumgespielt? Wenn man den DFPlayer mit Anfragen zuschüttet kommt er auch ins Stottern

Hallo,

Vorab:

die Software ist von @Thomas-Lehnert Always Queue ohne Anpassungen.

Die SD Karte ist eine intenso microSDHC class 10 mit 32 GB.

Die Tests konnte ich noch nicht durchführen.

Sagt denn der serielle Monitor etwas?

So wie sich das anhört, liegt das Problem in der Stromversorgung. Schalte Mal einen Elko mindestens 100 uF möglichst dicht am Df-Player von 5V gegen Ground. Das sollte schon helfen.
Was hast du als Stromversorgung?

Das glaube ich nicht. Das liegt meiner Meinung nach sehr wahrscheinlich an der SD Karte. Das ist genau das Phänomen welches ich (bei mir) mit dem SD Card Formater lösen konnte. Ich habe hier zwei Intenso Karten. Eine normal formatiert, die macht aktuell die gleichen Probleme. Eine weitere mit den SD Card Formater formatiert, läuft. Problem hier ist halt @Albert hat das schon probiert. Würde sonst mal die Karte oder Player tauschen…

Das wäre dann Mal zu testen. Ich hatte dieses Phänomen bei mir noch nicht. Das mit der Stromversorgung sollte man aber auch in Erwägung ziehen.

Danke für die Rückmeldungen. Ich habe die Versorgung usw. wie bei meinen beiden Boxen (von der powerbank über einen Schalter an den 5V PIN)
https://discourse.voss.earth/t/erster-tonuino-ist-fertig-kinder-sind-begeistert/9320

Ich konnte es heute nicht organisieren den Tonuino in die Hände zu kriegen.
Donnerstag (ehemals Morgen) weiß ich mehr. Ich melde mich dann…

1 Like

So, deutlich später als gedacht, konnte ich am Wochenende das Problem lösen. Nachdem das Stottern nach Wechsel der SD Karte weg war, war der Übeltäter gefunden. Also die Problem Karte nochmal mit dem SD-Card Formatter gelöscht und alles neu drauf kopiert. Jetzt funktioniert es. Ich bin mir aber sicher, dass vorher auch schon getan zu haben. Naja, Ende gut alles gut. Ich hoffe es hält jetzt lange.

1 Like