Nichts passiert

Hallo,

ich bin heute mit löten fertig geworden und es sieht soweit alles gut aus.
Leider passiert nichts wenn ich eine RFID Karte vorhalte.
Ich habe mir das Tonuino Paket von az gekauft und eine neue 32 GB Sandisk SD Karte.
Das kompilieren und hochladen hat (unerwarteter Weise, ich habe durch eine Neuinstallation meine vorherige IDE komplett verloren :confused: ) einwandfrei geklappt und die serielle Verbindung sieht auch gut aus.Aber es kommt keinerlei Ton.
Hier die Ausgabe von dem seriellen Monitor:
^⸮⸮⸮ ⸮⸮⸮Ǻ⸮⸮ʡ⸮ǚ⸮-⸮⸮⸮⸮⸮⸮e⸮⸮⸮
_____ _____ _____ _____ _____
|_ |__ | | | | | | |
| | | . | | | |- -| | | | | |
|
| |
|||||||__|

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
0
Firmware Version: 0x92 = v2.0
=== playShortCut()
3
Shortcut not configured!
5148
15648
=== setstandbyTimer()
0
=== setstandbyTimer()
0
=== setstandbyTimer()
0
=== setstandbyTimer()
0
=== volumeUp()
16
=== volumeUp()
17
=== volumeUp()
18
=== volumeUp()
19
=== volumeUp()
20
=== volumeUp()
21
=== volumeUp()
22
=== volumeUp()
23
=== volumeUp()
24
=== volumeUp()
25
=== volumeUp()
25
=== volumeDown()
24
=== volumeDown()
23
=== volumeDown()
22
=== volumeUp()
23
=== volumeUp()
24
=== volumeUp()
25
=== volumeUp()
25
=== volumeUp()
25
=== volumeUp()
25
=== volumeUp()
25
Card UID: 66 F1 17 29
PICC type: MIFARE 1KB
Authenticating Classic using key A...
Reading data from block 4 ...
Data on Card :
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Ich denke es ist nur eine Kleinigkeit, aber ich finde den Fehler nicht.
Danke im voraus, sorry wenn so ein Thema schon existiert, habe ehrlich gesagt gerade nicht gesucht, wegen Zeitmangel und Leidensdruck :slight_smile:

Hörst du ein Fiepen aus dem Lautsprecher, wenn du den Nano an Strom ansteckst?

In der Hardware FAQ gibt es Hinweise. Hast du die schon durchgearbeitet? Hat der dort beschriebene Test des Players einen Sound ausgegeben?

Dein Test der Buttons scheint ja erfolgreich.

So kannst du den Player mal Testen. Das würde ich mal als erstes machen.

Edit: ups, da war @Gute_Laune schneller :slight_smile:

Bilder deines Aufbaus wären auch nicht schlecht. Also Lötstellen und Verkabelung.

… Es ist mir peinlich zu schreiben was es war…
Falsch rum gelötet am dfplayer… Anscheinend hatte die Konzentration nachgelassen :blush:

Jetzt geht’s jedenfalls und ich befasse mich morgen nochmal damit. Spielt jedenfalls jetzt ab und erzählt mir auch Dinge :slight_smile: peinlich…

2 Like

Also so als Rückmeldung:
Es funktioniert jetzt alles, ich bin überrascht von der Leistung, ich habe den tonuino an einen alten Center Speaker gehängt und der Klang ist klasse.
Was ich nicht verstehe ist, wenn ich die Lautstärke massiv erhöhe, in meinem Fall auf 26 oder 27, stockt die Wiedergabe und ich habe das Gefühl das sich das System resettet. Bleibe ich bei 22 oder niedriger ist alles tutti.
Vielleicht kann mir das jemand erklären?
Wäre interessant :slight_smile:

Die Spannung bricht ein. Lautsprecher evtl. zu niederohmig.

Ahhh… Dachte mir sowas schon :slight_smile:
Spannung erhöhen durch mehr Ampere beim Netzteil, oder einen hochohmigen Lautsprecher nehmen?

Ich bin dabei den mit einer 18650er zu betreiben. Kann ich irgendwie berechnen wieviel Spannung ich brauche? Oder einfach ausprobieren?

Du brauchst immer 5V. Nimm einfach einen Lautsprecher den der Verstärker auf dem DFPlayer vernünftig betreiben kann (4-8 Ohm (besser 8) / 3W).