Bitte um Hilfe, Tonuino ruft zufällig Zahlen aus!

Hallo zusammen,

ich habe mich an meinen ersten Tonuino gemacht und kann ein Problem nicht lösen. Der Tonuino ruft immer wieder Zahlen dazwischen eins, zwei oder drei. Er wiederholt diese auch bis ihm wieder einfällt, dass er eigentlich ein Hörbuch weiter abspielen soll, oder ich ihn stromlos schalte. Damit man sich schnell einen Eindruck von dem Problem verschaffen kann habe ich ein kleines Video gemacht, das kann man sich hier anschauen: Video

Wie man sieht habe ich die letzte Version der Classic Platine verwendet und die 5 Knöpfe Matrix. Den RFID-RC522 und den DFPlayer Mini habe ich aus einem AZ-Delivery kit.

Die Software ist von diesem Git: GitHub - xfjx/TonUINO: Die DIY Musikbox (nicht nur) für Kinder aus dem DEV branch, ich gehe davon aus die wird täglich von Anderen aufgespielt und habe die nicht unter Verdacht.

So sieht der tree meiner SD-Karte aus (für die Leserlichkeit gekürzt):

E:.
├───01
│       001.mp3
│
├───02
│       001.mp3
│
├───advert
│       0001.mp3
│       0002.mp3
│       0003.mp3
│       .
│       .
│       .
│       0304_buttonslocked.mp3
│       0305_kindergarden.mp3
│
└───mp3
        0001.mp3
        0002.mp3
        .  
        .  
        .
        0992_admin_calc.mp3
        0993_admin_calc.mp3
        0994_admin_calc.mp3
        0999_reset_ok.mp3

Die Ausgabe aus dem Seriellen Monitor:

16:34:42.942 -> 
16:34:42.942 ->  _____         _____ _____ _____ _____
16:34:42.942 -> |_   _|___ ___|  |  |     |   | |     |
16:34:42.942 ->   | | | . |   |  |  |-   -| | | |  |  |
16:34:42.942 ->   |_| |___|_|_|_____|_____|_|___|_____|
16:34:42.975 -> 
16:34:42.975 -> TonUINO Version 2.1
16:34:42.975 -> created by Thorsten Voß and licensed under GNU/GPL.
16:34:42.975 -> Information and contribution at (https)://tonuino.de.
16:34:42.975 -> 
16:34:42.975 -> === loadSettingsFromFlash()
16:34:42.975 -> Version: 2
16:34:42.975 -> Maximal Volume: 25
16:34:42.975 -> Minimal Volume: 5
16:34:42.975 -> Initial Volume: 15
16:34:42.975 -> EQ: 1
16:34:42.975 -> Locked: 0
16:34:42.975 -> Sleep Timer: 0
16:34:42.975 -> Inverted Volume Buttons: 1
16:34:42.975 -> Admin Menu locked: 0
16:34:42.975 -> Admin Menu Pin: 1111
16:34:42.975 -> === setstandbyTimer()
16:34:42.975 -> 0
16:34:45.108 -> Firmware Version: 0x92 = v2.0
16:34:45.108 -> === playShortCut()
16:34:45.108 -> 3
16:34:45.108 -> Shortcut not configured!
16:34:45.108 -> Card UID: B7 B6 52 B2
16:34:45.108 -> PICC type: MIFARE 1KB
16:34:45.108 -> Authenticating Classic using key A...
16:34:45.108 -> Reading data from block 4 ...
16:34:45.141 -> Data on Card :
16:34:45.141 ->  13 37 B3 47 02 01 01 18 F9 00 00 00 00 00 00 00
16:34:45.141 -> 
16:34:45.141 -> 1
16:34:45.141 -> 1
16:34:45.141 -> == playFolder()
16:34:45.141 -> === disablestandby()
16:34:45.141 -> 1 Dateien in Ordner 1
16:34:45.141 -> Hörspielmodus -> zufälligen Track wiedergeben
16:34:45.174 -> 1
16:34:45.981 -> 4
16:34:45.981 -> === nextTrack()
16:34:45.981 -> Hörspielmodus ist aktiv -> keinen neuen Track spielen
16:34:45.981 -> === setstandbyTimer()
16:34:45.981 -> 0
16:34:46.592 -> 4
16:34:47.173 -> 4
16:34:47.711 -> 4
16:34:48.292 -> 4
16:34:48.833 -> 4
16:34:49.413 -> 4
16:34:49.992 -> 4
16:34:50.565 -> 4
16:34:51.109 -> 4
16:34:51.682 -> 4
16:34:52.254 -> 4
16:34:52.798 -> 4
16:34:53.375 -> 4
16:34:53.945 -> 4
16:34:54.521 -> 4
16:34:55.063 -> 4
16:34:55.366 -> Card UID: B7 B6 52 B2
16:34:55.366 -> PICC type: MIFARE 1KB
16:34:55.366 -> Authenticating Classic using key A...
16:34:55.366 -> Reading data from block 4 ...
16:34:55.366 -> Data on Card :
16:34:55.366 ->  13 37 B3 47 02 01 01 18 F9 00 00 00 00 00 00 00
16:34:55.366 -> 
16:34:55.366 -> 1
16:34:55.366 -> 1
16:34:55.366 -> == playFolder()
16:34:55.401 -> === disablestandby()
16:34:55.435 -> 1 Dateien in Ordner 1
16:34:55.435 -> Hörspielmodus -> zufälligen Track wiedergeben
16:34:55.435 -> 1
16:35:12.797 -> 4

ab und zu kommt auch mal sowas:
17:11:45.551 -> Com Error 129

Zuerst hatte ich die Spannungsversorgung unter verdacht, habe alles ausprobiert, unterschiedliche Netzteile und Powerbank. Dann den DFPLayer Mini den habe ich jetzt ausgetauscht, es liegt das gleiche Problem vor. Jetzt habe ich das RFID Modul unter Verdacht, aber ich dachte ich frage mal bevor ich wieder was Kaufe und das Problem bleibt.

Vielen Dank im Voraus
Johannes

Ich hätte eher immer noch den Player im Verdacht. Der Fehler, der dir angezeigt wird, kommt ja auch vom Player. Welchen Player verwendest du denn genau? Es sind ja doch einige im Umlauf, die nicht empfohlen werden (siehe FAQ).
Du kannst den Reader ja einfach mal abziehen und schauen, ob der TonUINO dann ohne Probleme funktioniert. Wie er sich dann bei Wuedergabe verhält kannst du mithilfe der Shortcuts ausprobieren.

Ich habe den JL AA19HFF859-94. Ich muss sagen, wenn ich ihn abziehe passiert nichts, es werden keine Karten ID’s gelesen.
Shortcurs habe ich ebenfalls noch keine Konfiguriert, da muss ich mich noch kurz reinlesen. Aber für Shortcuts muss das Programm zumindest die Karten lesen oder? Kann es sein, dass das Program nur noch mit dem AiO Set kompatibel ist?

Meinst du mit ihn jetzt den Player, wie im Satz zuvor oder den Reader?

Nein, für Shortcuts werden die RFID-Karten nicht benötigt. Auf der RFID-Karte werden beim Anlernen Zahlen gespeichert (Ordner X, im Modus Y (Track von xy - yx) ). Diese Zahlen werden für den Shortcut auf dem Arduino gespeichert und können dann durch langem Druck auf den Taster abgespielt werden. Deshalb kann man damit die Wiedergabe testen ohne einen RFID-Reader angeschlossen zu haben.

Die von dir verlinkte Software funktioniert gar nicht mit der AiO-Platine. Außerdem ist die letzte Änderung, wie du sehen kannst aus Juli 2020. Da gab es die AiO-Platine noch gar nicht.

Das Programm das du aufgespielt hast ist richtig für den TonUINO in der Klassik Version. Also mit Arduino Nano Df-Player usw. Für die AiO Version wird die Version 2.2 benötigt

1 Like

Wo du beim Aufbau natürlich mehr beachten musst, als bei der AiO ist beim Buttonboard. Dazu gibt es im Quick Start Guide ja entsprechende Hinweise.

Ich habe das Buttonboard erstmal bei Seite gelegt und verbinde einfach die entsprechenden Jumperkabel mit Ground, damit kann ich das Buttonboard als Fehlerquelle ausschließen. Ich habe die Hinweise aber beachtet.

1 Like

Es gab übrigens schon mal ein Thema mit dem Problem mit den Ansagen von Nummern.

Mein Fehler war, dass ich Lötwasser verwendet habe. Ich habe jetzt alle Lötstellen mit einer Zahnbürste sauber gemacht und es läuft stabil. Die Antwort habe ich hier gefunden: Software oder Classic Platine v1.6 fehler? - #9 von Gute_Laune

Vielen Dank für eure Hilfe, ich konnte dadurch vieles ausschließen.
Danke auch für Gute_Laune, ebenfalls ein guter Tipp in dem anderen Thread.

1 Like

Gerne. Zu den Flussmitteln steht sogar was in der FAQ. Hattest du das gesehen?
Es geht mir auch nicht darum dir einen Vorwurf zu machen. Es wäre ja nur toll, wenn der/ die Nächste vielleicht gleich die Lösung findet.

Ich habe Lötwasser mehr als ein ätzendes Reinigungsmittel gegen Fett auf der Platine angesehen und nicht als Flussmittel und schon gar nicht als Lötfett. Ich habe das also nicht wahrgenommen.

Dann sollten die FAQ da also erweitert werden. Hat da jemand eine gute Idee für die Formulierung?
Ich mache mal einen ersten Vorschlag. Sicherlich muss nicht nur die Überschrift angepasst werden.