Anfänger fragen


#1

Hy
Ich bin ganz neu in der microcontroller Szene und hab ach vom programmieren keine Ahnung ,war aber von dem TonUINO so begeistert das ich mir direkt alle componenten bestellt habe.
Ich bin nun so weit das ich die Firmware auf dem arduino aufgespielt habe. Nun weiß ich aber nicht weiter. Muss ich den sourcecode auf den arduino spielen und wo finde ich den oder muss ich da anders verfahren.
Ach und ist es normal das die" L "LED rot leuchtet nachdem ich die Firmware aufgespielt habe? Ich Danke euch jetzt schon für die Antworten


#2

Hast du die Anleitung auf der TonUINO Seite befolgt? Dateien auf die SD Karte kopiert (siehe ebenfalls die Anleitung)? Alles zusammen gebaut. Was passiert denn wenn du eine Karte an den nfc Leser hällst?


#3

Nur zum Verständnis: was meinst du mit Firmware? Den source Code von GitHub wird wie in der Anleitung mit der arduino IDE compaliert und geflashed. Auf die SD-Karte kommt nur die Ordnerstruktur mit deinen MP3’s und die MP3’s für die Sprachausgabe


#4

War ein bissl irritiert wegen „Firmware“ und „sourcecode“.
Ich hab soweit den Arduino vorbereitet und die Software ist drauf.
Dann hab ich auf der SD Karte mal 4 Ordner erstellt und in der ersten Ordner einfach mal zu testen 4 Lieder eingefügt , natürlich umbenannt in 001.mp3 usw.
Wie kann ich den Ordner mit den Daten des Konfigurationsdialogs herunterladen,(aus dem git Hub Repository)und muss ich den dann auf die Sd Karte mit einfügen (was ich ja meine).
Bis jetzt hab ich nur einen mp3 player der ein Lied abspielt :slight_smile:


#5

Ok ich hab’s hinbekommen.
Musste mich erstmal schlau machen.
Kann es sein das die Taster Schalter in dem link von der Seite ziemlicher Mist sind.
Oder hab ich was falsch gemacht.
Wenn ich den Tonuino frisch an den Strom hänge ist alles super und die Taster funktionieren.
Wenn ich allerdings 2-3 mal gedrückt habe,Pause oder ähnliches dann funktioniert es nicht mehr.


#6

Die verlinkten Arcade Taster funktionieren eigentlich super. Wenn du durch trennen vom Strom wieder Funktion herstellen kannst, glaube ich auch nicht, dass es an den Tastern liegt. Da ist bestimmt irgendwas anderen nicht in Ordnung.


#7

Wenn es mit einem Neustart behoben ist würde ich die Mechanik ausschließen. Und wenn du die Software nicht verändert hast würde ich bei der Elektronik suchen. Hast du die Platine von Thorsten, oder hast du die Platine selbst gebaut. Wenn es alle Knöpfe betrifft, könnte es am gemeinsammen Massepotenzial der Köpfe liegen (keine sauber Masse). Ist aber schwer zu sagen …


#8

Grüsst euch miteinander
Nun habe ich doch noch eine Frage zum Projekt, bzw anordnung der Dateien auf der Sd-Karte.
Es gibt einen Ordner advert, darin inbegriffen 0001.mp3 - 0250.mp3,
einen zweiten Ordner, darin ebenfalls 0001.mp3-0250.mp3 + zusätzlich die files für die Sprachausgabe.

Nun lese ich, es können Unterordner 01-99 angelegt werden und darin enthalten, Dateien 001.mp3 bis 255.mp3.
Ich habe nun den Ordner “advert und mp3” auf die SD Karte kopiert. Einen Ordner 01 in mp3 angelegt und darin enthalten, 2 mp3 dateien, beginnend mit 0001 und 0002.
Wo ist der Fehler?


#9

Du kopierst advert und mp3 so wie sie sind auf die Karte. Korrekt.
Die Unterordner 01 - 99 kommen ebenfalls ins root der Karte - nicht in mp3 oder advert.
Die Dateien in den Unterordnern 01 - 99 müssen 001xyz.mp3, 002xyz.mp3, 003xyz.mp3 etc.pp. heissen. Also dreistellige Nummer, nicht Vierstellig.


#10

Danke für die Antwort,
so hatte ich es aber schon probiert, ohne Fehlermeldung. Wurde aber nichts abgespielt, deshalb habe ich alle möglichen Konstellationen probiert :joy:
Habe es dann noch einmal so reinkopiert aber mit der Fehlermeldung: „Oh, das hat leider nicht geklappt.
Habe aber diesmal ein paar sekunden gewartet, bevor ich wieder den Stecker ziehe und plötzlich lief die mp3 an.
werde nun mal noch ein paar Ordner hinzufügen und testen.


#11

Dieses Problem tritt auf wenn der Abstand zwischen RFID Karte und RFID Reader nicht passt. Einfach mal etwas herum experimentieren - z.B. verschiedene Holzbretter dazwischen legen, ein paar Blätter Papier oder Post-Its.


#12

sind 30 cm Abstand dazwischen, habs grad nur zu Testzwecken erstmal provisorisch vekabelt.
Ordner auswählen funktioniert, danach kommt die Auswahl …Album modus war Fehler, Hörspielmodus funktionierte ohne Fehler. Spielt aber beides ab, trotz Fehlermeldung.


#13

30cm? Das kommt mir aber arg viel vor. Die Tags/Karten funktionieren (zumindest bei mir…) am besten so in 1-2cm Abstand.


#14

3 nicht 30 :see_no_evil:
ich teste mal noch ne weile und danach überleg ich mir ne schöne Box.
Weihnachten lässt ja nicht mehr all zu lang auf sich warten.
gruss


#15

Danke für eure Antworten.
Marcel du hattest recht. Ich hatte so etwas wie ein Kabelbruch in einem der Masse Kabel.
Ist nun wieder behoben,und läuft super.
Vielen Dank für eure Antworten.
Jetzt gehts an basteln einer Box. Freu mich wie Bolle das der Apperat funktioniert.


#16

Ja super! Dann viel Spass. :slight_smile:


#17

Moin,
nach den Zahlen ist noch Platz für Text? Sowohl bei Ordnern als auch bei den Musikdateien? Ich dachte, es seien nur Zahlen zulässig, was die Verwaltung etwas fummelig macht.


#18

Bei den Ordnern nicht. Bei den Dateien ja. Also 001Dies_ist_Hoerspiel.mp3 ist kein Problem.


#19

Danke für die Info. Dann bin ich nicht mehr so ganz im Blindflug :wink:


#20

Danke für die Info! Das war mir nicht klar. Sollte man eventuell auch auf der Website erwähnen.