Tonuino startet nur durch Berührung

Hallo zusammen,

Ich baue gerade meinen Tonuino nach Vorbild von @hiJack und @Strandbummler. Ich verwende die Firmware von @marco-117 in der neusten Version mit der „Stopp wenn Karte weg“ Funktion. Bis jetzt klappt auch alles ganz wunderbar, jedoch habe ich nun ein Problem, durch welches ich meine Tonuino nicht verschließen kann.

Wenn ich den Tonuino anschalte, ertönt der Startsound, es werden jedoch keine Lieder abgespielt und der Tonuino geht nicht in den „Listen-Modus“. Erst nachdem ich auf dem Tonuino eine ganz bestimmte Stelle berühre, wird er „aktiv“ und spielt dann Musik ab.

Ich habe das ganze auch auf einem Video festgehalten, um den Umstand noch zu verdeutlichen.

Habt ihr eine Idee?

Ein weiteres Problemchen ist die Kopfhörerbuchse, bei der die Ausgabe extrem blechern klingt, was aber fürs Erste ein sekundäres Problem ist.

Liebe Grüße und danke
Thies

Erste Maßnahme sollte die Kontrolle der Konsolenausgabe sein. Hier kannst du schon sehen, ob z.B der rfidreader erkannt wird. Dann kannst du auch sehen ob die Tasten funktionieren. Zweitens solltest du mal die Lötstellen des Nano an den Stiftleisten kontrollieren. Auch die gesteckten Kabel machen gerne Probleme. Die Ursach kann also vielfältig sein. Hier muss man erst mal den Fehler eingrenzen. Blindes Raten hilft hier leider nicht weiter.

Hey Thomas,

die Ausgabe sieht bei mir wie folgt vor dem Berühren aus:

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

Fork by Marco Schulz
load settings from flash
Version: 5
Max Vol: 30
Min Vole: 1
Init Vol: 10
EQ: 1
Locked: 0
Sleep Timer: 5
Inverted Vol Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
Saved Modifier Mode: 0
set standby timer
milis: 302035
Firmware Version: 0x92 = v2.0
=== mfrc522-> RxGain_avg === 
_lastTrackFinished
_lastTrackFinished

Wenn ich nun den beschriebenen Punkt berühre ändert sich nichts in der Konsole. Beim Auflegen des NFC Tags kommt dann folgendes:

ReadCardSerial finished
Card UID 
 17  7B  94  56 
PICC type MIFARE 1KB
Authenticating Classic using key A...
Reading data block4...
Data on Card :  13  37  B3  47 02 05 05 05  AA 01 00 00 00 00 00 00 
5
5
new card
playFolder
disable standby timer
26 tracks in folder 5
Audio Book
read memory No. 1 of folder No. 5
play track: 5

Die Tasten funktionieren, so wie alles andere auch leider erst nach dem Berühren. Ich habe die Lötstellen noch einmal angeschaut. Allerdings erkenne ich da nun keine „Lücken“ etc. bin aber auch kein Profi.

Die gesteckten Kabel habe ich alle schon zu Anfang mit der Zange fester zusammen gedrückt, die sollten also genug Kontakt haben.

Heilung durch Hand auflegen ist definitiv ein Hardwareproblem.
Die Ausgabe ist unauffällig.

Eventuell schließt du einen Kontakt durch deinen Finger. Alle Lötstellen genauer fotografieren kann helfen.

Wie sind die Pins am Nano denn beschriftet, die du berührst.

Ich konnte es eingrenzen auf den Pin D4, wenn ich diesen mit einem Bleistift berühre, dann blinkt er los


Sieht für mich nicht schlechter aus als die anderen Lötstellen, oder?

Auch hier unten reicht eine Berührung des Pins aus.

Klingt für mich nach einem „Busy“ problem.
Kontrolliere die Verbindung des Busy pin am MP3 Player zum Nano. Vlt. Einen zusätzlichen Draht dranhalten ob das Problem dann weg ist.

Eith:
Ggf. testen ob eine Berührung am Busy-Pin auch wirkt und diese Lötstelle ebenfalls kontrollieren.

1 Like

Hey Thorsten,

danke, das war es, habe den D4 direkt mit Busy vom Player verbunden und es geht. Vielleicht ist irgendwas in der Platine kaputt. Nun geht es erst mal. Danke für eure Hilfe!

Das bezweifle ich. Wahrscheinlich hast du auf dem Weg irgendwo eine kalte Lötstelle. Vielleicht hilft es alle auf dem Weg liegende Lötstellen einmal nach zulöten.

Gute Idee, werde ich dann noch mal ausprobieren!

Habt ihr denn einen Tipp zu der belchernen Wiedergabe durch die Kopfhörerbuchse?