Meine erste Box ohne Bohren

Hab es jetzt raus. Ein Finger hat ein bisschen gelitten :sweat_smile:
Von oben hab ich das ganze nicht aufbekommen. Von unten bin ich dann dazwischen gekommen. Die orangene Abdeckung hat es auch nochmal in sich gehabt, da diese rundrum nochmal verklebt war. Bin bald verzweifelt :neutral_face:

Nun kann ich heute Abend mal loslegen wenn die Kids schlafen :ok_hand:

Ich glasube das war bei mir noch nicht

Welcher „kleine“ RFID Reader wurde denn hier verwendet? Gibt es eine Modell Bezeichnung oder sogar einen Link, wo man den her bekommt?
Danke schon mal

Also ich habe den ganz normal „großen“ rechts innen an die Seite geklebt. Passt nicht genau rein, erkennt aber trotzdem den Tag an der Seite.

Der soll auch gut funktionieren.

Ich habe diesen auch schon verwendet, und kann bestätigen, dass er sehr zuverlässig funktioniert. Die Empfindlichkeit ist besser und es werden alle RFID Karten, Tags und Aufkleber die dem Mifare Standart entsprechen zuverlässig gelesen und beschrieben. Da ist der höhere Preis schon gerechtfertigt.

ich habe diesen immer benutzt.

Danke für das Feedback. Ich brauch was wirklich kleines in der geplanten Box. Daher habe ich jetzt mal den MFRC522 bestellt…

Hast du damit schonmal Probleme gehabt? Ich habe gerade 3 Stück getestet und bekomme immer
Com Error 1
Firmware Version: 0x0 = (unknown)
WARNING: Communication failure, is the MFRC522 properly connected?
Mit dem Reader aus dem AZ Delivery Set läuft alles einwandfrei. Die LED von dem Reader leuchtet.

Hey zusammen,

bin leider jetzt erst dazu gekommen mich der Box zu widmen und bräuchte eure Hilfe.

Bin absolut kein Held was solche Elektronik Sachen angeht und bekomme es leider nicht hin.

Ich habe alles erstmal alles so verkabelt, damit ich es für eine zweite Box auch umsetzen kann. Viele Dupont Kabel als Verlängerung oder zum nachträglichen abstecken/umstecken. Daher sind die Farben auch noch nicht sauber (von den verbundenen Kabeln).

Bilder füge ich für das bessere Verständnis bei. Ich hoffe die gemachten sind ausreichen.

An dem Board von der Box ist mir leider am R1 die Verbindung abgerissen, deshalb habe ich es direkt am Knopf unten links (wo B- steht) angelötet. Somit läuft R1 und FB2 von Board mit dem VOUT vom Pololu zusammen und gehen am Tonuino auf 5V.

Vom Pololu geht OFF auf D8, GND (Pololu) auf GND (Tonuino) und das zwei unter GND auf dem Pololu (Kreis mit Strich nach unten und dann links) ebenfalls auf GND von Tonuino.

Wenn ich nun eine Powerbank (Intenso S10000-C) an das Board der Box anschließe, geht direkt alles an (Box macht ein komisches Geräusch beim Start). Ich kann mit der Karte die Musik starten und über die Knöpfe auch Start/Pause, Lauter, leiser bzw. nächstes und vorheriges Lied drücken. Beim Power-Knopf startet die Box neu und ich muss die Karte neu auflegen. Halte ich die Power-Taste gedrückt, schaltet sich alles aus und lässt sich aber anschließend nicht mehr neu starten.

Liegt das an der Firmware die ich irgendwann mal draufgespielt habe und muss ich da noch was ändern?

Ist es ansonsten von der Verkabelung alles richtig oder habe ich grundlegende Fehler gemacht?

Bitte seht von meinen bescheidenen Lötskills




ab :slight_smile:

Vielen Danke und beste Grüße

Hallo @maddig
ich glaube einen Fehler zu sehen, das bekomme ich nun aber nicht mit Handy so genau geschaut.

Kannst du zu deinen Beschreibungen mal noch verständlicher schreiben was wo hin geht.
Etwa

Board R3-blau - grün - tonuino A1

Ganz wichtig sind mir die GNDs und was du auf dem Board in der Nähe des USB getan hast

1 „Gefällt mir“

Hey @raznz_snasna,

vielen Dank für die Rückmeldung. Ich gebe mein bestes :slight_smile:

Board R4 - blau - braun - Tonuino A0
Board R1 (vom Power Button direkt) - grün - grün - Tonuino 5V (mehrere Kabel)
Board R2 - gelb - orange - Tonuino A2
Board R3 - orange - gelb - Tonuino A1
Board FB2 - rot - grün - Tonuino 5V (mehrere Kabel)
Board FB3 - grau - grau - Tonuino GND
Pololu VOUT - blau - grün - Tonuino 5V (mehrere Kabel)
Pololu GND - lila - lila - Tonuino GND
Pololu Kreis mit Strich nach unten und links - hellgrau - hellgrau - Tonuino GND
Pololu OFF - weiß - weiß - Tonuino D7

Die Kabel würde ich wie gesagt noch alle sauber in einer Farbe verkabeln wenn es läuft.

Auf dem Board ist U1 entfernt und die Bahnen zwischen R4 und R1 sowie R1 und R2 habe ich durchtrennt.

Viele Grüße und Dankeschön

EDIT:
Hab gesehen dass ich oben geschrieben habe, dass Pololu Off auf Tonuino D8 geht. Das habe ich falsch abgelesen. Er geht wie in diesem Post geschrieben auf D7

EDIT2: Beim Boars sind mir auch beide Lötverbindungen abgerissen. War ne dämliche Aktion meinerseits… Deshalb direkt runtergelötet um die Verbindung herzustellen. Die Bahn ging von Lötpunkt auch dort runter zum USB Port

Erste Version

Der ist falsch.
Der ist das Signal vom Power-Button.
Das habe ich oben schlecht formuliert.

Der darf nicht an 5v,der muss an Anschluss A vom pololu.
Als du ihn gedrückt hast, hast du einen Kurzschluss verursacht…

Den kenne ich nicht.

Aber jetzt habe ich geschaut wie die Kontakte noch so heißen…
Ach verdammt ist das witzig :smile: :smile: :smile:

Ok… Weiter geht’s…

Jetzt nochmal von vorne und richtig

Das kommt ganz weg.

Das vom tonuino ab und an dein Kreis strich am pololu. Auch mit „A“ beschriftet.
Eventuell kommt der auch zusätzlich an A5 vom tonuino, zum normalen abschalten. Aber jetzt noch nicht, vorsehen kannst du es aber.

Für deinen Edit 2 mach bitte ein Foto, da kann ich dir nicht folgen

1 „Gefällt mir“

Hey, jetzt funktioniert er. Die An-Aus Taste aber leider noch nicht. Liegt das an der Programmierung?

Hier ein Bild von EDIT2.


Ist das besser für dich?

Viele Grüße

EDIT:
Habe nochmal eine Blöde Frage. Den USB Anschluss am Board würde ich gerne nutzen um die Powerbank zu laden. Ich gehe von der Poewerbank-OUT auf den Tonuino. Doch wie komme ich vom Board USB zur Powerbank-IN um sie zu laden?

Nur an, nur aus oder garnicht?

Darüber bin ich gestern leider nicht gestolpert…

Nimm die beiden und „lade“ damit die Powerbank.
Am besten du nimmst dir ein USB Kabel das in die Powerbank zum Laden passt, schneidest die andere Seite ab und lötest die rote Ader dort drinnen an FB2 und die schwarze Ader an FB3.

FB3 sieht wirklich nicht gut aus.
Alternativ kannst du etwas weiter oben wo die „Hülle“ der SD-Karte aufs Board kommt deinen Draht anlöten.

1 „Gefällt mir“

Das mit dem USB-Kabel teilen und an beide dranlöten ist ne gute Idee. Hätte ich auch selbst drauf kommen können :sweat_smile: Sehr gut. Danke!

Der An-Aus geht gar nicht. Weder bei kurzem Druck noch bei langem passiert was.

Und wie bekommst du sie nun an?

Wenn ich das USB Kabel anschließe geht sie direkt an. Wenn ich auf den An/Aus Knopf drücke passiert nichts. Ich sehe auch keine Reaktion bei der Tonuino LED.

Und sorry für die späte Rückmeldung. Habe keine Mail bekommen, dass du geantwortet hast :face_with_raised_eyebrow:

Und wenn du den USB abzieht bleibt sie auf Akku an oder geht sie wieder aus?

Wenn ich den Akku und zusätzlich per Netzteil anschließe, geht sie immer an. Egal was ich zuerst anschließe. Es ist auch egal was ich als erstes abziehe. Bleibt solange an bis beide Kabel ab sind

Es ist vollbracht! Sogar deutlich vor dem 24. :laughing: Und das Beste - es klappert nichtmal irgendwas!

Variationen

  • LiFePo4 Akku mit Laderegler statt dem originalen LiIon Akku
  • Ich habe den Powerbutton ganz von der Platine entfernt, und mit dem „Button-Anschluss“ des Pololu Switches verbunden, dass ich die Box damit sowohl ein- als auch ausschalten kann. Shutdown Timer funktioniert auch.
  • Power-Led und Led vom Laderegler in der Vorderseite integriert (ohne Bohren, nein, nicht mit mir!)

Learnings

  • Diese kleinen Lötpads auf der Platine reißen wirklich leicht ab!
  • Was ist ein Pull-Up. Bzw. wie umgehe ich den Fehlenden auf dem Mini Rfid Reader
  • Heißkleber ist super
  • Um das Plastik der Box zu bearbeiten, funktioniert ein alter Cutter erhitzt mit einem Flambiergerät (aka Bunsenbrenner) wunderbar. Ich musste die Halterung der untersten Schraube (und alles vom Originalen LiIon-Akku) entfernen, um den Akku von @Eremit_LiPos unterzubekommen.
  • Ich musste die Platine von den Leiterkartenpiraten etwas mit Schleifpapier bearbeiten, dass sie zwischen die „Rippen“ der Box passt. Sie war vorher vielleicht nen halben mm zu breit.

Offene Frage

  • Wie zum *** ist der GND der Komponenten auf der originalen Platine verbunden? Gibts da ne „geheime“ unsichtbare Verbindung „innerhalb“?

Fazit

  • Ich habe unvernünftig lange für das Projekt gebraucht
  • Durch das Erfolgserlebnis (alles läuft so, wie ich es mir vorgestellt habe), hat es sich aber total gelohnt und viel Spaß gemacht
  • Box 2 sollte ich so schnell wie möglich umbauen, bevor ich wieder die Hälfte vergessen habe

3 „Gefällt mir“