Kein Ton - und keine Idee mehr

Guten Tag,

mein TonUINO macht keinen Ton und ich habe keine Idee mehr was ich noch prüfen soll. Vielleicht hat noch jemand eine gute Idee oder kann mir anhand der Bilder der Platine (ich bin Lötanfänger) sagen, was ich falsch gemacht habe - bzw wo ich anfangen sollte zu suchen.

Wenn ich den TonUINO mit seriellem Monitor starte, bekomme ich genau die Ausgabe, die ich laut FAQ auch bekommen sollte. Alle drei Knöpfe werden laut Monitor-Ausgabe erkannt. Wenn ich eine RFID-Karte auflege, bekomme ich auch genau die Ausgabe, die ich laut FAQ erhalten sollte. Es gibt keinen Com-Error oder sonstige Fehler. Einziges Problem ist der fehlende Ton.

Der DFPlayer ist vom Typ „GD3200B“. Liegt hier ein mögliches Problem?

Die Ordner „mp3“ und „advert“ sind vorhanden und alle Ordner und Dateien sind wie im FAQ angegeben beschriftet.

Ich habe den DFPlayer und den Lautsprecher schon jeweils ausgetauscht, um den Fehler weiter einzugrenzen.

Wo sollte ich denn jetzt am besten mit der Fehlersuche weitermachen?

Hier die Ausgabe nach Test der Knöpfe und des RFID-Lesers:

 _____         _____ _____ _____ _____
|_   _|___ ___|  |  |     |   | |     |
  | | | . |   |  |  |-   -| | | |  |  |
  |_| |___|_|_|_____|_____|_|___|_____|

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
0
Firmware Version: 0x92 = v2.0
=== playShortCut()
3
Shortcut not configured!
=== volumeDown()
14
=== setstandbyTimer()
0
=== volumeUp()
15
Card UID: C9 A2 4C C2
PICC type: MIFARE 1KB
Authenticating Classic using key A...
Reading data from block 4 ...
Data on Card :
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00




Das ist ziemlich wahrscheinlich. Siehe #hardware FAQ, letzter Punkt. Dort ist auch ein Thread verlinkt wo tapfere Recken den Chip ans laufen gebracht haben, aber es ist nicht wirklich ein Spaziergang… je nachdem wie viel Erfahrung man hat.

Deine gepostete Ausgabe endet etwas früher als die im Guide für Troubleshooting. Entweder hast du nichts alles kopiert oder die Ausgabe entspricht nicht dem Beispiel, denn gerade die Nummern am Ende zeigen, welcher Track abgespielt wird. Wenn nichts abgespielt wird, sollte bei Drücken der Playtaste auch nichts in der Konsole angezeigt werden.

Tatsächlich endet die Ausgabe nach dem von mir geposteten Ausschnitt. Ich dachte das wäre normal, wenn ich danach keine weiteren Tasten mehr zur Auswahl drücke.

Also ich habe jetzt tatsächlich drei verschiedene DFPlayer (hätte ich mich da mal anständig informiert…).

Wie beim „GD3200B“ habe ich mit dem „MH2024K-16SS“ genau das selbe Verhalten.

Mit dem JL („AA20HF-J616-24“) bekomme ich zumindest beim Einschalten das standardmäßige Piepsen, mehr aber auch nicht. Die Ausgabe ist hier etwas anders:

 _____         _____ _____ _____ _____
|_   _|___ ___|  |  |     |   | |     |
  | | | . |   |  |  |-   -| | | |  |  |
  |_| |___|_|_|_____|_____|_|___|_____|

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
0

Com Error 1
Firmware Version: 0x92 = v2.0
=== playShortCut()
3
Shortcut not configured!

Com Error 1
=== volumeUp()
16

Com Error 1
=== volumeDown()
15

Com Error 1
=== playShortCut()
0
Shortcut not configured!
Card UID: C9 A2 4C C2
PICC type: MIFARE 1KB
Authenticating Classic using key A...
Reading data from block 4 ...
Data on Card :
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00


Com Error 1
=== setupCard()

Com Error 1
=== voiceMenu() (99 Options)

Com Error 1

Kann das auch am Player liegen oder habe ich noch irgendetwas anderes verbockt?

Ich bestelle jetzt jedenfalls schon einmal der vierten DFPlayer (vom Typ MH-ET LIVE) in der Hoffnung, dass es dann einfach klappt.

Hast du mal versucht die Speicherkarte neu zu formatieren oder mal eine andere Speicherkarte verwendet?

1 Like

Ich habe sie mehrfach neu formatiert. Morgen kann ich mal versuchen, eine andere SD-Karte aufzutreiben und es mit der dann noch versuchen.

Mit letzterem sind die Erfolgsaussichten ohne Modifikation an der Software (Library z.b.) am vielversprechendsten. Vielleicht liegt es nur an der SD Karte.

Also ich habe jetzt eine andere SD-Karte genommen und auf genau die selbe Art und Weise bespielt. Siehe da, ich habe keinen ComError 1 mehr und höre die Tonausgabe. Das hätte ich nie geglaubt, zumal die andere SD-Karte ziemlich neu war und ansonsten keine Probleme macht.

Vielen Dank an alle für die großartige Hilfe.

1 Like

Vielleicht war daß auch genau das Problem. Neue Karten sind vielleicht zu neu für die recht abgehangene Technik im DFPlayer.