Hello! Please help! shortcut not configured

Gutten tag! Hello! I was wondering if anyone can help me? I’ve got so far with Google translate and Youtube as I don’t speak German and have searched pervious posts here about a message I keep getting: Shortcut not configured.

I read a previous post to check that Busy was connected to DP4 which I’ve checked. Also checked the 3 switches; the volume buttons work but the play button brings up the same message: shortcut not configured.

Any help would be greatly appreciated by a novice who is learning as she goes! :sweat_smile:

Hi, glad you’re here. First of all a little tip, use deepl.com instead of Google Translate. The message you see is not an error. It says that you have not configured a startup sound. Internally, the same mechanism is used as with key shortcut. According to the monitor output, your music box should work properly.

That is ok. There is the possibility to configure one of the three (five) buttons instead a RFID-card. "Shortcut not configured means that you haven’t done this.

Hi thanks for the tip re deepl!

Sorry how do i configure a startup sound? I have only got 1 mp3 file as i just want to test that it works first. I have copied the 2 mp3 folders from github and the mp3 file that ive put is in another folder

advert
mp3
001 --> 001.mp3

any help would be appreciated!

Wrong folder name, just saying. It needs to be two digits! See #hardware FAQ.

As for the startup sound: admin menu, shortcut menu, last option in that menu.

Hi stephan! yes i realised my folder should only be 2 digits :sweat_smile:

i’m really sorry but I have no idea what you mean? :sleepy: :worried: I think I’ve obviously missed something on the tutorial?

So when I put a new rfid tag, no sound comes out to give instructions to register a card BUT if I press volume button, its plays ‚1‘ then my mp3. If I hold and press the play button it then says „OK single track, use the volume to select the track and press pause. Hold pause to cancel“ I tried that and nothing happens, its says „shortcut not configured“

really appreciate your help!

Ann

You have a COM error 6. That is saying, that a file (mp3) is missing or wrong named. The folders mp3 and advert are filled correctly? Also you have renamed your folder 001 to 01? Please doublecheck.

Press all three buttons for long and at the same time, the you can enter the admin menu.

1 Like

To get to the Admin menu you have to press all three buttons.
This topic is a good overview of the functions Übersicht der Bedienung TonUINO.
But Com Error 6 means there is a file mismatch. Did you change the name of the folder from 001 to 01?

1 Like

Hi Manu! yes I changed the folder 001 to 01 but I downloaded the English voice commands for Advert and the MP3 folder instead of the German ones. I have been able to access the menu but not the admin menu because I think the audio commands do not appear to match what is on my output screen? When I press alll 3 buttons, its says the instructions to use the volume buttons to select which option and press play button to confirm, but as soon as I press the volume button its says „preference saved / audio book / preference reset completed / appearance menu terminated / set up maximum volume“ It does not say „admin menu“

I downloaded the English Advert and mp3 folder from here

I’m thinking the mp3s are not

matching what the program is?

I’m so sorry to keep asking! :sleepy: Feel i’m nearly there, its just the final missing piece of the puzzle!! :sweat_smile: :sweat_smile: Really appreciate all your help everyone!

You are using the speech files from @stephan’s fork but using the official software from @Thorsten. There is a mismatch between the offical Tonuino software and stephans fork. I think, stephan is not using the same numbers for the speech files. That causes your problems.

Yes, you are right :wink:

From my GitHub page:

Audio Messages

TonUINO only functions correctly, when there is the correct ( as in matches the firmware ) set of audio messages on the SD card. These are the folders advert and mp3 .

As @manu said, you are using incompatible audio message files. Either switch the firmware or the files.

Thanks everyone! I’ve got it working!! wooo!!! :partying_face: :partying_face: :partying_face:

Super pleased as this is my first arduino project and I have no experience in electronics! :sweat_smile:

2 Like

And then you choose a German-speaking one as your first project? Respect! And respect to @Thorsten , it really seems to be a do-it-yourself jukebox for everyone

3 Like