Fehler beim Testaufbau

Erstmal Danke an den Macher der Box und die Zeit die er in das Projekt steckt.
Ich habe mich auch entschlossen dieses Projekt umzusetzen, allerdings bekommt der DFPlayer noch einen Class D Amp hinterher. Das ganze wird in ein altes Röhrenradio eingebaut und soll weniger für Kids sondern eher in der Küche als „Guten Morgen Radio und Musik“ seinen Dienst erweisen.

Meine Kenntnisse in der Programmierung sind eher bescheiden, den Rest kann ich aber.

Ich habe beim Testaufbau folgende Probleme:

Nach dem Start kann ich eine Karte oder chip auflegen und bekomme die Ansage „Karte nicht bekannt, bitte Ordner wählen“ ich wähle Ordner 1 (Masse auf A1) und bestätige (Masse auf A0),
Dannach bleibt es etwa 40 sek ruhig und der DFPLayer spielt aus diesem Ordner Titel 1ab.

Screenshot Monitor Arduino IDE (Android smartphone)

Die Hardware ist bereits einmal komplett durchgetausch, auch habe ich immer etwa 30 Player unterschiedlicher Margen hier liegen. SD Karten habe ich von transcend und sandisc ausprobiert, beide mit gleichen Ergebnis. Nanos hab ich auch getauscht, auch mit gleichem Ergebniss.
(ich hab die Chinaclone 386 und nen älteren der mit old Bootloder bespielt werden muss.

Normnalerweise benutze ich für meine Spielerein meine Handy IDE (reicht aus) in diesem Fall kommt der Code vom Notebook auf den Nano. (Händy machte probleme beim kompilieren)

Ordnerstruktur ist wie beschrieben (1 zu 1 Kopie aus der Github Zip).

Ich bin jetzt am Ende mit meinen „Künsten“ und hoffe auf ein wenig Unterstützung…

Danke im Vorraus!

Stefan

Die 40 Sekunden Pause ist nicht normal. Da müsste man checken woran das liegt. Hast du das anlernen überhaupt beendet? Karte auflegen, Ordner wählen, bestätigen, Widergabemodus wählen, bestätigen. Karte die ganze zeit auf dem Reader gelassen?

In letzter Zeit häuft sich auch dieses Problem (siehe #hardware FAQ):

  • Manchmal ist der DFPlayer schlampig verlötet so daß der TX Pin fälschlicherweise Kontakt zum SD-Kartenslot hat und damit auf GND gezogen wird. Beispiele inkl. Fotos und Hilfe zur Behebung gibt es hier und hier.

Nachtrag:

Das speichern funzt nicht, … er meldet sich mit „schade, das hat leider nicht geklappt“…
Hab noch mal komplette Hardware getauscht…

Karte die ganze zeit auf dem Reader gelassen? Wenn ja, mal mit dem Abstand (2-3 Bierdeckel o.ä.) experimentiert?

mh… mit den hässlichen blauen runden Rfids funzt es… ust n problem mit den ksrten bekannt?

Mir den unterstützen Karten ist kein Problem bekannt. Aber deine Tastatur würde ich mal checken. :wink: SCNR

lol… das war eben mit dem Handy geschrieben…

Einige Fernost Karten haben ein Problem. Die RFIds Tags funzten tadellos. Ich habe die mit dem Smartphone ausgelesen, das Dump gespeichert und dieses Dump auf die Karten geschrieben. Funzt jetzt…

Ich habe 60 graue Haare mehr…

Grüsse stefan

1 Like

Das ist die Hauptsache um den Sonntag noch zu einem Erfolg zu machen!