AiO nach Einbau dauerhaft an

Hallo zusammen,
ich habe endlich eine Platine ergattern können und habe nacherhalt auch sofort losgelegt. Software flashen, SD-Karte bestücken, restliche Komponenten anstöpseln - alles kein Problem.
Leider habe ich auch den Bug vom AZ-Delivery Kartenleser, dementsprechend habe ich hier bereits einen neuen geordert.
Dennoch habe ich bereits die Komponenten ins Gehäuse einbauen wollen.
Nun musste ich leider feststellen, dass die Platine seitdem dauerhaft an ist, sobald diese Strom hat. Auch der Reset-Knopf bringt nicht den gewünschten Zustand.
Hatte schon mal jemand dieses Problem (ich habe leider nicht mit Hilfe der Suche etwas passenden gefunden)? Handelt es sich hierbei um einen Hardware Defekt?

Kleiner Nachtrag:
Die Buttons funktionieren nicht mehr im Akkubetrieb und der Kartenlesen geht nicht ohne Akku.

Vielen Dank und beste Grüße
Jan

Den Jumper vom Button-Board hast du wie im Quick-Start-Guide beschrieben abgezogen? Wenn PBP und PBN verbunden sind, kann die Platine nicht abschalten.

Vielleicht machst du auch mal ein Bild von deinem Aufbau und den Lötstellen.

Jumper ist gezogen. Hat ja auch soweit alles außerhalb des Gehäuses funktioniert. Die Lötstellen kann ich gerade nicht fotografieren, ist im Gehäuse verschraubt.

Hast du den Buttonadapter irgendwie gesichert? Da kann leicht ein Kurzschluss passieren, wenn der zum Beispiel gegen den Lautsprecher oder gegen die Platine kommt.
Wenn das passiert ist, kann es natürlich sein, dass etwas kaputt gegangen ist.

Hast du denn den Standby-Timerm ueber das Adminmenü aktiviert?. Wenn nicht kommt auch das Ausschaltsignal über den Standby-Timer nicht.

Hatte ich bisher nicht, weshalb ich das nicht ausschließen kann, dass es zum Kurzschluss gekommen ist.

Standby-Timer ist aktiviert, Platin bleibt aber eingeschaltet.

Welche Software verwendest du? Hast du da irgendwas geändert? Ein Auszug der Konsolenanzeige könnte auch hilfreich zur Eingrenzung des Fehlers sein. Es muss nicht zwingend ein Hardwarefehler sein, wenn es nicht funktioniert.

Bei welcher Software geht die Platine denn von allein an, nachdem man den Reset-Taster gedrückt hat? Denn dann sollte die Platine doch unabhängig von der Software abgeschaltet bleiben, oder?

@Gute_Laune
Ja, stimmt. Durch die Software wird die Platine natürlich nicht eingeschaltet. Aber wenn sie nicht abschaltet, kann es auch an der Software liegen.
@Jan.H Geht die Platine auch automatisch an, wenn der Stecker zu den Buttons abgezogen ist?

1 Like

Ja, die Platine schaltet sich auch ohne die Buttons sofort ein. Ich habe auch nochmal den Online Updater drüber laufen lassen, allerdings ohne Veränderung.
Hier ein Auszug aus dem Monitor (hier war nichts an der Platine angeschlossen, bis auf das USB-Kabel zum PC):

TonUINO Version 2.2
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 0
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
0

Com Error 1
Firmware Version: 0x0 = (unknown)
WARNING: Communication failure, is the MFRC522 properly connected?
=== playShortCut()
3
Shortcut not configured!

Com Error 1

Leider kann man hier auch keine Ursache erkennen.

Das legt doch mehr einen Hardwarefehler auf der AiO Platine näher. Bitte kontaktiere @stephan , ob da die Möglichkeit besteht die Platine zu Überprüfen und ev. zu Reparieren oder Tauschen.

Hier war ein mosfet defekt. Bitte achtet darauf mit den DIY Adaptern keine Kurzschlüsse zu erzeugen. Die sollten genauso befestigt werden wie alle anderen Platinen im Gehäuse auch. Löcher sind ja vorhanden…

4 Like

Auch hier nochmal vielen lieben Dank an alle Beteiligten!

1 Like