Wieder mal Anfängerfragen - Down-Knopf


#1

Hallo Leute,
ich hab ein paar Fragen, die ich in der SuFU und der FAQ nicht klären konnte. Als Elektroniklaie komme ich selbst nicht weiter. Mein Aufbau besteht aus Thorstens toller Platine und der Hardware von AZdelivery sowie Arcade-Knöpfen. Nach mehreren Lötleichen habe ich jetzt ein halb funktionierendes Exemplar mit der DEV-Software drauf. Einige Karten konnte ich anlernen, Ordner auf der SD-Karte sind auf der Hauptebene von 01-99 erstellt, die verknüpften Dateien kann ich auch abspielen. ABER: der play/pause-Knopf und der lauter/next-Knopf funktionieren, der leiser/back-Knopf funktioniert nur als “back”, die Lautstärke läßt sich nicht runterregeln. wenn ich den Knopf drücke und halte, leuchtet zwar die linke LED auf dem Arduino (TX?) auf, aber es passiert nix. Karten löschen funktioniert auch nicht, wenn ich bei gestoppter Wiedergabe lange pause/play drücke passiert nix. Jetzt brauche ich Hilfe… und würde außerdem gern noch auf KY-040-Drehgeber und/oder Fünf-Knöpfe-System umstellen, muß aber erst mal drei Knöpfe in den Griff kriegen. Vielen Dank!


#2

Könntest Du bitte ein Foto von Deinem Aufbau posten?
Und bitte mal die Ausgabe im Monitor posten.


#3


#4

hier noch mal das Gesamtkunstwerk. Die drei Knöpfe hängen an A0, A1, A2 und GND.
Mit “Monitor” kann ich noch nicht dienen, muß erst rausfinden wie das funktioniert.


#5

Oha! ; )
Dann entferne doch mal den Zurück-Button und versuche direkt an der Platine GDN mit A2 zu verbinden (testweise). Nur um auszuschließen, dass es nicht an der Verkabelung liegt.


#6

Habe A2 gegen GND kurzgeschlossen. TX flimmert, sonst passiert nichts, insbesondere wird es nicht leiser.


#7

Was steht in der Konsole? Bitte einmal posten.
EDIT: Min-Lautstärke gesetzt?


#8

Äh… ich bin Gynäkologe und hatte seit dem Schuco Philips Electronic Baukasten 1987 keine nicht-vorgefertigten elektronischen Geräte mehr in der Hand. Ist die Konsole jetzt das gleiche wie der Monitor ? Die Software ist die aktuelle DEV-Version, mit der Arduino-Mac-APP kompiliert und hochgeladen ohne jede Veränderung.


#9

Hehe, die meisten hier sind keine Elektrotechniker sondern ambitionierte Eltern ; )

Ja, mit Monitor und Konsole meine ich das selbe.
Aus den FAQs:

  • Ich bekomme jede Menge Meldungen wenn ich den Sketch kompiliere.
  • Das ist „normal“. Es handelt sich nur um Warnungen und das Programm wird ohne Probleme auf den Arduino übertragen.
  • Ich bekomme nur Hieroglyphen im Debugger angezeigt.
  • Bitte den Debugger auf „115200 Baud“ und „Sowohl NL als auch CR“ umstellen.
    (unten rechts im Fenster)
  • Wo finde ich den Debugger?
  • Arduino -> Tools -> Serial Monitor (CTRL+Shift+M)

#10

Ich würde um nicht komplett durcheinander zu kommen die GND (Masse) Kabel gegen schwarze tauschen.
Es reicht auch einmal mit GND von der Platine wegzufahren und Masse von Button zu Button weiterzuziehen.
Ich schätze da hast Du irgendwo einen Fehler eingebaut.
Beim anlernen einer neuenKarte konntest Du aber mit vor und zurück zwischen den Ordnern switchen?


#11

Wieder was gelernt: Monitor = Konsole = Debugger. Ich melde mich, sobald ich das hingekriegt habe. Vielen Dank schon mal bis hierhin für die rasche Hilfe!


#12

Ich konnte ursprünglich mit vor und zurück switchen. Von der Platine aus geht ein (blauer) GND weg, der dann dreifach zu den Schaltern führt. GND von Schalter zu Schalter habe ich auch schon probiert, selbes Problem.
Zum Verhalten des TonUINO: wenn ich alle Buttons entferne und A2 nach GND kurzschließe (mit so einem female-to-female-Kabel) dann passiert nichts. Wenn ich A0 gegen GND kurzschließe sagt er kurz “eins” und spielt dann weiter, auch wenn der Kurzschluß bestehen bleibt.
Der Debugger:


#13

Die Initial-Lautstärke ist 1, sollte aber zwischen Min und Max liegen.


#14

Viel schlimmer, Max ist 15 und Min 25. Das bringt sicher die Logik durcheinander. Das Flash sollte mal gelöscht werden. Das reinitialisiert die Settings. Adminmenü, letzter Punkt.


#15

Hab die DEV noch mal aufgespielt, die Einstellungen im Adminmenü gelöscht, die max- und min-Einstellungen angepaßt, jetzt gehts. Vielen Dank für die Hilfe!Serial%20monitor%20neu


#16

Perfekt! Dann viel Spaß.