TonUINO stoppt nach jedem Titel

#1

Hallo,
erstmal vielen Dank für die super Idee. Habe jetzt alles zusammen und es läuft auch, fast.
Bei mir (Version 2.01) bleibt der Tonio nach jedem Lied stehen, erst wenn ich die ±Taste drücke geht es zum nächsten Lied, am Ende wieder stopp, usw.
Dieses Problem kommt bei jedem Wiedergabemodus.

Vielleicht kann mir jemand helfen.

Viele Grüße

0 Likes

#2

Wenn ich mich recht erinnere, hab ich von dem Phänomen bisher noch nichts gehört. Was siehst du in der Console der Arduino IDE?

0 Likes

#3

Hallo Stephan,
nur Hyroglyphen |⸮@ǫ⸮⸮|P⸮⸮⸮⸮A⸮⸮|
|—|---|
|I⸮᠔⸮⸮⸮⸮⸮J⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮⸮b⸮⸮⸮⸮⸮⸮i⸮⸮⸮|⸮V⸮⸮|

0 Likes

#4

Also ich habe eben Arduino offen und wähle “Serieller Monitor”, ist das richtig?

0 Likes

#5

Richtig ja, aber stell unten auf 115200 um. Dann wird der Salat weniger. :wink:

0 Likes

#6

Ich schätze da ist die Baudrate nicht richtig eingestellt? Daher die Hyroglyphen…

Die Lied-Ende Erkennung läuft dann über die mp3.loop und mp3Notify::lastTrackFinished oder ähnlich (schreibe das gerade aus dem Kopf vom Handy).

Aber wenn der Serielle Monitor mal läuft wird einiges klarer :slight_smile:

0 Likes

#7

ok jetzt sieht es besser aus :slight_smile:

TonUINO Version 2.0
© Thorsten Voß
Firmware Version: 0x92 = v2.0
Card UID: E6 EB 3D F8
PICC type: MIFARE 1KB
Authenticating using key A…
Current data in sector:
1 7 00 00 00 00 00 00 FF 07 80 69 FF FF FF FF FF FF [ 0 0 1 ]
6 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
5 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
4 13 37 B3 47 01 01 02 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]

Reading data from block 4 …
Data in block 4:
13 37 B3 47 01 01 02 00 00 00 00 00 00 00 00 00

Com Error 255
0 Dateien in Ordner 1
Album Modus -> kompletten Ordner wiedergeben
Albummodus ist aktiv -> nächster Track: 2Albummodus ist aktiv -> nächster Track: 3

0 Likes

#8

Vielleicht liegt ja hier dein Problem. Wie hast du denn die Dateien benannt?

0 Likes

#9

Verzeichnisse
01
02
03
usw

Dateien
001.mp3
002.mp3
003.mp3
usw.

0 Likes

#10

Hey, Lötstellen am RFID Leser und an den anderen stellen überprüfen. Das Lötzinn muss den Kontakt komplett umschließen.

Hat bei mir wunderbewirkt.

0 Likes

#11

Karte wird doch ausgelesen… Irgendwas mit den Ordnern bzw. der Benamung im allgemeinen wird es sein.

0 Likes

#12

Ja, Karten wurden bei mir auch gelesen. Ich sah nur schon wieder den vom 255 Error.

0 Likes

#13

Würde auch sagen, mal die SD Karte formatieren und alles sauber neu aufspielen.

0 Likes

#14

ok, werde ich versuchen. Melde mich dann wieder, wird aber nächste Woche.

0 Likes

#15

Wäre auch mein Tipp gewesen - hatte das Problem beim Testen auch 1x.
Formatieren hat geholfen. Und immer auch auf andere Dateien achten, da sollte nach Möglichkeit nichts anderes auf der Karte sein.

0 Likes

#16

Hallo zusammen, es war der DFPlayer mini defekt. Habe meinen beim Zusammenbau kaputt gemacht und einen neuen bestellt und siehe da jetzt geht es.

Viele Grüße

0 Likes

Thema aufgeteilt, #17

9 Beiträge wurden in ein neues Thema verschoben: DFPlayer Mini mit USB Stick betreiben

0 Likes

#18

Moin,
ich hatte den Fehler auch, bei mir lag es daran, dass ich statt SD Karte einen USB Stick angeschlossen habe. Details dazu hier: DFPlayer Mini mit USB Stick betreiben .

bYe Martin

0 Likes