Taster funktionieren nicht mehr

#1

Hallo, meine Box lief eigentlich gut, bis ich auf die Idee kam, die Tastenbelegung ändern zu wollen (Laut leise bei einfach Druck, vorwärts, rückwärts bei langem). Aber soweit habe ich es erst gar nicht geschafft. Heute gab es ein Update für die JC_Button Bibliothek. Installiert auf 2.1.0 Nächster Schritt: Kaum, dass ich die DEV Version eingespielt hatte, waren die Knöpfe funktionslos, d.h. ein Drücken führte zu keinem Ergebnis. Also die Originalversion eingespielt, auch nix. Taster durchgemessen, da fließt Strom. Also die Box spielt schon Musik über die programmierten Karten ab, aber ich kann weder Pause, noch laut leise etc. verwenden, da die Taster wie gesagt funktionslos sind. Jetzt bin ich ziemlich ratlos. Hat einer von euch eine schlaue Idee?

Monitor liefert das:

 _____         _____ _____ _____ _____
|_   _|___ ___|  |  |     |   | |     |
  | | | . |   |  |  |-   -| | | |  |  |
  |_| |___|_|_|_____|_____|_|___|_____|

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 1
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
=== setstandbyTimer()
0

Com Error 1
Firmware Version: 0x92 = v2.0
=== playShortCut()
3
Shortcut not configured!

Com Error 1
0 Likes

#2

Sieht nach DFPlayer, eher Speicherkartenformatierung aus.

0 Likes

#3

Ja der com error 1 ist weg, an der sd karte liegt es nicht, die vorherige Bibliotheksversion funktioniert auch nicht

0 Likes

#4

Hast du den Link von @Christopher gelesen und die Lösung durchprobiert? Speicherkarte neu formatieren und bespielen. Achtung: bei der DEV gibt’s andere Sprachdateien.

0 Likes

#5

Hat du mal die vorherige Version der jc_button Library eingespielt? Wenn die Box noch Musik spielt wenn Karten aufgelegt werden, kann es ja an der SD Karte nicht so richtig liegen…

0 Likes

#6

Könnte schon sein, eben durch die geänderten Sprachdateien. Manche Dateien sind noch an alter FAT-Stelle zu finden, andere nicht. Wäre zumindest ein Versuch wert.

0 Likes

#7

Aber während was spielt muss man doch unabhängig davon lauter/leiser machen können oder nicht?

0 Likes

#8

Genau das geht ja nicht.

0 Likes

#9

Stelle den letzten funktionierenden Zustand wieder her. Alte Version von jc_button, die Firmware die du vorher hattest etc.

0 Likes

#10

Also, ich habe jetzt alles neu aufgespielt (DEV), die neue gegen die alte Bibliothek getauscht, die SD Karte formatiert, nochmal alle Verbindungen durchgemessen, jetzt funktioniert es. Vielen Dank für die Hilfe

0 Likes

#11

Jetzt wissen wir aber leider nicht was das Problem war. Gerade in Hinblick auf die Library wäre das aber schon wichtig. Wäre cool wenn du den Fehler nochmal reproduzieren könntest. z.B. nochmal die Library updaten.

0 Likes

#12

Ja, das mit der Reproduzierbarkeit ist so eine Sache. Aus heiterem Himmel habe ich heute, ohne an der Software geschraubt zu haben, wieder das gleiche Problem. Evtl. liegt es doch auch an der Hardware.

Edit: Es lag wohl an der Stromversorgung. Zumindest beim erneuten Auftreten.

0 Likes