Probleme beim beschreiben der Karte


#1

Hallo,

habe ein Problem und zwar kann ich keine Karte beschreiben.

Es läuft so ab…

Oh eine neue Karte…

  • Ordner ausgewählt und mit Play bestätigt
  • Spielmodus gewählt und mit Play bestätigt
    Jetzt sagt die Stimme—> Oh eine neue Karte…
    und alles fängt von vorne an.

Die Karte liegt die ganze Zeit auf dem Reader.
hier mal ein Log

TonUINO Version 2.0
© Thorsten Voß
Firmware Version: 0x92 = v2.0
Card UID: D6 20 DD 1A
PICC type: MIFARE 1KB
Authenticating using key A…
PCD_Authenticate() failed: Timeout in communication.
Neue Karte konfigurierenTrack beendet5
Track beendet5

Com Error 6
Authenticating again using key B…
PCD_Authenticate() failed: Timeout in communication.
Card UID: D6 20 DD 1A
PICC type: MIFARE 1KB
Authenticating using key A…
PCD_Authenticate() failed: Timeout in communication.
Neue Karte konfigurierenTrack beendet255
Track beendet255


#2

Wie ist denn der Abstand zwischen dem Reader und deiner Karte?
Wenn die Karte direkt auf dem Reader liegt, dann klappt das gerne nicht. versuche mal den Abstand zu vergrößern (oder falls zu groß, dann verringern) und probier es dann noch einmal.


#3

und lass die Stimme ausreden. Hat bei mir geholfen als ich zu ungeduldig war


#4

Den Abstand zwischen Karte und Reader habe ich schon verändert.
Wenn der Abstand nicht in Ordnung ist gibt er ja auch eine Meldung wie “das hat jetzt nicht geklappt” oder so aus.

Aber er beginnt einfach mit der Einrichtung einer neuen Karte ohne eine Fehlermeldung .


#5

OK was teste ich Mal.


#6

was für Karten hast du denn genau?


#7

Die bei dem Reader dabei liegen und noch Aufkleber die ich vor einiger Zeit mal beim Ali bestellt habe.

Ist immer das gleiche egal mit welchen.

Habe mir eben das Video bei YouTube noch mal angesehn. Dabei ist mir aufgefallen das die Stimme bei mir die Ordner durchzählt ( eins )und nicht den ersten Titel anspielt.
Habe einen order ( 001) angelegt und MP3s ( 001.mp3 , 002.mp3 ) reingelegt.

ansonsten den “advert” Ordner und den “mp3” Ordner auf der Karte


#8

Die Ordner mit 01 bis 99 benennen, nicht 001… und darin dann die mp3s mit 001xyz.mp3 bis 255xyz.mp3 und wenn du auf Nummer sicher gehen willst, dann nur 001.mp3 - 255.mp3


#9

Oh ja das habe ich nicht beachtet.
Danke.

Jetzt sagt der den Ordner an und spielt das Lied an.

Leider besteht das Problem weiterhin.


#10

In der PDF von GitHub mit dem Schaltplan ist ne gestrichelte Verbindung vom Reader RST nach GND. Auf dem Schaltplan auf der Homepage ist die Verbindung nicht.

Was hat es damit auf sich?

Habe nach dem Plan von der Page alles gesteckt.

Hab mal zur Sicherheit ne Platine per Mail beim Thorsten bestellt.:joy:


#11

Das ist ein Grafikfehler und gehört da nicht hin.

Das ist sehr löblich :wink: , wird aber vermutlich dein Problem nicht lösen. Ich tippe auch auf ein Problem mit dem Abstand Karte<->Reader. Leg mal was dazwischen, so daß du auf 5-10mm Abstand kommst.


#12

Also…
Habe jetzt viele Abstände ausprobiert mit Papier falten , Kunststoff, Holz… Handy geht übrigens nicht das wird als NFC Chip erkannt:rofl:

Keine Veränderung.

Wenn ich die Karte nur kurz auflegen und dann wieder weg nehme kommt zum Schluss die Meldung … Blabla hat nicht funktioniert.
Habe alles nachgelötet und neu gesteckt. Hat auch keine Abhilfe geschaffen.

Ich glaube ich bestelle Mal neue Hardware. Evtl liegt da ja der Fehler.
Stimmt die Lieferzeit bei Amazon für das Set?

Ich geh jetzt schlafen n8 und danke für die Hilfe.


#13

Eventuell am ehesten neue Karten. Wenn man diesem Artikel hier glauben darf kommt die Fehlermeldung auch wenn der Authentication Key nicht mehr 0xFF ist sondern geändert wurde.


#14

OK…
Habe die Karte und den Chip tatsächlich Mal mit der Android App"NFC Tools" beschrieben um mich mit der NFC Geschichte mal zu beschäftigen. :roll_eyes: Neue Karten habe ich auch geordert.

Ich werde berichten. Danke.

Guten Rutsch ins neue Jahr :tada:


#15

Versuch Mal die Karten per NFC Tag Info auszulesen und sieh nach, was in den einzelnen Key blöcken drinn steht.


#16

Vermutlich wurden die in NTAG umformatiert.


#17

Das kommt beim Auslesen raus.

Frohes neues Jahr


#18

Sieht man leider nicht viel. Kannst du auch komplett auslesen? Ich gäbe dazu NXP Taginfo.


#19

Ja klar …


#20

OK wie vermutet sind deine Keys nicht mehr 0xFF. Also einmal neue Karten besorgen, es sei denn du kennst den aktuellen Key :wink: