PAM8403 knackt sporadisch und brummt leise


#1

Hallo,
ich wollte meine Box auf Stereo ausbauen, ich habe mir dazu den PAM8403 bestellt und verdrahtet.
Leider habe ich gleich beim einschalten einen leises Brummen. Zudem knackt er immer wieder.
einen 47mF Kondensator habe ich jetzt au schon mal angelötet. Leider ohne Verbesserung.

Ich verwende die 1.51 Platine an der Line Out

Hat jemand eine Idee was ich falsch mache? Könnte der Kabelquerschnitt ein Problem sein, verwende die Dupontkabel?


#2

Du hast vermutlich nichts falsch gemacht, ich habe auch schon mal so ein teil am dfplayer gehabt und hatte ähnliche Effekte. Versuche mal ganz nahe am pam vor die Eingänge (L und R) einen 100nF oder 220nF Keramik- oder Folienkondensator in reihe in die leitung zu schalten. Ich vermute mal du fängst dir da gerade die wildesten störsignale ein und versuche die leitungen so kurz wie moglich zu halten, spannungsversorgung direkt von usb oder powerbank abgreifen und am Verstärker mit 10uF Elko stützen.


#3

Versuch es so.


#4

Bei mir hat das Teil auch gebrummt ohne Ende, hab es aufgegeben. Lösungsansätze wären: Geschirmtes Kabel, isolierte Stromversorgung, Massetrennfilter.
Problem dabei, die meisten Sachen würden wohl mehr kosten als der Verstärker :wink:


#5

Was habt ihr als Alternative?


#6

das Knacken haben die Jungs von Raspberry basierenden Tonuino durch einen Massetrennfilter in den Griff bekommen

Vielleicht verschwindet da auch das Brummen


#7

Interessant, was steckt da wohl drin? Ein Kondensator?


#8

Vielleicht als zusätzliches Bauteil. :wink: Das wird wohl eher in Richtung (man verzeihe mir meine laienhafte Ausdrucksweise) galvanische Trennung oder sowas in der Richtung gehen.


#9

Wäre Interessant zu wissen ob es mit dem Arduino auch funktioniert. Ein Problem mit knacken habe ich nicht direkt, aber das Brummen stört gundsätzlich.


#10

Würde vermuten spule und Kondensator


#11

Oh doch so simpel? Interessant.


#12


Das ist glaube ich mein Ansatz Zudem werde ich ich die 100nf Kondensatoren in den Ausgang hängen.


#13

Das mit den Kondensatoren hatte ich ja leider schon ohne Erfolg getestet:


#14

Ich will ne combo testen aus, Leitungslängen, anderer Stromquelle, Kondensator…
Werde die Erkenntnisse hier teilen :smiley: Warte nun aber zuerst mal auf Teile


#15

Wenn du dich auf meinen Beitrag beziehst; da habe ich den größten nutzen von koppelkondensatoren gesehen, so wie es @paulaner gezeichnet hat.


#16

paule76 schrieb ‘brummt’.

Nicht verwechseln mit dem lästigen ‘Einschaltknacken’ oder dem ‘Rauschen’.

Brummen ist im tiefen Frequenzbereich, entweder Masseleitung, schlechtes Netzteil etc…
Rauschen (Noise) ist im höheren Frequenzband anzusiedeln und hat auch andere Ursachen.

Dieser Powernoisefilter den paule76 verwenden will, beseitigt das eventuell auftretende Rauschen, nicht das Brummen.

In meinem Bild sind wie schon Christopher geschrieben hat, Koppelkondensatoren geschalten, es sind keine Elkos, also unpolarisierte.

Ob damit das Brummen beseitigt wird ich weiß es selber noch nicht.
Ich warte noch auf meine Lieferung SMD Kondensatoren aus Fernost.
Ich habe auch in einigen Situationen dieses lästige Brummen.

  • über DAC an JBL BT Box, den Ladestecker der Lautsprecherbox in dem USB HUB, und die TonUINO über den Nano ebenfalls am USB HUB. Ziehe ich den Ladestecker des Lautsprecher raus, ist das Brummen weg. Eine Masseschleife (Brummschleife).

Abgeschirmte Kabel bringen nur dann Erfolg wenn die Schirmung nicht auf beiden Seiten aufliegt, also auch da keine Verbindung besteht (sonst wieder Brummschleife).

Wer steckt in den USB Kabel drin, das er 100% sagen kann es ist geschirmt oder nicht?
Darum gibt es bei Netzwerkkabel geschirmte/ungeschirmte.


#17

Auch sollte man unbedingt schreiben wie die Stromversorgung bewerkstelligt wird.

Hier nehme ich an mit Netzteil über USB.

  • Powerbank
  • USB
  • Stifte (Platine 1.51)
  • 5v Anschluß
  • USB und USB HUB (z.B.PC)
  • Netzteil USB

#18

Stimmt vergessen.
Der Strom wird durch eine Powerbank bereitgestellt.


#19

Dann ist das Einschaltknacken vom Modul. Siehe da oder bemüh die Suche.
Das Brummen ist beim Betrieb mit Powerbank (Akku) eigentlich unverständlich.

Ich hab noch was vergessen.
Wie erfolgt die Wiedergabe?

  • Lautsprecher an SPK
  • DAC und dann

Auch DAC verursachen Störungen, aber eher in höheren Bereichen der Frequenz.
Ich such mal nach der Schaltung.


#20

DAC und dann.

Das Tack Tack Tack hat meiner Meinung nach mit der Leistung zu tun die gezogen wird. Wenn ich lauter mache, tritt es deutlich häufiger auf. Dachte zuerst an ein Problem der Spannung die abfällt und somit der Chip Probleme bekommt. Deswegen der erste Test mit einen Kondensator.

Bin aber was Elektronik angeht unter den Laien anzusiedeln…