Noob braucht Hilfe, kein Ton

Hallo Community,

ich wollte für meine Söhne einen Tonuino bauen und ganz offensichtlich brauche ich kompetente Hilfe, um das Projekt hinzubekommen.

Was funktioniert nicht?

Ganz einfach, ich höre nichts, keinen Ton. Bis auf einmal, bei dem kontinuierlich „vierzehn“ gesagt wurde, bis ich die Stromzufuhr unterbrochen habe, danach kam aber nichts mehr.

Was funktioniert?

Der Arduino leuchtet grün, manchmal auch orange. Der RFID-Leser leuchtet rot. Der MP3-Player hat beim Karten ranhalten mal rot geleuchtet, macht er aber aktuell auch nicht mehr.

Was habe ich bisher gemacht?

Lötstellen geprüft (die schon von Haus gelötet waren, sehen sehr gut aus, die eigenen passabel).

Die Verkabelung zweifach geprüft. Schwierig allerdings beim MP3-Modul, da hier keine Beschriftung zu lesen ist.

Geprüft, dass ich einen 1000 Ohm Widerstand benutze.

Die Firmware neu aufgespielt, ohne Probleme.

Die SD Karte ist eine 32GB Karte in Fat32 mit der korrekten Struktur (mp3, advert, 01, 02 etc)

Was könnte es sein?

Ich könnte mir vorstellen, dass eine Verbindung nicht richtig hinhaut. Zum Beispiel die GNDs, die ich durch die Knöpfe durchschleife. Hier habe ich zum Teil mehrere männliche Jumper mit der gleichen Schraube festgeschraubt.

Müssen die Verbindungen von GND einen Kreis ergeben, oder reicht es, wenn alle miteinander gekoppelt sind? Bisher habe ich GND vom MP3 auf Schalter 1 auf Schalter 2 auf Schalter 3 UND GND RFID und von Schalter 3 auf GND Arduino

Oder hat der Lautsprecher (CTE-11W von chillitec, 8 Ohm) oder das MP3-Modul ein Problem?

Habt ihr Tipps für mich, wie ich dem Problem auf die Schliche komme?

Vielen Dank im Voraus.

LG djgauss

Was sagt die Konsole?

Vielen Dank für deine schnelle Antwort.
Wie komme ich den zur Konsole? :smirk:

Edith sagt: habs gefunden. Ich habe mal eine Karte rangehalten:
TonUINO Version 2.0
© Thorsten Voß
Firmware Version: 0x92 = v2.0
Card UID: E1 94 E2 20
PICC type: MIFARE 1KB
Authenticating using key A…
Current data in sector:
1 7 00 00 00 00 00 00 FF 07 80 69 FF FF FF FF FF FF [ 0 0 1 ]
6 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
5 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
4 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]

Reading data from block 4 …
Data in block 4:
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Neue Karte konfigurieren

Hier tut sich erstmal nichts. Dann kommt:
Neue Karte konfigurierenAuthenticating again using key B…
PCD_Authenticate() failed: Timeout in communication.

danach kann ich die anderen Tasten lang drücken und es kommt auch volume up / down.

Die Tasten scheinen zu funktionieren, der RFID Leser doch auch, wenn er die Karte ausliest, oderP. Aber die Tonausgabe geht nicht.

Ich bin auch noch ganz nah an den LS ran, er rauscht leise und es kommt auch leise ein Knacksen beim Ein- und Ausschalten.

Der Kartenleser scheint ja zu funktionieren. Beim auflegen sollte kommen „oh neue Karte blabla“. Und da sollte dann auch die LED auf dem Player leuchten (bedeutet es wird was gespielt). Leuchtet die nicht, stimmt was nicht. Keine Verbindung zum Player, Player kaputt, SD Karte kaputt, SD Karte falsch bespielt… kann vieles sein.

Meine Empfehlung (weil du dich ja selber als noob bezeichnest): Noobs sollten die Platine benutzen. Punkt. Damit schließt du mit einem Schlag alle Verkabelungsfehler aus. Wir sehen leider häufig, dass die Leute mit Wild West Verkabelung Probleme haben. Sind das dann Anfänger kommt schnell Frust auf. Das wollen wir ja mit der Platine vermeiden.

Zu deiner GND Frage: Nein GND muss keine Schleife sein. Es müssen halt alle GND verbunden sein.

Hast du die SD-Karte mal auf unsichtbare Dateien geprüft?
Versteckte Dateien anzeigen.

1 Like

Hi djgauss

Der DFPlayer bietet die Möglichkeit ihn per Taster zu steuern, dazu einfach GND mit IO_1 oder IO_2 kurz brücken, dann weiss man zumindest ob der Player spielen würde. Damit wäre dann glaube ich der Lautsprecher und auch die SD-Karte geprüft.

Als weiteren Punkt die RX und TX verbindung zum PLayer prüfen, auch die Lötstellen an den seriellen Wiederständen.

Beide Tipps hatte Christopher mir mal gegeben und das hat mur damals sehr geholfen (
Troubleshooting nach dem Löten - DFPlayer)

VG

1 Like

Also, vielen Dank für die Antworten.

  • SD Karte hat die richtige Struktur.
  • Platine werde ich bestellen, bin mir aber nicht sicher, ob es später dann noch geht (ich möchte, falls alles klappt, eine Powerbank, einen beleuchtete An/Aus-Schalter und ein Drehpotentiometer einbauen)
  • die anderen Sachen (Lötstellen) kann ich erst überprüfen, wenn die Kinder versorgt sind :slight_smile:
    Ich melde mich.

Vielen Dank, am Ende war der Widerstand wohl doch defekt. Mit einem neuen ging es erstmal.
Aber keine Sorge, ich werde bestimmt mit anderen Fragen noch einmal zu euch stoßen :wink: