MP3 wird nur angespielt


#1

Guten Tag,
ich bin im Bereich TonUINO und generell im Bereich Arduino neu.

Ich habe bereit zwei Phonieboxen gebaut. (Auf Raspberry Basis).

Nachdem ich herausgefunden habe durch dieses Forum, dass ich die RFID Karte die ganze Zeit beim Einlesen aufgelegt haben muss, hat das zuweisen des Ordners auch geklappt.
Wenn ich nun die RFID Karte auflege fängt er kurz an abzuspielen, etwa 5 Sekunden, dann stoppt das Abspielen. Ich kann auch Vor oder zurück Spulen und Lauter Leiser machen aber vollständig abspielen klappt nicht. Wenn ich nach dem stopp wieder Play/Pause drücke fängt die mp3 vom Start aus an.

Hatte das schon jemand? Woran lag es?
Was mache ich falsch?

Versucht habe ich auch schon die RFID Karte auf den leser liegen zu lassen aber das hat auch nicht geklappt.


#2

Das hatten wir glaube ich noch nicht.
Vielleicht mal die SD-Karte neu formatieren oder eine andere verwenden.


#3

Bitte mal den Output der Konsole Posten. (Arduino IDE, Button oben rechts, dann auf 115200 umstellen). Bei Posten bitte den </> Knopf verwenden.


#4

Danke für die schnelle Rückmeldung.
Werde ich beides mal machen und auch mal einen anderen Ordner testen.
Melde mich wieder.

Was habe ich nun gemacht:

  1. Zweite Karte angelernt, einen anderen Ordner zugeordnet.
    Ergebnis selbes Problem. Kurzes anspielen ca. 5 Sekunden. Danach geht die LED auf dem DF Player aus.

  2. Konsole gestartet.
    Hier kommt folgendes:
    TonUINO Version 2.0
    danach habe ich ein wenig gedrück da erste nichts weiteres kam.
    Dann Ausgabe gelöscht und ab dann Kartenwechsel:

    09:47:50.226 -> Card UID: 99 D5 4D 47
    09:47:50.226 -> PICC type: MIFARE 1KB
    09:47:50.226 -> Authenticating using key A…
    09:47:50.226 -> Current data in sector:
    09:47:50.226 -> 1 7 00 00 00 00 00 00 FF 07 80 69 FF FF FF FF FF FF [ 0 0 1 ]
    09:47:50.226 -> 6 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
    09:47:50.226 -> 5 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
    09:47:50.226 -> 4 13 37 B3 47 01 01 05 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
    09:47:50.226 ->
    09:47:50.226 -> Reading data from block 4 …
    09:47:50.226 -> Data in block 4:
    09:47:50.226 -> 13 37 B3 47 01 01 05 00 00 00 00 00 00 00 00 00
    09:47:50.260 ->
    09:47:50.294 -> 6 Dateien in Ordner 1
    09:47:50.294 -> Hörbuch Modus -> kompletten Ordner spielen und Fortschritt merken

Ergebnis Abspielen hört nach 5 Sekunden auf. (LED am Player geht aus.

Ich nehme jetzt mal eine weitere SD-Karte dazu und teste es nochmal neu.


#5

Von der Konsole her sieht das alles gut aus.


#6

Eine andere SD im FAT Format funktioniert.
Ich lösche nochmal die komplette Karte mit SD Formatter und spiele dann nochmal auf.

Weitere Frage:
Sollte nicht die RFID IDs auf der SD Karte irgendwo gespeichert und zugeordnet werden oder habe ich das nun falsch verstanden. Das stand so ähnlich in den Neuerungen drin.
Wo werden die sonst gespeichert oder wie kann man ggf. die Zuordnung nicht über die Taster machen?


#7

Nein. Ja. Was womit und mit welchem Modus verknüpft ist, wird auf den Karten/Tags/Aufklebern gespeichert.

Dort steht:

Um mehr als 100 Karten zu unterstützen wird die Konfiguration der Karten nicht mehr im EEPROM gespeichert sondern direkt auf den Karten - die Karte muss daher beim Anlernen aufgelegt bleiben!

Damit ist nicht die SD Karte gemeint.


#8

Okay danke für die Antworten.

Nach dem fomatieren der 32GB Karte funktioniert jetzt alles.


#9

Perfekt :+1: So soll es sein.


#10

:+1: da hatte ich ja den richtigen Riecher :wink: