Kelevra bastelt

828EEF4F-643D-4A1A-B519-12E07DB406C5 2E7DCB2D-CA77-4D35-94AB-1AD4F4ED7AAD 37C5030D-86E7-4CB2-A17A-3A0A42FC3F22 Hallo!
Ich hab nun auch meine ersten Komponenten erhalten und mal losgelegt:
Erstmal alles zusammengesteckt. Dann etwas in der Werkstatt gewühlt.
Mein Lötkolben scheint so ziemlich das letzte zu sein (30W) und das Lötzinn war halt mal günstig zu haben. Gelötet habe ich schon jede Menge. Meist eher sehr schlecht als recht… Jetzt muss ich mal schauen ob ich noch irgendwo nen Lautsprecher finde und natürlich die SD Karte bespielen. Meinen Dank schonmal an Thorsten - die Platine mit Zubehör, die Geschwindigkeit bis zur Lieferung sowie der Preis sind sehr fein! Frage: wie klemmt man die Kabel auf den Pins fest? Sorry, das erscheint mir ne dumme Frage zu sein, aber ich checks echt nicht.

Google mal nach „Jumperkabel“, dann wird einiges klarer :wink:
An die Lötstellen vom DF-Player solltest du noch mal ran. Hast du dir mal die in der Hardware-FAQ verlinkten Tutorials bzgl. Löten angesehen? Ich habe allerdings auch festgestellt, dass schlechtes Lötzinn sehr frustig ist. Ich habe ein gutes und damit geht es gefühlt 10x besser…

Das alter des Zinns ist nicht ausschlaggebend. Viel mehr die Zusammensetzung. Wenn jemand für zu Hause Lötzinn kauft, dann achtet darauf das es mit Blei ist (Pb). Mit dem Bleifreien wird sich jeder Anfänger mehr als schwer tun, da es einen höheren Schmelzpunkt hat.
Vorausgesetzt es gibt das noch zu kaufen, es wird seit Jahren Systematischaus dem Verkehr genommen.

Gibts z.B. bei Reichelt noch ohne Probleme zu bekommen. Die Auswahl ist aber trotzdem immer noch eine Wissenschaft für sich. Ich löte seit Jahren mit einer Minirolle aus dem Baumarkt… wenn die mal alle ist, steht ich da. :see_no_evil: Vielleicht macht jemand mal in #tipps-und-tricks einen Thread welches Lötzinn (also Zusammensetzung, Durchmesser, Flussmittelanteil usw.) zu empfehlen ist, mit (idealerweise) länger verfügbarer Bezugsquelle…

Im Hobby bereich stellt man denke ich kaum Unterschiede fest, außer dem Schmelzpunkt.
Der ist bei Bleifreiem Zinn teilweise stark unterschiedlich.
Und gerade die günstigen Kolben kommen damit kaum klar, dann klebt das Zinn am Kolben oder der Lötstelle fest.

Ein Tipp von mir noch, kauft ein Döschen Lötfet/Kolophonium und immer wenn ihr nachlöten müsst, gebt eine kleine Menge davon auf die Lötstelle. Dann muss kein extra Zinn zugeführt werden für ein sauberes Ergebnis.

Ein Beitrag wurde in ein existierendes Thema veschoben: Welches Lötzinn?

Hi!

Eine Anleitung zum Verbauen von Jumperkabeln hab ich nicht gefunden. Manche wollen die wohl löten. Im PC Bereich werden sie einfach aufgeschoben. Am TonUINO rutschen aber - vor allem die äußeren - immer wieder ab. (Hab einzelne Leitungen, keinen Block)

Ich habe den Treiber runtergeladen und auch das Programm. Im Programm die Bibliotheken geladen und die neueste Version installiert. Ich habe meine 32GB SD Karte am Mac initialisiert (MS DOS Fat Formatierung) und sie wird direkt am Mac erkannt. Den TonUINO allerdings per USB Kabel angeschlossen, wird die SD Karte (im TonUINO) nicht im Finder als Datenspeicher angezeigt. Habs mit 2 Kabeln getestet (eins überträgt mir sonst die Bilder von der Kamera auf den Mac). Ist das normal oder schon ein Fehler? Außerdem leuchtet die rote LED am MP3-Modul nicht. Die am Arduino und am RFID Reader aber schon. Wobei die am Arduino deutlich heller leuchtet als die am RFID Reader.

Ich habe dann weiter nach Anleitung die Tonuino.ino von Github runtergeladen, mit dem Programm geöffnet und dann auf „hochladen“ geklickt. Das ist erfolgreich gewesen. Aber wenn ich eine Karte auf den Reader lege, passiert nichts. Auf der SD Karte sind aber auch noch keine Daten. Müsste nicht dennoch schon eine Ansage kommen „diese Karte kenne ich noch nicht“? (wie im Video).
PS: Der Lautsprecher ist testweise unserem Hifi System entwendet (80W). Scheitert eine Soundausgabe daran?

Die Lötstellen hab ich teils nochmal überarbeitet. Hier ein paar Fotos zum Einschätzen:

Wenn die Kabel nicht halten kannst du die Pins mit einer Zange etwas rund biegen. So haben die Buchsen mehr widerstand. Das sieht dann aber nicht so schön aus. Alternativ kannst du auch ein anderes Kabel versuchen.

Das liegt oft an der (minderwertigen) Qualität der Jumperkabel. Ich hab auch solche und solche hier.

Das ist normal. Die SD Karte wird direkt am PC/Mac mit passendem SD-Card Reader befüllt.

Die leuchtet nur wenn was gespielt wird.

Wie soll das gehen, wenn die Karte noch leer ist? Du musst minimum die Ordner mp3 und advert von GitHub auf die SD Karte schreiben. Schau dir bitte die #hardware FAQ an. Dort ist das erklärt.

Ich hab das jetzt nochmal gelesen und die Karte mit den Ordnern aus GitHub bestückt. Es bleibt aber dabei - keine Soundausgabe. Zufällig hab ich gemerkt, dass, wenn ich das Kabel am RFID Reader vom PIN mit der Aufschrift „3.3V“ abziehe (zweites Bild), die rote LED am RFID heller leuchtet - so hell wie am Arduino. Mit dem Kabel angesteckt (3. Bild) leuchtet sie deutlich weniger hell. Ist das auch normal?

Welche Ausgaben erscheinen denn auf dem seriellen Monitor (vgl. FAQs)?

Einmal das hier:

Arduino: 1.8.10 (Mac OS X), Board: "Arduino Nano, ATmega328P (Old Bootloader)"

/Users/Toni/Desktop/Arduino/TonUINO-master/Tonuino/Tonuino.ino: In function 'void writeCard(nfcTagObject)':
Tonuino:566:20: error: 'w' was not declared in this scope
   Serial.println();w
                    ^
Mehrere Bibliotheken wurden für "DFMiniMp3.h" gefunden
 Benutzt: /Users/Toni/Documents/Arduino/libraries/DFPlayer_Mini_Mp3_by_Makuna
Mehrere Bibliotheken wurden für "EEPROM.h" gefunden
 Benutzt: /Users/Toni/Desktop/Arduino/Arduino.app/Contents/Java/hardware/arduino/avr/libraries/EEPROM
Mehrere Bibliotheken wurden für "JC_Button.h" gefunden
 Benutzt: /Users/Toni/Documents/Arduino/libraries/JC_Button
Mehrere Bibliotheken wurden für "MFRC522.h" gefunden
 Benutzt: /Users/Toni/Documents/Arduino/libraries/MFRC522
Mehrere Bibliotheken wurden für "SPI.h" gefunden
 Benutzt: /Users/Toni/Desktop/Arduino/Arduino.app/Contents/Java/hardware/arduino/avr/libraries/SPI
Mehrere Bibliotheken wurden für "SoftwareSerial.h" gefunden
 Benutzt: /Users/Toni/Desktop/Arduino/Arduino.app/Contents/Java/hardware/arduino/avr/libraries/SoftwareSerial
exit status 1
'w' was not declared in this scope

Dieser Bericht wäre detaillierter, wenn die Option
"Ausführliche Ausgabe während der Kompilierung"
in Datei -> Voreinstellungen aktiviert wäre.

und im seriellen Monitor das hier:

TonUINO Version 2.0
(c) Thorsten Voß
Firmware Version: 0x0 = (unknown)
WARNING: Communication failure, is the MFRC522 properly connected?

MFRC522 ist installiert.

Hier hast du wohl ein Zeichen eingetippt was da nicht hin gehört.

Es gibt Probleme mit deinem NFC Reader. Auch die Tatsache bzgl. der glimmenden LED die du beschreibst deutet darauf hin. Überprüfe die Lötstellen (ggf. auch die „ab Werk“) und schaue das alles gut verklötet ist und kein Kurzschluss vorhanden ist. Überprüfe auch das Kabel.

1 Like

Die Lötstellen sehen verbesserungswürdig aus. Mosi sieht zb gar nicht leitend aus.

Wo hab ich das W eingetippt und wie werd ich das wieder los? Hier mal ein paar Detailaufnahmen der Lötstellen am RFID Reader



In Zeile 566… einfach raus löschen.

Es wäre übrigens töfte, wenn du dir etwas Mühe gibst mit der Formatierung deiner Beiträge, so das man das alles vernünftig lesen kann und ich nicht alles editieren muss. Danke.

Oh! Das ist mir gar nicht aufgefallen! Wird gemacht! Sorry!
Und danke für die Zeilenangabe!

Edit: „w“ ist gelöscht und dann neu hochgeladen.
Es bleibt bei:

TonUINO Version 2.0
© Thorsten Voß
Firmware Version: 0x0 = (unknown)
WARNING: Communication failure, is the MFRC522 properly connected?

Mja das „w“ behebt das Reader Problem nicht, das war klar. Das ist entweder die Verkabelung oder irgendeine Lötstelle. Beides aus der Ferne leider schwierig zu diagnostizieren.

Habe nochmal alle Lötstellen am RFID Reader und dem Gegenstück am Arduino gelötet - keine Funktion. Dann die Kabel gegen ein neues Set von AZ Delivery gewechselt - siehe da, die rote LED leuchtet sofort hell auf und die aufgelegte Karte wird sofort erkannt. Es scheiterte also an den mitgelieferten Kabeln. Naja, wenns weiter nichts ist :slight_smile: Nun wird die SD Karte erstmal bestückt und dann gehts ja erst richtig los :slight_smile: Ich freue mich :slight_smile: Danke an euch und bis in Kürze :slight_smile:

EDIT: Ich hab mir das FAQ zur Hardware durchgelesen. RFID Karten müssen 13,56 MHz haben. Ihr habt ein paar mal Aliexpress verlinkt… scheint also nicht verpönt zu sein. Daher hier die Frage: Funktionieren die hier auch? Da steht was von MF Classic - also Mifare Classic?

1 Like

Mifare Classic geht, ja.