Bug oder nicht?


#1

Hallo,
Version Version 2.1 (xx.xx.xxxx) noch WIP
Schon in Version Version 2.0 (26.08.2018) public gemacht

  • Während der Wiedergabe wird bei langem Tastendruck auf Play/Pause die Nummer
    des aktuellen Tracks angesagt

Bei mir spielt der gleiche Track, aber bei jedem drücken der Taste sagt er den nächsten Track an, 1 dann 2 dann 3 usw.

Korrektur: 1. Track spielt, Ansage beim erstenmal lang drücken 1, aber bei jeden Druck eins weiter, 2 , 3, 4 …?
Danke paulaner


#2

kannst du mal bitte die Konsolen ausgabe dazu schicken?


#3
18:21:29.606 -> TonUINO Version 2.1

18:21:29.606 -> created by Thorsten Voß and licensed under GNU/GPL.
18:21:29.606 -> Information and contribution at https://tonuino.de.
18:21:29.606 ->
18:21:29.606 -> === loadSettingsFromFlash()
18:21:29.606 -> Version: 1
18:21:29.606 -> Maximal Volume: 25
18:21:29.606 -> Minimal Volume: 5
18:21:29.606 -> Initial Volume: 20
18:21:29.606 -> EQ: 1
18:21:29.606 -> Locked: 0
18:21:29.606 -> Sleep Timer: 0
18:21:29.606 -> Inverted Volume Buttons: 0
18:21:29.640 -> === setstandbyTimer()0
18:21:31.744 -> Firmware Version: 0x92 = v2.0
18:21:31.744 -> === playShortCut()3
18:21:31.744 -> Shortcut not configured!
18:21:33.620 -> Card UID: 39 ED 6A 48
18:21:33.620 -> PICC type: MIFARE 1KB
18:21:33.654 -> Authenticating Classic using key A…
18:21:33.654 -> Reading data from block 4 …
18:21:33.654 -> Data on Card :
18:21:33.654 -> 13 37 B3 47 02 01 02 00 00 00 00 00 00 00 00 00
18:21:33.654 ->
18:21:33.654 -> === disablestandby()
18:21:33.790 -> 246 Dateien in Ordner 1
18:21:33.790 -> Album Modus -> kompletten Ordner wiedergeben
18:21:42.644 -> === nextTrack()
18:21:42.644 -> Albummodus ist aktiv -> nächster Track: 2=== nextTrack()
18:21:48.356 -> Albummodus ist aktiv -> nächster Track: 3=== nextTrack()
18:21:51.320 -> Albummodus ist aktiv -> nächster Track: 4=== nextTrack()
18:21:54.042 -> Albummodus ist aktiv -> nächster Track: 5

Ich spiele immer noch Track 1 ab


#4

Bei der ‘Normal’ Version das Gleiche.

18:28:17.424 -> TonUINO Version 2.0
18:28:17.424 -> © Thorsten Voß
18:28:17.526 -> Firmware Version: 0x92 = v2.0
18:28:23.187 -> Card UID: 39 ED 6A 48
18:28:23.187 -> PICC type: MIFARE 1KB
18:28:23.187 -> Authenticating using key A…
18:28:23.187 -> Current data in sector:
18:28:23.187 -> 1 7 00 00 00 00 00 00 FF 07 80 69 FF FF FF FF FF FF [ 0 0 1 ]
18:28:23.221 -> 6 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
18:28:23.221 -> 5 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
18:28:23.255 -> 4 13 37 B3 47 02 01 02 00 00 00 00 00 00 00 00 00 [ 0 0 0 ]
18:28:23.255 ->
18:28:23.255 -> Reading data from block 4 …
18:28:23.255 -> Data in block 4:
18:28:23.255 -> 13 37 B3 47 02 01 02 00 00 00 00 00 00 00 00 00
18:28:23.255 ->
18:28:23.392 -> 246 Dateien in Ordner 1
18:28:23.392 -> Album Modus -> kompletten Ordner wiedergeben
18:28:28.938 -> Track beendet257
18:28:29.041 -> Albummodus ist aktiv -> nächster Track: 2Track beendet258
18:28:35.415 -> Albummodus ist aktiv -> nächster Track: 3Track beendet259
18:28:38.313 -> Albummodus ist aktiv -> nächster Track: 4Track beendet260
18:28:41.210 -> Albummodus ist aktiv -> nächster Track: 5Track beendet261
18:28:44.284 -> Albummodus ist aktiv -> nächster Track: 6Track beendet262
18:28:47.182 -> Albummodus ist aktiv -> nächster Track: 7

Die Konsolenanzeige ist aber falsch, der Title 1 spielt immer noch und ist nicht beendet.


#5

Eine Frage, mein Englisch ist bescheiden.
Was wurde geändert vor 10h im GitHub an der Tonuino.ino?

Danke

Update: ich weiß es jetzt ‘{}’ Play/Pause Button

@Thorsten
meine Frage wurde nicht beantwortet, vielleicht ist sie untergegangen.

Noch eine, wann wird aus der DEV Version wieder eine Offizielle?

@stephan
Wird noch das eine oder andere Gimmick der offiziellen oder DEV Version in deiner Software erscheinen?

Danke paulaner


#6

Kann es sein das man damit auch wenn der Title beendet wird zu dem angesagten springt?

18:28:23.255 ->
18:28:23.392 -> 246 Dateien in Ordner 1
18:28:23.392 -> Album Modus -> kompletten Ordner wiedergeben
18:28:28.938 -> Track beendet257
18:28:29.041 -> Albummodus ist aktiv -> nächster Track: 2Track beendet258
18:28:35.415 -> Albummodus ist aktiv -> nächster Track: 3Track beendet259
18:28:38.313 -> Albummodus ist aktiv -> nächster Track: 4Track beendet260
18:28:41.210 -> Albummodus ist aktiv -> nächster Track: 5Track beendet261
18:28:44.284 -> Albummodus ist aktiv -> nächster Track: 6Track beendet262
18:28:47.182 -> Albummodus ist aktiv -> nächster Track: 7Volume Up
18:32:48.808 -> Track beendet1
18:32:48.910 -> Albummodus ist aktiv -> nächster Track: 8Track beendet8
18:36:49.526 -> Albummodus ist aktiv -> nächster Track: 9

Er hat Titel 1 gespielt, angesagt nach mehren drücken 7, und hat dann mit 8 weiter gemacht, als 1 beendet war?


#7

Wenn man 1x drückt gibt es die aktuelle Nummer. Wenn man öfter drückt sagt er die Tracks an die übersprungen werden.
Super, sollte man mit hineinschreiben.

18:47:19.445 -> Track beendet257
18:47:19.547 -> Albummodus ist aktiv -> nächster Track: 2Track beendet258
18:47:24.112 -> Albummodus ist aktiv -> nächster Track: 3Track beendet1
18:50:58.839 -> Albummodus ist aktiv -> nächster Track: 4Track beendet260
18:51:31.850 -> Albummodus ist aktiv -> nächster Track: 5Track beendet261
18:51:36.623 -> Albummodus ist aktiv -> nächster Track: 6Track beendet262
18:51:40.782 -> Albummodus ist aktiv -> nächster Track: 7Track beendet4
18:54:40.985 -> Albummodus ist aktiv -> nächster Track: 8

Track 1 gespielt, dann gedrückt bis zu hören war 3, er spielte dann mit 4 weiter.
Wieder gedückt bis zu hören war 7, er spielt nach dem 4 Track Nummer 8 usw…


#8

Das ist wohl eher ein Fehler der behoben werden sollte. Du drückst play/pause ja? Da sollte doch nicht zum nächsten Titel gesprungen werden oder übersehe ich hier grad was?


#9

Ja Play/Pause.

Ist ein gutes Gimmick wenn man weiß wie.

Aber er springt nicht sofort dahin, erst noch Beendigung des aktuellen Titles.


#10

also irgendwie ist dein DFPlayer glaube ich etwas daneben. Wo hast du den her?
Nexttrack sollte nicht getriggert werden bei der Advert Funktion die für die Ansage verwendet wird.


#11

es ist ein MP3-TF-16P von Voicemodul.

Aber diese Feature probiere ich gern mit dem DFPlayer Modul, hab ja genug davon.
Melde mich wieder.
Danke


#12

Ja da hast du völlig Recht gehabt.
Habe es mit einem DFPlayer Mini probiert und da läuft alles richtig.

Sachen gibts, also von mir falscher Alarm, sorry das ich dich beschäftigt habe.
Aber auch gut zu wissen das es doch Unterschiede bei den MP3 Playern gibt.
Eigentlich waren wir (Stephan und ich) uns zu 99% einig das die nur gelabelt sind.

Nun laß ich ersteinmal den DFPlayer auf dem Breadboard zum testen.
Danke


#13

Wir sammeln ja seit einiger Zeit Auffälligkeiten in der FAQ. Was für ein Chip ist unter dem auffälligen Modul? Und was für einer unter dem was funktioniert?


#14

Habe 4 Stück greifbar, auf keinen war irgendein Aufdruck, es sieht auch nicht aus als ob da je einer drauf war. Der Verstärkerchip 8002A.
Habe ich auch 2012 gekauft.

Soundmodul Multifunktion FN-M16P

Mo4 Soundmodul Multifunktion FN-M16P

Soundmodul Multifunktion FN-M16P

AKTION… preisreduziert
AUCH ALS 5er PACK ERHÄLTLICH
1 Modul, unendliche Möglichkeiten der Nutzung. Hier ein paar Highlites:
direktes Abspielen von MP3 Files
bis 32GB Karten werden unterstützt,
3 Watt Ausgangsleistung,
verschiedene Modi wählbar:
1-14 Files über 14 AD Key DIREKT,
1.000 Files über AD KEY (Player) und
100.000 File über SERIAL MODE abrufbar
volle MP3 Player Funktion
Datenblatt [KLICK]


#15

Mja, mit den ganzen Daten kann ich leider nix anfangen. Wenn der mp3 chip nicht beschriftet ist hilft uns das nicht weiter. Ich habe hier ein MP3-TF-16P (mit MH2024K-24SS) und das hat diesen Bug nicht. Dafür habe ich aber ein DFPlayer Mini (mit YX5200-24SS) womit ich das von dir beschriebene Verhalten nachvollziehen kann. Man sieht also weder auf die PCB Beschriftung noch auf das Chip Label kann man sich verlassen. Wir haben genau das gegenteilige Verhalten.


#16

Das jetzige pdf zeigt auch ein andes Modul.
Das abgebildete ist meins.

Hab hier noch das original pdf zum Modul.


#17

Wie gesagt. Einziger Anhaltspunkt ist (bzw. besser: wäre theoretisch) der Chip unten drunter und dessen Label. Wie wir aber mehr und mehr feststellen, gibt es doch reichlich Schwankungen. Irgendwelche PDFs sind Schall und Rauch wenn du einen Fake Chip in der Hand hast.

Von daher können wir da lange drüber schwadronieren, machen können wir aber leider wenig. Ausser die Software so anzupassen, daß sie möglichst alle “Eigenheiten” umschifft (sofern möglich). Wenn du funktionierende Module hast, empfehle ich dir diese zu nutzen oder aber die Trackansage Funktion zu ignorieren. :wink:


#18

Bezeichnung steht auch im pdf.

Module hab ich die funktionieren, danke.


#19

Wie gesagt. Das nutzt gar nichts wenn der Chip den du hast nich gelabelt ist. Gehe mal davon aus, daß das original richtig beschriftet ist. Wenn du also kein Label hast, hast du höchst wahrscheinlich kein original. Umgekehrt kannst du bei einem Chip mit Label aber auch nicht davon ausgehen, das du einen originalen hast - weil auch die kann jeder bedrucken. Verstehst du was ich meine? Ist ne Zwickmühle.

Achja, und wer garantiert, daß gerade das Original den Bug nich hat? :wink: Also von daher…


#20

Ich versteh dich 100%.
Aber danke das ihr mir bei dem ‘Problem’ geholfen habt.

Ich bin wieder etwas schlauer.
Danke nochmals.