Tonuino läuft nach Softwareupdate auf 3.1.4 nicht mehr

Kleines Update. Die Hörspiele laufen ganz normal nur im Admin Menü ist keine Audioausgabe vorhanden.
Echt komisch sieht wirklich so aus als könnte er die MP3 nicht lesen könnte? Woran könnte es liegen?
Habe auch die SD Karte schon mal neu formatiert.

Der Alte war der DF-Player Mini HW-247A
Mit dem neuen DF Player

Welche Bezeichnung steht auf dem größeren Chip auf der Unterseite? GD… irgendwas?
Mit TNG meine ich die Tonuino Software mit Version 3.x.x. wollte Verwirrungen zwischen Software 3 und Player mit v3 vermeiden

war mit der neuen Version 3.1.4. die ich vorhin drauf geladen habe.
Neuer DF Player
MH2024K-24SS
221107

Alter bzw vorher Benutzer DF Player
GD3200B
210410679F

Hattest du den Player HW247A mit der Software 3.1.4 betrieben?
Wenn ja, war die Ausgabe im seriellen Monitor die gleiche, wie die die du oben eingestellt hattest?

Die Software 3.1.4 bietet die Möglichkeit, die nötigen Änderungen für den HW247A zu aktivieren! Dazu musst die die Software aber mit Arduino IDE oder PlatformIO aufladen und vorher die constants.hpp entsprechend anpassen.

Ich kann es zwar nicht erklären, aber vielleicht ist das Problem ja analog zu
Probleme mit DFPlayer mini MH2024K-24SS - Hardware - TonUINO (voss.earth)

Der Fehler des Players ist auf jeden Fall der gleiche

Oje jetzt wird es kompliziert :slight_smile: SW anpassen kann ich leider nicht.
Mit dem neuen DF Player sollte es wohl eigentlich funtionieren?

Und wenn der Fehler mit dem alten Player HW247A auch aufgetreten ist, ist meine Vermutung, dass mit dem Inhalt der SD-Karte etwas nicht stimmt.
Daher meine Frage nach dem Output aus dem seriellen Monitor mit dem alten Player.

Wenn die Struktur auf der SD-Karte stimmt und die Karte nicht defekt ist, schon.

Das ist mit der 3.1.4 nicht schwer!
In der constants.hpp musst du in Zeile 35 nur die beiden // am Anfang löschen.

��ԕ
�U

�BRH[hR�@F���
 _____         _____ _____ _____ _____
|_   _|___ ___|  |  |     |   | |     |
  | | | . |   |  |  |-   -| | | |  |  |
  |_| |___|_|_|_____|_____|_|___|_____|
TonUINO Version 3.1 - refactored by Boerge1

created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

V3.1.4 16.11.23

Ver:2
Vol:25 5 15
EQ:1
ST:0
IB:1
AL:0
AP:1111
PCR:0
Volume: 15
MFRC522:146
enter Idle
Command: 6
enqueue mp3 262 0
play mp3 262
missing OnPlayFinished
Command: 1
enter AdmAllow
enter AdmEntry
enqueue mp3 900 0
play mp3 900
missing OnPlayFinished

So ist mit dem alten Player HW247A

Werden die Dateien 262 (das ist der Start-Pling-Ton) und 900 (herzlichen willkommen im Adminmenü) abgespielt? Der Fehler, dass die Dateien nicht gefunden werden, kommt auf jeden Fall nicht.

Nein kommt leider keine Audio Ausgabe. Außer die Hörbücher mit einer Karte laufen.

Dann schau doch mal nach ob auf deiner SD-Karte im Ordner mp3 eine Datei 0262.mp3 ist. Vielleicht fehlt die ja einfach. Oder teile mal wie deine SD-Karte befüllt ist.

Werde ich versuchen. Vielen Dank für den Tipp.
Muss jetzt leider los zum Training. Ich werde die Tage weiter machen.
Danke.
Darf auch keine Antworten mehr erstellen. Habe mein Limit als neuer Benutzer erreicht.

Das ist zwar etwas Aufwand aber versuch mal die Karte komplett neu zu bespielen!
Dabei die Ordner mp3 und advert als erstes und danach erst die Ordner mit den Hörspieldateien.

1 „Gefällt mir“

Habe nochmal alles versucht aber es kommt keine Ansage im Admin Menü. Neuste Software drauf geladen. SD Karte mit SD Card Formatter formatiert. Neusten SD karten Inhalt drauf geladen. Er spielt nur die Hörspiele an aber keine Ansagen. Auch andere SD karte probiert. Beide Player versucht. Es kommt nichts. Könnte ich noch etwas versuchen?

Vielleicht verstehe ich das falsch, aber heißt das, dass die Hörspiele nicht vollständig abgespielt werden, sondern nur starten und dann abbrechen?
Dann hätten wir nämlich noch eine Fehlerbeschreibung.

Den alten Player (HW427A) mit den für ihn nötigen Änderungen in der 3.1.4 Software testen:

und die Software per platformIO oder IDE auf den Arduino laden.

1 „Gefällt mir“

Die Hörspiele funktionieren ganz normal.

Gibt es eine Anleitug wie das hochladen mit IDE oder IO hochläd? Das habe ich noch nicht gemacht.
Den Sourcecode habe ich schon al runter geladen.