Tonuino does not produce any sound or reaction

alright! I finally did the serial monitor and this is the result, doing the following things: 1 put sd card (wrote nothing), press vol down, press vol up, press next, press previous, press and hold pause (only by pressing it wrote nothing).

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
0
Firmware Version: 0x92 = v2.0
=== playShortCut()
3
Shortcut not configured!
=== volumeDown()
14
=== volumeUp()
15
=== playShortCut()
2
Shortcut not configured!
=== playShortCut()
1
Shortcut not configured!
=== playShortCut()
0
Shortcut not configured!

I hope that helps find out something!!!
Many many thanks to you folks

Is there an output, when you put an rfid-tag on the reader?

No, reader doesn’t do anything

Maybe you can Take a Photo of the soldering of the Reader

1 „Gefällt mir“

:+1:

And of the whole setup!

1 „Gefällt mir“

:sweat_smile: I will!! I’m so sorry for the trouble. I really was so exited about this that it broke my heart not to make it work. I hope my daughter appreciates it

1 „Gefällt mir“

I am sure!!!

It Looks Like the second from left could be critical but i am Not a solder expert

The rfid-reader does not report a connection problem.

The behavior of the LED on the dfplayer seems unusual. It should just light up, when it is playing regardless of the power source.

Yes, this soldering does look like it could be a problem.
But it is not a problem, because there is not an issue with the reader…

Yes. That is what I thought too. This seems really weird.

@dabenza Could you test the dfPlayer by itself?

Connect IO_1 or IO_2 with GND. You should hear something. Your SD Card should be insert :wink:

Hi guys, sorry for the delay, but I’ve been banned for 14 hours :roll_eyes: I suppose for answering too soon or rapidly, forum rules.
I tried playing the dfplayer without the arduino. But it did nothing.
In the meantime I have ordered 3 more dfplayers… and i tried another one. The behaviour is different. When connected to power through the arduino, the LED blinked red (the old one didn’t do it). And when powered from the 5v pin behind the dfplayer, it did the same (the old one stayed red). The serial monitor gives the same output though. and still no music, no card reading… nothing. I’m thinking of wiring the system without the tonuino classic, in case there is a problem with that PCB board. As I’m very limited to publish freely, I’ll post another photo of the setup for you to check. I also had a look at the soldering points and worked on some of them, but they all looked goood to my eyes. I have soldered much more difficult things before, but no expert.

Ok, I set up the bread board with the schemes found on the web, but without buttons, just to check, and the result is the same. No sound, no rfid reaction. So the classic board is not the issue. ¿could it be software? Am I missing something?

And this is what I get from the serial monitor (the last lines I took out the sdcard and put it back)

 _____         _____ _____ _____ _____
|_   _|___ ___|  |  |     |   | |     |
  | | | . |   |  |  |-   -| | | |  |  |
  |_| |___|_|_|_____|_____|_|___|_____|

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
0
Firmware Version: 0x92 = v2.0
=== playShortCut()
3
Shortcut not configured!
=== volumeDown()
14
=== volumeUp()
15
=== playShortCut()
0
Shortcut not configured!
SD Karte entfernt
SD Karte bereit

Does something happen, when you press the buttons connected to A0, A1 and A2 at the same time for more than a second?

I loaded the tonuino software back without modifications (in case the 5 button option was making problem or the pololu option). So only vol up, down and play. Play up and down react, holding them for some seconds, i get:
1
Shortcut not configured!
=== playShortCut()

No sound, no rfid card reaction to a card nearby…

When I put power on the arduino, the dfplayer just blinks red at the very begining but no sound at all.

IMG_3858

Could It be that the speaker ist broken?

For testing the soundfunction, you can connect an earphone to the DAC-R and DAC-L pins to Ground. If you turn on the Tonuino you must hear a short sound like „Fiuuup“. If you hear that , the initialisation of the dfPlayer was succesfully. Usually you hear the same sound in the speaker too. For testing the speaker you can connect the speaker directly to a 1,5V AA cell for a very short moment. If the speaker is good, you hear a short tak tak sound and the cone will make a little move.
When i look your konsole it me seems, that the forward-button and the backward-button taking no information to the arduino, because it shows only shortcut 1 is not configured. Normally when you press all 3 buttons the same time for more than 1 second the adminmenü shell active and it speeks to you.

Hi guys! Good news. I’ve been reading all your messages thoroughly, and checking everything you say. This morning i started recording a video, because i could access to the menu with the new dfplayer, but cards did not work. While doing the video, i picket up a card to show how it did not work. And it worked. It was a card from a different set. I had a hundred cards that didn’t work and some few, bought from another place, that worked… First a bad player unit. Solved. Now, bad rfid cards. SOLVED!!
Tonuino is coming to life. I tried it with dac output to an amp, and works fine. I’ll do a stereo setup and I’ll be posting progress. So exciting!!
Thank you so much for all your help! I do appreciate it!
Will be back soon!

4 „Gefällt mir“