Hilfe benötigt beim LED Buttons verkabeln

in diesem post angepriessen wegen seiner größe und reichweite:

laut post zu 100% kompatibel

1 „Gefällt mir“

ah okay :wink: ist also ein kleinerer g

kannst du die lötstellen mal von oben fotografieren? man sieht die so schlecht durch die licht reflektion. am betsen mal das ganze board von unten ablichten.

genau

Ich habe ürbrigens jetzt erst bemerkt, dass 522 ja der RFID ist und nicht der DF Player…Ich…dussel

anbei mal die lötstellen vom jetzt wirklichen problemkind:

ich würde nochmal alle punkte nachlöten, nicht nur die vom rfid leser sondern auch die anderen… da können einige noch ein wenig zinn gebrauchen und manche haben ein wenig zuviel abbekommen, eventuell ist ja wo ne „kalte“ lötstelle und hat keinen kontakt

Schau dir am besten mal die in der #hardware FAQ verlinkten Tutorials zum Thema Löten an.

Ich glaub du hast die Kabel spiegelverkehrt angeschlossen. Zieh die mal alle ab und Dreh sie um180 grad.

Nein, die Kabel zum RFID-Player sind nicht verdreht (gut erkennbar: das blaue Kabel geht vom dritten Kontakt der Platine (GND) zu GND), die Kontakte müssen aber definitiv, insbesondere am Reader (MH-ET LIVE) mit mehr Lot nachgelötet werden.

Der steht ja auch unter strom, die kabel sind also schon korrekt. Ich hab nochmal nachgelötet aber es hat nichts gebracht. Tatsächlich hatte ich aber auch das Gefühl, dass sich der RFI Chip nicht so gut löten lässt wie Thorstens Platine…

Naja, vielleicht ist das Ding ja defekt?

Es sind nur rot und Orange am Reader also sck und Mosi vertauscht.

Aber wie schon von einigen gemeldet sind da einige Kalte Lötstellen drauf.

also Video ansehen und eigentlich alle Lötstellen auf Torstens Platine und am Reader nachlöten.
Immer mit frischem Zinn löten und eventuell vorher mit einer Lötpumpe absaugen. Ein Geübter kann auch mit einer sauberen Lötspitze dicke Zinknubbel vorher abnehmen, die Spitze säubern und dann mit Zugabe von frischem Zinn nachlöten. Ich nutze trotzdem gerne in solchen Fällen die Pumpe.


Wenn man den Newsletter dort anmeldet gibt es 5€ Gutschrift, die gleicht das Porto aus.

Bei einer guten Lötung haben beide zu verbindenden Teile die gleiche Temperatur zu haben, die das Zinn zum schmelzen bringt.
Gleichzeitig darf diese an unseren Bauteilen nur kurze Zeit anliegen, da sonst die Bauteile zerstört werden können.

Wenn die Lötstellen hinterher so wie auf dem Player aussehen dann ist alles gut.

1 „Gefällt mir“

So,

jetzt habe ich alle nochmal entlötet/nachgelötet. Fehlermeldung im Monitor ist weg.

dafür steht da jetzt aber gefälschter chip???
24

Das könnte einfach eine Meldung der RC522 library sein die darauf hinweist, dass es ein anderer Chip bzw. eben andere Firmware ist.
Geht es denn jetzt oder passiert einfach nichts weiter, wenn du eine Karte an den Reader hältst?

Ist es. Haben wir bisher eigentlich noch nie gesehen. Schon interessant. Noch interessanter wäre jetzt zu wissen, geht der Reader trotzdem? Sprich sind die benötigten Funktionalitäten vorhanden oder nicht.

Leider höre ich nichts, wenn ich die karte druf halte, daher kann ich auch nicht sagen, ob er funzt. Es sei denn, man würde das an einem blinken der LED des RFID erkennen, dann könnte ich sagen, dass nichts passiert, weil die immer durchgängig leuchtet.

Ich hab jetzt nochmal den RFID aus Thorstens anleitung bestellt und probiere damit nochmal, wenn er da ist.

Allerdings funktioniert zumindest mal das abspielen und pausieren, sowie lauter und leiser beim lange gedrückt halten. Allerdings nicht vor und zurück. Das ist seltsam

Wie kann das denn sein?

@Peer

Eine Frage zum Vorwiderstand. Brauche ich den bei diesen LED Buttons überhaupt? Die LED Lichtspannung beträgt 12V bei denen, der Nano lässt doch aber nur 5V durch, oder?

Also ich hab mir das Ding ja als erster geholt gehabt ( hatte den Threat verfasst) und ich hab das ding ohne Fehler oder der Gleichen zum Laufen gebracht. Kein libraryfehler oder sonst was. Die Karten werden erkannt ( ohne Material dazwischen ca ab einer Entfernung von 3-4 cm)

Bei dir sagt er nicht counterfeit?

nein.er zeigt die ganz normale Ausgabe

Ggf. liegt dann hier doch noch ein Verkabelungsproblem vor, Wackeliger oder irgendwie sowas…

 _____         _____ _____ _____ _____
|_   _|___ ___|  |  |     |   | |     |
  | | | . |   |  |  |-   -| | | |  |  |
  |_| |___|_|_|_____|_____|_|___|_____|

TonUINO Version 2.1 + mods by McGreg
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 2
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
Admin Menu locked: 0
Admin Menu Pin: 1111
=== setstandbyTimer()
0
Firmware Version: 0x12 = counterfeit chip
=== playShortCut()
3
Shortcut not configured!
ReadCardSerial finishedCard UID: F9 F9 3E 59
PICC type: MIFARE 1KB
Authenticating Classic using key A...
Reading data from block 4 ...
Data on Card :
 13 37 B3 47 02 01 01 1C 24 00 00 00 00 00 00 00

1
1
Neue Karte== playFolder()
=== disablestandby()