Box stoppt nach einem Titel

Hallo,
Ich habe das Problem, dass die Box immer nach einem Titel stoppt. Egal ob Partymodus oder Hörbuchmodus. Insgesamt habe ich 3 Boxen gebaut, wovon alle 3 das gleiche Phänomen aufweisen. Alle haben 16Gb Speicherkarten verbaut. Die aktuelle Test-Box die ich zum testen nehme, hat die Software 2.1 gekriegt. Setup ist mit 5 Tasten. In der Console kriege ich keine Fehlermeldung oder ähnliches. Liest die Karte ein, erkennt den Modus und startet den Titel. Nach dem Titel tut sich nichts mehr. Play startet dann den nächsten Titel. Hab die SD-Karte mehrmals formatiert und mittlerweile die mp3 Bezeichnung nur noch auf Nummern reduziert. So langsam gehen mir die Ideen aus. Kann es vielleicht noch an der Speicherkarte liegen? Oder irgendwas mit dem DFPlayer? Habe alle Teile von AZDelivery gekauft.
Ansonsten ist der Player über eine externe Platine und ein mehrpoliges Kabel mit dem Controller verbunden. Mangelhafte Lötstellen würde ich ausschließen, da ich gelernter Elektroniker bin und weiß wie schlechte Lötstellen aussehen. Es ist nur komisch, dass alle 3 Boxen das selbe machen.
Am Player ist noch ein Kopfhöreranschluss angelötet.
Habt ihr eine Idee woran es liegen könnte?

Welchen Player hast du denn? In der FAQ sind ja bei einigen Problemberichte verlinkt.

Ansonsten könnte es helfen, wenn du die Ausgabe der Konsole trotzdem mal teilst. Es gibt ja auch andere Auffälligkeiten als nur Fehlermeldungen des Players.

Das kann ich leider nicht sage, da der Chip ja auf einer Platine verlötet ist und da kann ich nicht mehr drunter gucken. Könnte aber sein, dass ich noch einen Player aus der gleichen Lieferung habe. Muss ich mal suchen.
Consolenausgabe poste ich nochmal separat.

Ich hatte mal das gleiche Phänomen. Das lag daran, dass sich eine Datei auf der SD-Karte befand, dir dort nicht hingehört.

Schau vielleicht mal die SD durch oder probiere eine mir nur einem Ordner.