Batteryshield v8 + Thorstens Platine + Auto Off?

hm. okay. Dann müsste ich also zum Einschalten einen extra Taster/Schalter einbauen, der nicht kapazitiv ist. Danke für den Hinweis.
Scheint leider schwer zu sein einen Lieferanten für den Pololu Switch zu finden, der vor Weihnachten noch liefert.

Welche version vom V8 Shield hast du denn? die mit Schalter oder die mit Taster?

Die mit Taster und zwei Batterien.

Also die neue Version… und derzeit schaltest den TonUINO mittels taster an? Im Prinzip solltest Du das Auto Off auch mit einem 5V Relais realisieren können… das durch den Arduino aktiviert wird und das V8 shield wieder ausschaltet.

Etwa so:

1 „Gefällt mir“

@Beno82:
Das wäre ja cool. Also Einschalten über den Taster und Ausschalten mach das Relais?
Ist dann der Ausgang P? der hier in der DEV-Software als ShutdownPin bezeichnet wird also standardmäßig 7?
digitalWrite(shutdownPin, HIGH);

Was ist das für ein Relais und weißt du zufälligerweise wo man das mit schneller Lieferzeit bekommt? Oder ist das Relais schon auf dem Aduino/ Thorstens Platine vorhanden?

Hier ist übrigens schon ein Thread zum V8 Shield:

was zu testen wäre ist ob die Spannung schnell genug vom Arduino weg ist und das Teil nicht gleich wieder Ein schaltet. Ansonsten wäre das ein günstiger Weg für den Auto-Off Modus

Am schnellsten bekommst du so ein Relais wohl beim Conrad etc… ist ein stink normales Relais das halt mit 5V betrieben wird.
Ja in deinem Fall dann P7 wenn das so in der Software steht, wusste den Pin nicht auswendig deshalb das „?“.

@Beno82: Der Taster hat 4 Beinchen. Wenn ich hier mein Relais anschalten muss, dann gehe ich auf die beiden inneren Beinchen, richtig?
Genauso mit meinem eigenen Taster den ich nach außen legen möchte, damit das Kind nicht am Batteryshield rumfummeln kann.

Beim Battery Shield sind es die 2 Pin’s die nicht am Blech rund im den Taster enden (sollten die inneren beiden sein)

Hier ist ein Relais für den Arduino, das klappt sogar mittels Signal Pin, und mit Amazon wohl auch an 1 Tag da :wink:

lG

1 „Gefällt mir“

Sehr gut. Habe ich mir soeben bestellt. Dh. auf der rechten Seite schließe ich D7 an Signal Line S an.
Strom brauche ich nicht oder?
Wenn doch, dann den Strom vom 5V Ausgang des Batteriyshields V8, oder?

Auf der linke Seite dann die beiden Pole von dem Taster des Batteryshields. Aber zwischen welche?
Mit den Beschriftungen kann ich so nichts anfangen. Die Pole lauten:

  1. Normally Closed
  2. Middle Pin
  3. Normally Opened

Um das Batterie Shield V8 auszuschalten muss ich den Taster sonst zwei Sekunden drücken.

Doch Spannung brauchst du.

Einfach 5v vom shield nehmen.

Den taster solltest du MID und NO anschließen.

Lg

1 „Gefällt mir“

Ich danke Dir! :pray:
Ich werde es am Wochenende wenn alle Teile da sind umsetzen!

Gutes gelingen. :slight_smile:

1 „Gefällt mir“

@Beno82: Ich hab den Taster versucht rauszulöten und gegen eine Stiftleiste ersetzt. Wenn ich nun die beiden Kontakte kurz mit einem leitenden Draht verbinde, dann leuchtet die LED des Batterieshield V8 nicht mehr wie zuvor auf. Ist mein Stiftleiste falsch eingelötet (sieht okay aus für mich) oder habe ich das Prinzip des Tasters falsch verstanden. Ich habe die beiden inneren PINs miteinander verbunden.
Hier auch Fotos der Vor- und Rückseite


Sieht für mich richtig aus, hättest Du aber nicht tun müssen sondern einfach ein Kabel unten dran löten. Die Taster/Schalter gehen ziemlich besch… raus hab mir auch schon ein V8 Shield damit geschrottet bzw. musste die Bahnen umlöten.
Versuch mal ob eventuell das Zinn nicht bis oben hin gekommen ist.
Also noch mal anheizen und schauen ob das Zinn durchzieht.

1 „Gefällt mir“

:frowning: Tja. Habe wohl beide Batteryshields vernichtet. Bei dem Ersten habe ich den Taster vorsichtig ausgelätet und PINs eingesetzt. Leider scheinen diese aber soviel ich es auch versuche keinen Kontakt zu bekommen.
Bei dem zweiten Batteryshield habe ich von der anderen seite des Tasters zwei Pins angelötet. Ich hatte nicht mehr als 1 Sekunde eher weniger Kontakt mit den Lötstellen. Trotzdem funktioniert seit dem der Taster nicht mehr. Mein Gott wie empfindlich ist der der bloss eingebaut. :frowning:
Jm. ne Idee wo man an dem Boards die Kontakte noch abgreifen kann?
Aktuell sieht es so aus als ob mein Weihnachtsgeschenk nicht mehr fertig werden wird. :cry:

Bei den mit taster leider nicht, hab die Version mit Schalter „gerettet“.

Der Normale Taster ist auch nicht mehr funktionstüchtig beim 2ten Board?

Ja die Teile sind qualitativ nicht der Hammer, die Leiterbahnen sind schnell ab.

Aber wenn du nur 1 Sekunde auf den Lötstellen warst, bist Du sicher das die Kontakte bestehen, die 2 Lötpunkte schauen sehr Bummelig aus :wink:

Ne die Variante auf dem Foto ist die wo ich den Taster entfernt habe. Da hat das Board ne Menge Hitze abbekommen. Aber beim anlöten war ich super vorsichtig.

Puh schwer zu sagen, aber wenn Du sagst es geht nicht mehr, ist der Kontakt vermutlich flöten gegangen.

Das es beim 2. Board mit den Lietzen am Taster nicht klappt finde ich komisch.

@helipus WICHTIG: Du musst einmalig ein Ladekabel anschließen damit Du das V8 Shield einschalten kannst.

Dürfte wohl ein Bug sein.

2 „Gefällt mir“