TonUINO - Fehlersuche

Danke:
So nun bin ich auch bei meinem ersten Tonunio. Hier mal danke für all die Mühe von Thorsten und allen anderen die hier so fleißig dran sind.

Ausstattung:
Ich habe mir die Platine (danke) und die Kopfhöhrer Platine bestellt.
Acard Buttions
Set von AC Delivery

Vorgehensweise:
ich habe beim einschalten leuchten zwei LED vom Arduino aber ich habe keine reaktion auser ich schalte lauter oder leiser Buttion

Ich habe nun über den Seriellen moitor im IDE herausgefunden das die Version zumindest richtig geflashed wurde >> fehler behebung war richtige Schnittstelle unter linux einstellen USB0 oder USB1

Fehler: [
– MFRC522 properly connected …>> behebung tja gebe es zu zwei kabel vertauscht

Kein Ton (leider noch keine Lösung)
– bis jetzt probiert pin belegung überprüfen
– durchmessen ob die lötstellen korrekt sind
– andere Box als alternative oder kopfhöhrer getestet
– speaker direkt an die Platine ohne die Kopfhöhrerplatine (leider auch kein Ton)

?? leider noch keine Lösung gefunden

3 Acard Knopf zeigt im Seriellen Monitor nichts an? ist das normal?

Hat vielleicht wer von euch eine Idee was ich falsch mache oder noch überprüfen kann?

Hi,

Die SD Karte ist korrekt bespielt?

Was kommt denn in der Konsole wenn du eine Karte auflegst?

SD karte habe ich die ordner vom Github und dann ODRNER 01 mit Dattei.mp3 ohne leerzeichen

Wen ich die RIFD Karte daurf lege habe ich gar keine raktion ;(

RFID: habe jetz tnochmal die Karte aus dem set von AZ Delivery genommen und es kommt in der Konsole - neue Karte konfigurieren TonUnijo
– aber immer noch kein Ton
– d.h. wohl das die von aliexpress bestellten nicht funktionierten

Poste doch bitte die komplette Ausgabe!

Hi,

Der DFPlayer bietet die Möglichkeit ihn per Taster zu steuern, dazu einfach GND mit IO_1 oder IO_2 kurz brücken, dann weiss man zumindest ob der Player spielen würde. Damit wäre dann glaube ich der Lautsprecher und auch die SD-Karte geprüft.

VG
Chris

erst mal danke für die bisherigen antworten

@Thorsten leider kriege ich nicht mehr infos aus dem IDE Monitor
@Christoph84 ich habe es versucht nach dem DFB Pinbelegung anzuschließen keine Reaktion mit GND mit IO1 meinst du einfach einen buttion oder via direkt mit „jumperkabel“ überbrücken ?

Box ist auf jedenfall ganz habe sie getestet - an sterioanlage (nicht noble lösung aber dazugehängt)

  • Ich sehe auch kein Licht beim DFB Player (gibt es hier eine LED?)
  • aus meiner sicht gibt es irgendein problem mit dem DFB Player - haber hier 5 Stück rumliegen von DZ Delivery und Aliexpress und keiner zeigt mir eine LED Leuchtend an
  • Speicherkarte hat sicher nur die Ordner oben habe ich überprüft und fat formatiert (unter linux)

Einfach direkt per Kabel überbrücken. Wenn du dann nichts hörst, würde ich auf SD-Karten-Probleme oder defekten Lautsprecher/DFP tippen

@Christoph84
danke habe jetz tmal den player direkt an den adruinio gehängt und wie du gesagt hast und voila
led leuchtet und er spielt die dateien ab wen ich es direkt in kontakt bringe
d.h. für mich verbindungen arduino und player nochmal bei den steckkontakten der Platine neu löten und schauen woran es hängt
die nächsten tage werde ich mal mich dran machen danke für die Rückmeldung

@cma0815: Ich möchte dich bitten, in Zukunft etwas mehr große Buchstaben und Satzzeichen in deine Postings zu streuen. Das macht es für alle einfacher. Danke @stephan.

So danke auch für die Rückmeldungen.
Inzwischen funktioniert der Kopfhöhreranschluss. Jetzt muss ich nur nochmal durch und die Verbindung mit dem Lautsprecher testen :-D.

Ein Freund hat mit mir nochmal durchgeschaut und auch angeregt mit mehr Temparatur zu löten und auch die kalten Löststellen und generell alles nochmal durchzugehen.
Tja - und siehe da Kopfhöhrer funktioniert.

D.h. soweit mal gelöst. Danke nochmal für die Rückmeldungen und Hilfe.

1 Like

so nun funktioniert es

– bespielen der Karten mit App tonunio und dem NFC vom Handy

  • vorher hatte ich nur Probleme mit Handy ging es tip top und Karten funktionieren
  • kopfhöhrer Platine (eventuell für FAQ) der Thorsten denkt schon mit beim designen und macht die PINS so das sie Ground (beschrieben) von da in der gleichen Reihenfolge auf der Platine vom Tonunio und von der Kopfhöhrer Platine sind

wichtig war hier für mich: die Kopfhöhrer Buchse auf der richtigen Seite auflöten. Hier wieder danke

@Thorsten du hast sie eh mit tixo fixiert :smiley: aber ich habe es bei einer trotzdem geschafft im Eifer des gefechts sie mal falsch zu löten

– einzige Sache jetzt noch: beim Auflegen der Karten spielt der Tonunio nicht automatisch ab sondern muss immer wieder der Play Button gedrückt werden 1x sonst bin ich zufrieden danke. Hat das eventuell mit dem Modus zu tun? oder mit dem Error 6 den ich teilweise bekomme

Das ist nicht normal.

Nein. In jedem Modus wird automatisch los gespielt.

Möglich. Com Error 6 heisst halt Datei nicht gefunden. Das ist in keinem Fall normal und sollte abgestellt werden.

PS: Die Kopfhörerplatine ist von @HiSEBA.

Spät aber doch antwort.
Dann geht mein danke an @HiSEBA für die Platine

Also ich habe jetzt nochmal alles durchgeschaut und auch die SD Karte neu beschrieben.
Die ordner werden gefunden und mit der RFID Karte erkannt (habe sie über das Handy beschrieben) .
Einziges Problem ist das wen ich die Karte einlese - bekomme ich auf dem Monitor IDE -> COM 6 Error udn sobald ich aber den Buttion 1 Drücke spielt er ab.

Genaue Ausgabe z.B:

42 Dateien in Ordner 5
21:18:38.992 -> Hörbuch Modus -> kompletten Ordner spielen und Fortschritt merken
21:18:40.154 ->
21:18:40.154 -> Com Error 6

Dann drücke ich Play /Buttion 1 und voila spielt ab

Bereits habe ich probiert:

  1. die karte überprüft keine Leerzeichen und er spielt ja alle Dateien ab sobald ich Buttion 1 drücke
  2. habe ich dann die buttions überprüft auch diese ausgetauscht.
  3. ich habe auch den MP3 Player ausgetauscht um zu schauen ob es an diesem liegt.
  4. probiert was passiert wen ich ogg oder ma4 dateien spiele (hier stürtzt der Player ab) somit passen die mp3

ich kann ja mit dem Problem leben aber da ich weis das es nicht normal ist wundert es mich trotzdem.

Meine Überlegung ist: gibt es einen PIN der nach dem Einlesen - Play weiter gibt an den Player (das heißt ich müsste eventuell diese Lötstelle überprüfen?).

EDIT: nachdem ich jetzt eine zweite vollständige Platine gelötet habe (klingt nach viel arbeit, aber mehr haben diejenigen die die Platine gemacht haben getan). Selber Error somit werde ich jetzt nochmal versuchen die Tage die Speicherkarte auszutauschen. Habe gerade keine andere da.

Kann es sein, dass die Dateien im Ordner nicht 001.mp3,002.mp3, … heißen?

1 Like

Danke @Thorsten ich habe das immer so gelesen das sie 01;02; … heisen müssen
jetzt nochmal umbenannt und geht.

Tja danke für eure Geduld und muss schon sagen habe jetzt durch die Fehlersuche viel gelernt.

Das ist jetzt nicht dein Ernst…

Was kann man da falsch verstehen?! Bitte erkläre es mir, dann passe ich die FAQ an. Danke.

1 Like

@stephan leider doch mein ernst. Sorry dafür.
Hat überhaupt nichts mit der FAQ zu tun. Ich habe es schlichtweg überlesen. Sei es Legastenie oder einfach zu schnell Rückschluss gezogen.

Die FAQ und dessen Erklärungen sind mehr wie passend. Wie gesagt einfach untergegangen.

:see_no_evil:
@stephan ich glaube wir sollten an der Stelle in der FAQ noch ein/zwei Screenshots von den Verzeichnissen einbauen.

Ich habe noch ein/zwei Beispiele aufgenommen. So bleibt das jetzt erstmal.