Lautstärke beim Start wird nicht gespeichert


#1

Hallo zusammen,
nach dem Neustart ist der Tonuino zu laut.
Habe mal im Setup die initVolumen auf 6 runter gesetzt.
Bringt leider nicht den Erfolg.
Was muss ich machen?


#2

Manuell im Sourcecode geändert oder über das Adminmenü?


#3

Gleiche Frage :wink:
Mach es mal übers Admin-Menü. Je nach dem wo du es geändert hast, wird es nicht übernommen, sondern die (für dich “falschen”) Einstellungen aus dem Speicher geladen.


#4

Hi Stephan,
manuell im Sourcecode


#5

Das ist eigentlich (aus den von @nanos genannten Gründen) so nicht mehr vorgesehen. Bitte ändere den Wert über das Adminmenü.


#6

Im Admin_Menü hatte als erstes 5 Eingestellt. Wird aber beim Neustart nicht übernommen steht dann bei 15


#7

Also hier die 15 lassen ??

void resetSettings() {
Serial.println(F("=== resetSettings()"));
mySettings.cookie = 322417479;
mySettings.version = 1;
mySettings.maxVolume = 25;
mySettings.minVolume = 5;
mySettings.initVolume = 6 ;
mySettings.eq = 1;
mySettings.locked = false;
mySettings.standbyTimer = 0;
mySettings.invertVolumeButtons = true;
mySettings.shortCuts[0].folder = 0;
mySettings.shortCuts[1].folder = 0;
mySettings.shortCuts[2].folder = 0;
mySettings.shortCuts[3].folder = 0;
writeSettingsToFlash();


#8

Die Funktion wird nur einmal aufgerufen. Danach erkennt der TonUINO das schon Settings im Flash sind und stellt die wieder her. Das ändern in der Funktion hat dann keinen Effekt mehr. Entweder du änderst es über das Adminmenü oder du löscht die Settings (alle Buttons beim einschalten gedrückt halten - Achtung es geht auch der Fortschritt des Hörbuch Modus verloren). Wenn du dann VORHER in resetSettings() die Werte änderst, werden die einmalig übernommen…


#9

Es wird immer verrückter.
Nun finder der Mac die USB vom nano nicht mehr
50

Port findet er nur den Bluetooth Port.
Welcher Bootloader muss eingestellt sein.
Gute Nacht


#10

Bei mir sieht es so aus:


#11

Habe ja zwei Tonuino, ruck zuck vom Enkel den Koffer geholt, angeschlossen und mit Start der Edi oh Wunder geht der weite Tonuino am meinem Mac. Scheinbar hat sich der Arduino Nano verabschiedet. Gibt es einen RESET aller DATEN?


#12

Alles wieder gut!
Mein USB Kabel war ein Zwilling. Und scheinbar ist ein Stecker nur für die Spannung, ausgerechnet den habe Ich I… genommen. Danke noch mal für die Antworten.


#13

Hallo Gemeinde,
ich habe immer noch keine Ahnung was da falsch läuft.
Mein Problem.
Nach dem Neustart (Spannung ON) des Tonuino startet er mit Lautstärke 15 und mein kleiner Leon erschreckt sich jedes mal. Auch wenn ich vorher alles Einstellungen im Admin Menü (Start Vol) auf 5 Eingestellt habe. Starte ich den Monitor reduziert sich die Lautstärke auf die Werte wie ich sie im Admin-Menü eingestellt habe. Ich brauche mal ein Tipp von Euch was ich falsch mache.


#14

Hallo Gemeinde,
Mein Problem:
Nach dem Neustart (Spannung OFF-ON) des Tonuino startet er mit Lautstärke 15 und mein kleiner Leon erschreckt sich jedes mal. Er lässt sich auch nicht leiser machen. Auch wenn ich vorher alle Einstellungen im Admin Menü (Start Vol) auf 5 Eingestellt habe.
Starte ich den Monitor reduziert sich sofort die Lautstärke auf die Werte wie ich sie im Admin-Menü eingestellt habe. Ich brauche mal ein Tipp von Euch was ich falsch mache.
Da ich ja zwei Tonuino habe, habe ich mal die zwei verschiedenen Monitore ausgedruckt.
Beim Ersten klappt es und beim Zweiten gibts das Problem.
Beide haben die gleiche Software bekommen.
img-190201211110


#16

Bitte keine zwei Threads mit dem gleichen Thema starten.

Hast du bereits versucht beim Starten alle drei Buttons zu drücken um den Speicher zurückzusetzen? Danach müssten nämlich die Einstellungen neu geschrieben werden. Du hast ja bereits im Quelltext die initiale Lautstärke auf 6 gestellt, diese müssten nach einem Reset eigentlich funktionieren.


#17

Die drei Butten war das Erste was ich versucht habe. Leider ohne Erfolg


#18

Frage: was ist denn mit den anderen Settings? Verstehe ich es richtig, dass er gar nichts abspeichert?

Schick mal bitte die Ausgabe vom Monitor während du die Lautstärke im Admin Menü einstellst.


#19

Funktioniert der Hörbuchmodus (Speichern des Fortschritts)?


#20

Blockquote
Owen das hat leider nicht geklappt, sagt die nette Stimme.


#21

Hi Thorsten, hi nanos,
Die Karte lässt sich auch starten obwohl die Speicherung im Hörspielmodus misslungen ist.
Hier das Monitor Protokoll:

 _____         _____ _____ _____ _____
|_   _|___ ___|  |  |     |   | |     |
  | | | . |   |  |  |-   -| | | |  |  |
  |_| |___|_|_|_____|_____|_|___|_____|

TonUINO Version 2.1
created by Thorsten Voß and licensed under GNU/GPL.
Information and contribution at https://tonuino.de.

=== loadSettingsFromFlash()
Version: 1
Maximal Volume: 25
Minimal Volume: 5
Initial Volume: 15
EQ: 1
Locked: 0
Sleep Timer: 0
Inverted Volume Buttons: 1
=== setstandbyTimer()
0
Firmware Version: 0x92 = v2.0
=== playShortCut()
3
Shortcut not configured!
Card UID: B9 EF 15 2B
PICC type: MIFARE 1KB
Authenticating using key A...
Current data in sector:
   1      7   00 00 00 00  00 00 FF 07  80 69 FF FF  FF FF FF FF  [ 0 0 1 ] 
          6   00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  [ 0 0 0 ] 
          5   00 00 00 00  00 00 00 00  00 00 00 00  00 00 00 00  [ 0 0 0 ] 
          4   13 37 B3 47  01 03 02 00  00 00 00 00  00 00 00 00  [ 0 0 0 ] 

Reading data from block 4 ...
Data in block 4:
 13 37 B3 47 01 03 02 00 00 00 00 00 00 00 00 00

=== disablestandby()
66 Dateien in Ordner 3
Album Modus -> kompletten Ordner wiedergeben
=== volumeDown()
14
=== volumeDown()
13
=== volumeDown()
12
=== volumeDown()
11
=== volumeDown()
10
=== volumeDown()
9
=== previousTrack()
Albummodus ist aktiv -> vorheriger Track
=== previousTrack()
Albummodus ist aktiv -> vorheriger Track
=== volumeUp()
10
=== volumeUp()
11
=== volumeUp()
12
=== volumeDown()
11
=== volumeDown()
10
=== setstandbyTimer()
0