#error "This library needs at least a C++11 compliant compiler"

#1

Hallo zusammen

Ich bekomme beim compailer immer diese Meldung:
#error “This library needs at least a C++11 compliant compiler, maybe compiler argument for C++11 support is missing or if you use Arduino IDE upgrade to version >=1.6.6”

Lib ist diese: MFRC522-1.4.3.zip

jemand eine Idee?

0 Likes

#2

Welche Arduino Version hast du denn? Hast du die aktuelle von der Arduino Homepage runtergeladen? Hast du die MFRC522 Library über die Arduino Bibliotheken Verwaltung installiert?

0 Likes

#3

Hallo Stephan

Danke für die schnelle Antwort.

Ja ist die IDE 1.8.9 und die MFRC Libary habe ich über die Verwaltung installiert (1.43)

Gruss

0 Likes

#4

Hm hab ich noch nie gehabt das Problem. Vielleicht hilft dir das hier weiter:

0 Likes

#5

Hallo Stephan

Danke für die Antwort. Leider hilft auch das nicht.

Gruss

0 Likes

#6

Ich kann den Fehler nicht nachvollziehen. Ich habe gerade auf die v1.8.9 upgedated und die MFRC522 Library frisch installiert. Es kompiliert ohne Probleme.

Was für Hardware hast du genau? Hast du alles richtig für die Hardware eingestellt in der IDE? Kompilieren andere Sketches normal?

0 Likes

#7

Nur zur Sicherheit frage ich noch mal nach: du hast alles aus der FAQ beachtet, insbesondere die Arduino-Umgebung nicht aus den Windows-Store installiert, sondern direkt von der Arduino-Seite? (geht aus der letzten Antwort von dir nicht ganz klar hervor).

0 Likes

#8

Danke an alle. Hat sich erledigt. Habe es nun mit einem anderen PC gemacht.

0 Likes

#9

Und woran hat es nun gelegen?

0 Likes