DFPlayer spielt keinen Ton


#1

Ein freundliches Hallo an alle Tonuino Freaks,

Erst einmal ein Großes DANKE an Thorsten für das super Projekt.

ich bin neu im Arduino Business aber technisch nicht ungeschickt. Handys, Macs, Playstation alles schon repariert. Aber der DFPlayer treibt mich noch in den Wahnsinn :tired_face:

Folgendes Problem:

Ich hab alles nach Schaltplan verdrahtet, bis auf die Buttons die sind derweil noch nicht aus China eingetroffen. Aber ich bekomme keinen Sound :frowning:

Folgendes habe ich in gefühlten 5h schon probiert:

SD Karte an verschiedenen Betriebssystemen formatiert (Mac und Windows) FAT und FAT32
Zich verschiedene Ordnervariationen
Unterschiedliche MP3
DFPlayer Standalone
DFPlayer mit 3,3 Volt und 5 Volt
Direkt verkabelt und mit Breadboard
Lautsprecher 4Ohm 3 Watt und Kopfhörer
Anderer Sketch (Musikplayer) auf Arduino
Unterschiedliche Stromquellen

2 verschieden DFPlayers
Hier ist mir aufgefallen, dass der von Banggood eine blaue Status LED hat und der von AZ Delivery eine rote. Laut Google sei der mit der Roten LED ein Fake! Stimmt das?

Was mir auffällt ist, dass der DFPlayer mit der roten LED dauerhaft leuchtet was der mit der Blauen LED nicht hat. Eigentlich lautet die LED doch nur wenn ein Track abgespielt wird oder?!

Ich sehe gerade im Bild schaut es so aus als ob der GND vom DFPlayer an 5V angesteckt ist, der ist natürlich auf GND :slight_smile:

Vielen Dank und Beste Grüße
David


#2

Was sagt der serielle Monitor beim Abspielversuch?


#4

Hi nanos das ging aber flott :slight_smile:

erst einmal danke für die schnelle Antwort.

Darf ich den Nano auch an USB anstecken, wenn ich die Komponenten über das Netzteil mit Strom versorge?


#5

Eigentlich sollte der Arduino in der Lage sein, die Komponenten zu versorgen. Also Netzteil abziehen und Arduino an USB anklemmen.


#6

ok gerade probiert es kommt Com error 1!
Das hab ich hier im Forum schon mal gelesen, da war es die Formatierung der SD Karte, aber leider hat er nicht geschrieben, was für eine Formatierung er benutzt hat.


#7

FAT (nicht exFAT). Karte nicht größer als 32GB. Ordner 01-99 + mp3 + advert. In 01-99 Dateien die mit 001, 002, 003 etc. beginnen.


#8

Fat32 mit Windows
VG


#9

Hi Stephan

Hi Erni

Die Komponenten werden jetzt direkt über den USB Laptop versorgt.

Karte hat 16GB

Habe ich schon probiert, FAT und gerade wieder FAT32

Root:
/mp3
/advert
/01/001.mp3
/02/001.mp3


#10

Ich hatte am Anfang auch so einen Fehler. Bei mir lag es scheinbar daran, dass Schnellformatierung nicht ausreichend war. Langsam formatiert und danach ging es. Warum auch immer…


#11

Hi DasMoeh

Habe ich zwischendurch auch schon probiert, aber jetzt schon länger nicht mehr.

Werde ich gleich testen.

Danke


#12

Leider ohne Erfolg :frowning:

Wenn ich den Play/Pause Pin mit GND verbinde, wir mir

Com Error 1
Karte resetten…
angezeigt!

Könnte es auch damit zusammen liegen, dass ich den Treiber für CHG340G/CHG341G Chip nicht installiert habe, oder würde dann ein Fehler kommen beim Sketch uploaden?


#13

Dann hättest du schon vorher Probleme gehabt.
Du hast geschrieben das du die dfplayer standalone getestet hast und das schon nicht geklappt hat, dann ist der Fehler doch eindeutig auf der Seite. Der Arduino scheint ja soweit zu funktionieren.


#14

Hi Christopher,

hab die Installation jetzt nachgeholt bringt leider auch nichts.

Seitdem ich die Komponenten direkt über den USB vom Arduino versorge leuchtet die LED vom DFPlayer nicht mehr.

Die Button Befehle kann ich im Monitor auslesen, die funktionieren.


#15

Hab mit dem seriellen Monitor noch etwas getestet.

Der Com Error 1 kommt immer noch

Er erkennt allerdings die RFID Karten und wenn ich die SD Karte entferne und wieder einfüge.


#16

und bitte keine anderen Ordner auf der Karte lassen.


#17

Hi Thorsten,

es sind keine zusätzlichen Ordner auf der Karte.

Danke


#18

Habe nochmals ein paar Sachen getestet.

Direkte Verbindung von Arduino zum DFPlayer per Kabel also ohne Breadboard
Anderen Arduino Nano
Anderen DFPlayer

Über den Seriellen Monitor:

Wird erkannt wenn eine RFID Karte vor dem NFC gehalten wird.
Die Buttons werden erkannt
Es wird erkannt, wenn die SD Karte entfernt und eingesetzt wird.

Der DFPlayer leuchtet wenn er mit dem Arduino verbunden ist nicht.

Standalone leuchtet der DFPlayer dauerhaft wenn ich ein externes Netzteil anschließe.

Kann es an der SD Karte liegen? Ist eine Samsung 16GB

Alles leider ohne Erfolg :frowning:


#19

Wenn Du die Pause Taste drückst, müssteglaub ich der DFPlayer kurz blau/rot leuchten.
Also immer wenn er was abspielt.
Am Lautsprecher kanns nicht liegen? Tut der auf jeden Fall?
Evtl die Initiallautstärke einfach zu leise?
Hast Du die DEV Version oder die Stable geflashed?

Lautsprecher 4Ohm 3 Watt und Kopfhörer

ABer nur zum testen?
Also nicht das der Kopfhörerausgang die Ausgabe an den Lautsprecher blockiert.
Lautsprecher ist auch definitv richtig angeschlossen?


#20

Also am DFPlayer sollte die LED nur leuchten wenn ein mp3 abgespielt wird.


#21

Hi Barni,

er reagiert eben auf gar nichts ;-( Beim anschalten des Arduinos macht der Lautsprecher nur einen kurzen Pieps.

Hab die Stable geflashed.

Lautsprecher läuft hab ich mit Handy getestet. Kopfhörer hatte ich nur zum Testen anstelle des Lautsprechers verwendet. Aber der DFPlayer leuchtet erst gar nicht in Verbindung mit dem Arduino.